Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое заполнение ячейки с условием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение ячейки с условием (Формулы/Formulas)
Автоматическое заполнение ячейки с условием
Romzay84 Дата: Вторник, 03.09.2019, 02:22 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер форумчане. Как можно автоматизировать формулой, чтобы значение ОВ в ячейках проставлялось в нужную дату (на следующий день после отработки всех смен). Например, на 1 августа Алимову оставалось отработать 9 смен. В Ячейке за 10 августа должно автоматически появиться значение ОВ. В процессе заполнения табеля значение ОВ должно смещаться, т.к. Алимов брал выходные дни. Как это сделать не соображу.
К сообщению приложен файл: 3159712-2.xls(31.0 Kb)
 
Ответить
СообщениеДобрый вечер форумчане. Как можно автоматизировать формулой, чтобы значение ОВ в ячейках проставлялось в нужную дату (на следующий день после отработки всех смен). Например, на 1 августа Алимову оставалось отработать 9 смен. В Ячейке за 10 августа должно автоматически появиться значение ОВ. В процессе заполнения табеля значение ОВ должно смещаться, т.к. Алимов брал выходные дни. Как это сделать не соображу.

Автор - Romzay84
Дата добавления - 03.09.2019 в 02:22
Pelena Дата: Вторник, 03.09.2019, 09:42 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14473
Репутация: 3172 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Примерно так
Код
=ЕСЛИ(G$1=$F$1+$B2-$C2+СЧЁТЕСЛИ($F2:F2;"в");"ов";"")

Но Вы же понимаете, что как только Вы введете в ячейку значение вручную, формула в этой ячейке перестанет существовать?
К сообщению приложен файл: 3055962.xls(37.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Примерно так
Код
=ЕСЛИ(G$1=$F$1+$B2-$C2+СЧЁТЕСЛИ($F2:F2;"в");"ов";"")

Но Вы же понимаете, что как только Вы введете в ячейку значение вручную, формула в этой ячейке перестанет существовать?

Автор - Pelena
Дата добавления - 03.09.2019 в 09:42
Romzay84 Дата: Среда, 04.09.2019, 02:18 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, спасибо за помощь. Это круто.
 
Ответить
СообщениеPelena, спасибо за помощь. Это круто.

Автор - Romzay84
Дата добавления - 04.09.2019 в 02:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение ячейки с условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!