Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сколько проверок сделал человек, если даты повторяются - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сколько проверок сделал человек, если даты повторяются (Формулы/Formulas)
Сколько проверок сделал человек, если даты повторяются
Марго1197 Дата: Среда, 04.09.2019, 11:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2010
Добрый день, форумчане, помогите пожалуйста, уже который день бьюсь с этой задачей. :(
Люди делают проверки, все это сводится в одну таблицу, необходимо вычислить, сколько проверок сделал человек.
Человек делая проверку выводит замечания, в результате в таблице отображается несколько раз фамилия и дата, и нужно вычислить сколько раз делал проверку в разные дни. и отдельно сколько выявил замечаний. Т.е. в таблице отобразить если Иванов делал проверки 1 и 2 числа, то должно отобразиться 2 проверки.
К сообщению приложен файл: 1603902.xls(26.5 Kb)


Сообщение отредактировал Марго1197 - Среда, 04.09.2019, 11:38
 
Ответить
СообщениеДобрый день, форумчане, помогите пожалуйста, уже который день бьюсь с этой задачей. :(
Люди делают проверки, все это сводится в одну таблицу, необходимо вычислить, сколько проверок сделал человек.
Человек делая проверку выводит замечания, в результате в таблице отображается несколько раз фамилия и дата, и нужно вычислить сколько раз делал проверку в разные дни. и отдельно сколько выявил замечаний. Т.е. в таблице отобразить если Иванов делал проверки 1 и 2 числа, то должно отобразиться 2 проверки.

Автор - Марго1197
Дата добавления - 04.09.2019 в 11:00
Nic70y Дата: Среда, 04.09.2019, 11:46 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
у Вас Петров без точки в Выводе.
формула массива
Код
=СУММ(--(ЕСЛИ(ПОИСКПОЗ(Таблица_ВП!$B$3:$B$12&Таблица_ВП!$C$3:$C$12;Таблица_ВП!$B$3:$B$12&Таблица_ВП!$C$3:$C$12)=СТРОКА($B$3:$B$12)-2;Таблица_ВП!$C$3:$C$12)=D6))
и обычная
Код
=СЧЁТЕСЛИ(Таблица_ВП!$C$3:$C$12;D6)
вдруг правильно
К сообщению приложен файл: 3032131.xls(27.0 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениеу Вас Петров без точки в Выводе.
формула массива
Код
=СУММ(--(ЕСЛИ(ПОИСКПОЗ(Таблица_ВП!$B$3:$B$12&Таблица_ВП!$C$3:$C$12;Таблица_ВП!$B$3:$B$12&Таблица_ВП!$C$3:$C$12)=СТРОКА($B$3:$B$12)-2;Таблица_ВП!$C$3:$C$12)=D6))
и обычная
Код
=СЧЁТЕСЛИ(Таблица_ВП!$C$3:$C$12;D6)
вдруг правильно

Автор - Nic70y
Дата добавления - 04.09.2019 в 11:46
Марго1197 Дата: Среда, 04.09.2019, 11:59 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2010
запрещено излишнее цитирование

выходит ошибка !ЗНАЧ


Сообщение отредактировал китин - Среда, 04.09.2019, 13:06
 
Ответить
Сообщениезапрещено излишнее цитирование

выходит ошибка !ЗНАЧ

Автор - Марго1197
Дата добавления - 04.09.2019 в 11:59
Nic70y Дата: Среда, 04.09.2019, 12:01 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
формула массива
{формула массива вводится одновременным нажатием Ctrl Shift Enter}


ЯД(poison) 41001841029809
 
Ответить
Сообщение
формула массива
{формула массива вводится одновременным нажатием Ctrl Shift Enter}

Автор - Nic70y
Дата добавления - 04.09.2019 в 12:01
Марго1197 Дата: Среда, 04.09.2019, 12:44 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2010
{формула массива вводится одновременным нажатием Ctrl Shift Enter}

Теперь пишет !Н/Д
 
Ответить
Сообщение
{формула массива вводится одновременным нажатием Ctrl Shift Enter}

Теперь пишет !Н/Д

Автор - Марго1197
Дата добавления - 04.09.2019 в 12:44
Марго1197 Дата: Среда, 04.09.2019, 13:00 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2010
излишнее цитирование запрещено
Спасибо большое, не знала что надо нажимать сочетание клавиш.

Использовала формулу :

Код
=СУММ(--(ЧАСТОТА(ЕСЛИ(вывод!H8=Таблица_ВП!$P$2:$P$1493;Таблица_ВП!$H$2:$H$648);ЕСЛИ(вывод!H8=Таблица_ВП!$P$2:$P$1500;Таблица_ВП!$H$2:$H$1500))>0))


Спасибо Nic70y
 
Ответить
Сообщениеизлишнее цитирование запрещено
Спасибо большое, не знала что надо нажимать сочетание клавиш.

Использовала формулу :

Код
=СУММ(--(ЧАСТОТА(ЕСЛИ(вывод!H8=Таблица_ВП!$P$2:$P$1493;Таблица_ВП!$H$2:$H$648);ЕСЛИ(вывод!H8=Таблица_ВП!$P$2:$P$1500;Таблица_ВП!$H$2:$H$1500))>0))


Спасибо Nic70y

Автор - Марго1197
Дата добавления - 04.09.2019 в 13:00
bmv98rus Дата: Среда, 04.09.2019, 13:06 | Сообщение № 7
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2627
Репутация: 451 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUM(IFERROR((Таблица_ВП!$C$3:$C$12=Вывод!D6)/COUNTIFS(Таблица_ВП!$C$3:$C$12;Вывод!D6;Таблица_ВП!$B$3:$B$12;Таблица_ВП!$B$3:$B$12);))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=SUM(IFERROR((Таблица_ВП!$C$3:$C$12=Вывод!D6)/COUNTIFS(Таблица_ВП!$C$3:$C$12;Вывод!D6;Таблица_ВП!$B$3:$B$12;Таблица_ВП!$B$3:$B$12);))

Автор - bmv98rus
Дата добавления - 04.09.2019 в 13:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сколько проверок сделал человек, если даты повторяются (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!