Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Присвоения атрибута в зависимости от распределения значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоения атрибута в зависимости от распределения значений (Формулы/Formulas)
Присвоения атрибута в зависимости от распределения значений
vsg-good Дата: Среда, 04.09.2019, 23:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем добрый день.

Есть список значений (пример прилагаю). Необходимо присвоить каждой строке значение исходя из распределения этих значений в диапазоне. Подозреваю, что нужно как-то задействовать формулы массива. Прошу помочь в прописывании формул для присвоения этих значений.

Заранее спасибо.
К сообщению приложен файл: 6205828.xlsx(8.2 Kb)
 
Ответить
СообщениеВсем добрый день.

Есть список значений (пример прилагаю). Необходимо присвоить каждой строке значение исходя из распределения этих значений в диапазоне. Подозреваю, что нужно как-то задействовать формулы массива. Прошу помочь в прописывании формул для присвоения этих значений.

Заранее спасибо.

Автор - vsg-good
Дата добавления - 04.09.2019 в 23:07
Светлый Дата: Четверг, 05.09.2019, 07:12 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
С примером, что должно быть, было бы легче.
Как понял:
Код
=ЕСЛИ(ИЛИ(B3:F3);ЕСЛИ((СУММ(B3:F3;-D3)>0)*(D3=0);3;2);1)
*Даже так:
Код
=ЕСЛИ(ИЛИ(B3:F3);ЕСЛИ(D3;2;3);1)
**
Код
=ЕСЛИ(ИЛИ(B3:F3);3-(D3>0);1)
***
Код
=3^ИЛИ(B3:F3)-(D3>0)
****А если в таблице только 0 и 1, то:
Код
=3^ИЛИ(B3:F3)-D3


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 05.09.2019, 07:31
 
Ответить
СообщениеС примером, что должно быть, было бы легче.
Как понял:
Код
=ЕСЛИ(ИЛИ(B3:F3);ЕСЛИ((СУММ(B3:F3;-D3)>0)*(D3=0);3;2);1)
*Даже так:
Код
=ЕСЛИ(ИЛИ(B3:F3);ЕСЛИ(D3;2;3);1)
**
Код
=ЕСЛИ(ИЛИ(B3:F3);3-(D3>0);1)
***
Код
=3^ИЛИ(B3:F3)-(D3>0)
****А если в таблице только 0 и 1, то:
Код
=3^ИЛИ(B3:F3)-D3

Автор - Светлый
Дата добавления - 05.09.2019 в 07:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоения атрибута в зависимости от распределения значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!