Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение принадлежности точки - квадрату на диаграмме - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение принадлежности точки - квадрату на диаграмме (Формулы/Formulas)
Определение принадлежности точки - квадрату на диаграмме
Glass4217 Дата: Четверг, 05.09.2019, 15:20 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте, уважаемые специалисты по экселю.
У меня возник такой вопрос.

Есть решение по принадлежности точки - кругу на диаграмме.
При том что диаметр круга - примерно известен.
Формула [code]=--(КОРЕНЬ(СУММКВРАЗН(D6:E6;$I$6:$J$6))<=F6/2)
возвращает результат в столбец G (1-если принадлежит, 0-если не принадлежит).

Скажите - а как формулой определить принадлежность точки - не кругу, а квадрату (если его сторона тоже известна) и вывести результат в столбец G аналогичным способом ?
К сообщению приложен файл: 1362364.xls(45.5 Kb)
 
Ответить
СообщениеЗдравствуйте, уважаемые специалисты по экселю.
У меня возник такой вопрос.

Есть решение по принадлежности точки - кругу на диаграмме.
При том что диаметр круга - примерно известен.
Формула [code]=--(КОРЕНЬ(СУММКВРАЗН(D6:E6;$I$6:$J$6))<=F6/2)
возвращает результат в столбец G (1-если принадлежит, 0-если не принадлежит).

Скажите - а как формулой определить принадлежность точки - не кругу, а квадрату (если его сторона тоже известна) и вывести результат в столбец G аналогичным способом ?

Автор - Glass4217
Дата добавления - 05.09.2019 в 15:20
Светлый Дата: Четверг, 05.09.2019, 17:44 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Формула массива будет показана после оформления Вашей формулы тегами.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 05.09.2019, 17:57
 
Ответить
СообщениеЗдравствуйте!
Формула массива будет показана после оформления Вашей формулы тегами.

Автор - Светлый
Дата добавления - 05.09.2019 в 17:44
bmv98rus Дата: Четверг, 05.09.2019, 18:05 | Сообщение № 3
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2528
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013/2016
Цитата Светлый, 05.09.2019 в 17:44, в сообщении № 2 ()
Формула массива
Интрига однако


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Цитата Светлый, 05.09.2019 в 17:44, в сообщении № 2 ()
Формула массива
Интрига однако

Автор - bmv98rus
Дата добавления - 05.09.2019 в 18:05
Glass4217 Дата: Суббота, 07.09.2019, 15:37 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, оформил формулу тегами.

Вот:
Код
=--(КОРЕНЬ(СУММКВРАЗН(D6:E6;$I$6:$J$6))<=F6/2)


(а в первом сообщении - не могу отредактировать - правка недоступна).
 
Ответить
СообщениеСветлый, оформил формулу тегами.

Вот:
Код
=--(КОРЕНЬ(СУММКВРАЗН(D6:E6;$I$6:$J$6))<=F6/2)


(а в первом сообщении - не могу отредактировать - правка недоступна).

Автор - Glass4217
Дата добавления - 07.09.2019 в 15:37
bmv98rus Дата: Суббота, 07.09.2019, 16:09 | Сообщение № 5
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2528
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013/2016
ну я б делал так
Код
=(ABS(D23-$I$6)<=F23/2)*(ABS(E23-$J$6)<=F23/2)


Думаю Светлый массивно так
Код
=--AND(ABS(D23:E23-$I$6:$J$6)<=F23/2)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениену я б делал так
Код
=(ABS(D23-$I$6)<=F23/2)*(ABS(E23-$J$6)<=F23/2)


Думаю Светлый массивно так
Код
=--AND(ABS(D23:E23-$I$6:$J$6)<=F23/2)

Автор - bmv98rus
Дата добавления - 07.09.2019 в 16:09
Glass4217 Дата: Суббота, 07.09.2019, 16:31 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, спасибо вам.
Заработало все.
 
Ответить
Сообщениеbmv98rus, спасибо вам.
Заработало все.

Автор - Glass4217
Дата добавления - 07.09.2019 в 16:31
Светлый Дата: Суббота, 07.09.2019, 19:03 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Думаю Светлый массивно так
Да, фактически так.
Код
=ЕСЛИ(F6="";"";--И(ABS(I$6:J$6-D6:E6)<=F6/2))


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
Думаю Светлый массивно так
Да, фактически так.
Код
=ЕСЛИ(F6="";"";--И(ABS(I$6:J$6-D6:E6)<=F6/2))

Автор - Светлый
Дата добавления - 07.09.2019 в 19:03
like_Excel Дата: Воскресенье, 08.09.2019, 20:19 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Можно посмотреть здесью Там много полезной инфы.

https://www.youtube.com/channel/UCw4T0U7JcsWeeee4VaohTEQ


Всем привет!
 
Ответить
СообщениеМожно посмотреть здесью Там много полезной инфы.

https://www.youtube.com/channel/UCw4T0U7JcsWeeee4VaohTEQ

Автор - like_Excel
Дата добавления - 08.09.2019 в 20:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение принадлежности точки - квадрату на диаграмме (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!