Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как вставить знак из другой ячейки в тело формулы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как вставить знак из другой ячейки в тело формулы (Формулы/Formulas)
как вставить знак из другой ячейки в тело формулы
Villy Дата: Суббота, 07.09.2019, 09:52 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго дня!
прошу помощи по след задаче.
имею некую матрицу условий, в которой есть столбец условием <, >=, например условие при котором значение <40% в одной строке и >=40% в другой
Как написать формулу единую для всех строк и в тело формулы подставляю знак, указанный в ячейке?
например строка1: взнос < 40% от суммы кредита, то ....
строка2: взнос >=40% от суммы кредита, то ....
что-то типа =если(А1"знак из другой ячейки <"A2;9;0)
перепробовал все от сцепить и вставить....
К сообщению приложен файл: __.xlsx(9.2 Kb)
 
Ответить
СообщениеДоброго дня!
прошу помощи по след задаче.
имею некую матрицу условий, в которой есть столбец условием <, >=, например условие при котором значение <40% в одной строке и >=40% в другой
Как написать формулу единую для всех строк и в тело формулы подставляю знак, указанный в ячейке?
например строка1: взнос < 40% от суммы кредита, то ....
строка2: взнос >=40% от суммы кредита, то ....
что-то типа =если(А1"знак из другой ячейки <"A2;9;0)
перепробовал все от сцепить и вставить....

Автор - Villy
Дата добавления - 07.09.2019 в 09:52
китин Дата: Суббота, 07.09.2019, 10:00 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а поконкретнее плиз:
если
взнос >=40% от суммы кредита, то ....

и если
взнос >=40% от суммы кредита, то ....

а то что то с утра непонятно


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа поконкретнее плиз:
если
взнос >=40% от суммы кредита, то ....

и если
взнос >=40% от суммы кредита, то ....

а то что то с утра непонятно

Автор - китин
Дата добавления - 07.09.2019 в 10:00
Villy Дата: Суббота, 07.09.2019, 10:09 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
вроде в файле вложенном изобразил :)
имеем некую матрицу условий, в которой указан знак < или >= в ячейке
как написать формулу и вставить в нее ссылку, чтобы она брала знак из другой ячейки?
 
Ответить
Сообщениевроде в файле вложенном изобразил :)
имеем некую матрицу условий, в которой указан знак < или >= в ячейке
как написать формулу и вставить в нее ссылку, чтобы она брала знак из другой ячейки?

Автор - Villy
Дата добавления - 07.09.2019 в 10:09
китин Дата: Суббота, 07.09.2019, 10:18 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вроде в файле вложенном изобразил

%)
у вас в файле что больше,что меньше ставка 12.3% . и что вы изобразили?
аа, как хотите. я так понял

Код
=ЕСЛИ(G5/F5<D5;E5;D6)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
вроде в файле вложенном изобразил

%)
у вас в файле что больше,что меньше ставка 12.3% . и что вы изобразили?
аа, как хотите. я так понял

Код
=ЕСЛИ(G5/F5<D5;E5;D6)

Автор - китин
Дата добавления - 07.09.2019 в 10:18
Nic70y Дата: Суббота, 07.09.2019, 11:10 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 5607
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИ(ю;E5;)
где ю макрофункция
Код
=ВЫЧИСЛИТЬ(Лист1!G5/Лист1!F5&Лист1!C5&Лист1!D5)
К сообщению приложен файл: 5769663.xlsm(9.2 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(ю;E5;)
где ю макрофункция
Код
=ВЫЧИСЛИТЬ(Лист1!G5/Лист1!F5&Лист1!C5&Лист1!D5)

Автор - Nic70y
Дата добавления - 07.09.2019 в 11:10
bmv98rus Дата: Суббота, 07.09.2019, 11:34 | Сообщение № 6
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2528
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=IF(CHOOSE(MATCH(C5;{"<";"<=";"=";">=";">";"<>"};);G5<F5;G5<=F5;G5=F5;G5>=F5;G5>F5;G5<>F5);E5;)


ненужное зачеркнуть :-)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Суббота, 07.09.2019, 11:38
 
Ответить
Сообщение
Код
=IF(CHOOSE(MATCH(C5;{"<";"<=";"=";">=";">";"<>"};);G5<F5;G5<=F5;G5=F5;G5>=F5;G5>F5;G5<>F5);E5;)


ненужное зачеркнуть :-)

Автор - bmv98rus
Дата добавления - 07.09.2019 в 11:34
Villy Дата: Суббота, 07.09.2019, 12:31 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=ЕСЛИ(ВЫБОР(ПОИСКПОЗ(C5;{"<";"<=";"=";">=";">";"<>"};);G5<F5;G5<=F5;G5=F5;G5>=F5;G5>F5;G5<>F5);E5;)


Огромное спасибо!!! заработало!!!
 
Ответить
Сообщение
=ЕСЛИ(ВЫБОР(ПОИСКПОЗ(C5;{"<";"<=";"=";">=";">";"<>"};);G5<F5;G5<=F5;G5=F5;G5>=F5;G5>F5;G5<>F5);E5;)


Огромное спасибо!!! заработало!!!

Автор - Villy
Дата добавления - 07.09.2019 в 12:31
Nic70y Дата: Суббота, 07.09.2019, 12:31 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 5607
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
переборщил в соот.№5
Код
=ЕСЛИ(1-СЧЁТЕСЛИ(D5;C5&G5/F5);E5;)


ЯД(poison) 41001841029809
 
Ответить
Сообщениепереборщил в соот.№5
Код
=ЕСЛИ(1-СЧЁТЕСЛИ(D5;C5&G5/F5);E5;)

Автор - Nic70y
Дата добавления - 07.09.2019 в 12:31
Светлый Дата: Суббота, 07.09.2019, 13:06 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Аналогично:
Код
=ЕСЛИ(СЧЁТЕСЛИ(D5;C5&G5/F5);;E5)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеАналогично:
Код
=ЕСЛИ(СЧЁТЕСЛИ(D5;C5&G5/F5);;E5)

Автор - Светлый
Дата добавления - 07.09.2019 в 13:06
Nic70y Дата: Суббота, 07.09.2019, 13:22 | Сообщение № 10
Группа: Друзья
Ранг: Экселист
Сообщений: 5607
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
Цитата Светлый, 07.09.2019 в 13:06, в сообщении № 9 ()
Аналогично:
ну тогда еще сократим:)
Код
=(1-СЧЁТЕСЛИ(D5;C5&G5/F5))*E5


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Цитата Светлый, 07.09.2019 в 13:06, в сообщении № 9 ()
Аналогично:
ну тогда еще сократим:)
Код
=(1-СЧЁТЕСЛИ(D5;C5&G5/F5))*E5

Автор - Nic70y
Дата добавления - 07.09.2019 в 13:22
Villy Дата: Суббота, 07.09.2019, 15:06 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y
тоже работает !!!
Спасибо!
 
Ответить
СообщениеNic70y
тоже работает !!!
Спасибо!

Автор - Villy
Дата добавления - 07.09.2019 в 15:06
Nic70y Дата: Воскресенье, 08.09.2019, 19:47 | Сообщение № 12
Группа: Друзья
Ранг: Экселист
Сообщений: 5607
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
Огромное спасибо!!! заработало!!!

Nic70y
тоже работает !!!
ваще-то странно, формулы абсолютно на разный результат работают.


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Огромное спасибо!!! заработало!!!

Nic70y
тоже работает !!!
ваще-то странно, формулы абсолютно на разный результат работают.

Автор - Nic70y
Дата добавления - 08.09.2019 в 19:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как вставить знак из другой ячейки в тело формулы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!