Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества непустых значений в диапазоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества непустых значений в диапазоне (Формулы/Formulas)
Подсчет количества непустых значений в диапазоне
Evg1 Дата: Вторник, 10.09.2019, 10:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте.
В таблице есть список лиц, каждому из которых соответствует несколько мероприятий, ячейки с лицами объединены. Нужно посчитать количество мероприятий (непустых строк) для каждого лица.
Для каждой ячейки это можно сделать при помощи функции СЧЁТЗ, выделив нужный диапазон, как это сделано в примере.
Но этих лиц сотни, можно ли в таком случае как-то автоматизировать этот процесс, так как в случае объединенных ячеек простой протяжкой этого сделать не получается?
К сообщению приложен файл: 0868455.xls(26.0 Kb)
 
Ответить
СообщениеЗдравствуйте.
В таблице есть список лиц, каждому из которых соответствует несколько мероприятий, ячейки с лицами объединены. Нужно посчитать количество мероприятий (непустых строк) для каждого лица.
Для каждой ячейки это можно сделать при помощи функции СЧЁТЗ, выделив нужный диапазон, как это сделано в примере.
Но этих лиц сотни, можно ли в таком случае как-то автоматизировать этот процесс, так как в случае объединенных ячеек простой протяжкой этого сделать не получается?

Автор - Evg1
Дата добавления - 10.09.2019 в 10:19
Nic70y Дата: Вторник, 10.09.2019, 10:59 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5605
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
с доп.ячейкой внизу таблицы
Код
=ЕСЛИ(B3="";"";СЧЁТ(D3:ИНДЕКС(D4:D$65536;ПОИСКПОЗ("*";B4:B$65536;)-1)))
К сообщению приложен файл: 0250242.xls(28.0 Kb)


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Вторник, 10.09.2019, 10:59
 
Ответить
Сообщениес доп.ячейкой внизу таблицы
Код
=ЕСЛИ(B3="";"";СЧЁТ(D3:ИНДЕКС(D4:D$65536;ПОИСКПОЗ("*";B4:B$65536;)-1)))

Автор - Nic70y
Дата добавления - 10.09.2019 в 10:59
Evg1 Дата: Вторник, 10.09.2019, 11:14 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y,
Спасибо за помощь, но в данном случае объединение ячеек по столбцу C просто исчезло, насколько я понимаю.
А результат должен быть именно в объединенной ячейке.
 
Ответить
СообщениеNic70y,
Спасибо за помощь, но в данном случае объединение ячеек по столбцу C просто исчезло, насколько я понимаю.
А результат должен быть именно в объединенной ячейке.

Автор - Evg1
Дата добавления - 10.09.2019 в 11:14
Nic70y Дата: Вторник, 10.09.2019, 11:25 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5605
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
в первую объ-ю вводите формулу
Код
=СЧЁТ(D3:ИНДЕКС(D4:D$65536;ПОИСКПОЗ("*";B4:B$65536;)-1))
выделяете все ячейки, начиная с первой (где уже формула)
жмете F2, затем Ctrl+Enter


ЯД(poison) 41001841029809
 
Ответить
Сообщениев первую объ-ю вводите формулу
Код
=СЧЁТ(D3:ИНДЕКС(D4:D$65536;ПОИСКПОЗ("*";B4:B$65536;)-1))
выделяете все ячейки, начиная с первой (где уже формула)
жмете F2, затем Ctrl+Enter

Автор - Nic70y
Дата добавления - 10.09.2019 в 11:25
Evg1 Дата: Вторник, 10.09.2019, 12:02 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=СЧЁТ(D3:ИНДЕКС(D4:D$65536;ПОИСКПОЗ("*";B4:B$65536;)-1))

Не совсем понимаю как, но, главное, всё работает. )
Единственное, я не включил в пример вариант с одной строкой (mea culpa), в этом случае формула показывает что-то другое, в примере 2-я строка.
Можно это как-то поправить?
В любом случае работа сильно упростилась, спасибо огромное!
К сообщению приложен файл: 3410930.xls(26.5 Kb)


Сообщение отредактировал Evg1 - Вторник, 10.09.2019, 12:04
 
Ответить
Сообщение
=СЧЁТ(D3:ИНДЕКС(D4:D$65536;ПОИСКПОЗ("*";B4:B$65536;)-1))

Не совсем понимаю как, но, главное, всё работает. )
Единственное, я не включил в пример вариант с одной строкой (mea culpa), в этом случае формула показывает что-то другое, в примере 2-я строка.
Можно это как-то поправить?
В любом случае работа сильно упростилась, спасибо огромное!

Автор - Evg1
Дата добавления - 10.09.2019 в 12:02
Nic70y Дата: Вторник, 10.09.2019, 12:06 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5605
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
строкой (mea culpa)
где это? не нашел


ЯД(poison) 41001841029809
 
Ответить
Сообщение
строкой (mea culpa)
где это? не нашел

Автор - Nic70y
Дата добавления - 10.09.2019 в 12:06
Evg1 Дата: Вторник, 10.09.2019, 12:19 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y,
Я прикрепил файл к сообщению, вторая строка таблицы, вместо 1 показывает 5.
К сообщению приложен файл: 9405961.xls(26.5 Kb)
 
Ответить
СообщениеNic70y,
Я прикрепил файл к сообщению, вторая строка таблицы, вместо 1 показывает 5.

Автор - Evg1
Дата добавления - 10.09.2019 в 12:19
Nic70y Дата: Вторник, 10.09.2019, 12:24 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 5605
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
Код
=СЧЁТ(D3:ИНДЕКС(D3:D$65536;ПОИСКПОЗ("*";B4:B$65536;)))
не учел, что может быть всего одна строка


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=СЧЁТ(D3:ИНДЕКС(D3:D$65536;ПОИСКПОЗ("*";B4:B$65536;)))
не учел, что может быть всего одна строка

Автор - Nic70y
Дата добавления - 10.09.2019 в 12:24
Evg1 Дата: Вторник, 10.09.2019, 12:40 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y,
Теперь всё просто идеально. thumb
 
Ответить
СообщениеNic70y,
Теперь всё просто идеально. thumb

Автор - Evg1
Дата добавления - 10.09.2019 в 12:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества непустых значений в диапазоне (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!