Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма продаж по продавцу по количеству встреч или количеству - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма продаж по продавцу по количеству встреч или количеству (Формулы/Formulas)
Сумма продаж по продавцу по количеству встреч или количеству
Mago123 Дата: Вторник, 10.09.2019, 10:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Приветствую.
СУММЕСЛИМН перебирает условия с оператором И. Мне необходимо решить задачу в которой будут складываться значения с условием ИЛИ.

Т.е. есть таблица со столбцами: продавец, дата продажи, проданное количество товара, количество встреч, сумма продаж.
Необходимо в другой таблице вывести данные по каждому продавцу сумму продаж если количество товара в интервале, например, от 3 до 6, ИЛИ количество встреч больше 5.
К сообщению приложен файл: 9901447.xlsx(9.9 Kb)


Сообщение отредактировал Mago123 - Вторник, 10.09.2019, 10:29
 
Ответить
СообщениеПриветствую.
СУММЕСЛИМН перебирает условия с оператором И. Мне необходимо решить задачу в которой будут складываться значения с условием ИЛИ.

Т.е. есть таблица со столбцами: продавец, дата продажи, проданное количество товара, количество встреч, сумма продаж.
Необходимо в другой таблице вывести данные по каждому продавцу сумму продаж если количество товара в интервале, например, от 3 до 6, ИЛИ количество встреч больше 5.

Автор - Mago123
Дата добавления - 10.09.2019 в 10:29
bigor Дата: Вторник, 10.09.2019, 10:43 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 83
Репутация: 10 ±
Замечаний: 0% ±

Excel 2016
Добрый день

Ваше условие не соответствует приведенному примеру
в августе у продавца А нет продаж больше 3 и нет встреч больше 5, но Вы ему ставите 50

Вот так получилось:

Код
=СУММПРОИЗВ(($A$2:$A$13=A18)*($B$2:$B$13=8)*(($C$2:$C$13>3)*($C$2:$C$13<=6)*($E$2:$E$13)*($D$2:$D$13<=5)+($D$2:$D$13>5)*$E$2:$E$13))
К сообщению приложен файл: EW_prod_1.xlsx(6.8 Kb)


Сообщение отредактировал bigor - Вторник, 10.09.2019, 10:54
 
Ответить
СообщениеДобрый день

Ваше условие не соответствует приведенному примеру
в августе у продавца А нет продаж больше 3 и нет встреч больше 5, но Вы ему ставите 50

Вот так получилось:

Код
=СУММПРОИЗВ(($A$2:$A$13=A18)*($B$2:$B$13=8)*(($C$2:$C$13>3)*($C$2:$C$13<=6)*($E$2:$E$13)*($D$2:$D$13<=5)+($D$2:$D$13>5)*$E$2:$E$13))

Автор - bigor
Дата добавления - 10.09.2019 в 10:43
Mago123 Дата: Среда, 11.09.2019, 12:49 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, да, я не точно сказал условие. Больше или равно 3, доп знак я поставлю сам.

Правильно ли я понимаю, что формула работает так:
суммируем сначала произведение суммы продажи с 1 или 0 в зависимости от выполнения условий - все продажи где количество встреч <=5 и продано от 3 до 6. Затем находим сумму произведений продаж на 1 или 0 - если больше 5 до на 1. и два результата складываем.
 
Ответить
СообщениеСпасибо, да, я не точно сказал условие. Больше или равно 3, доп знак я поставлю сам.

Правильно ли я понимаю, что формула работает так:
суммируем сначала произведение суммы продажи с 1 или 0 в зависимости от выполнения условий - все продажи где количество встреч <=5 и продано от 3 до 6. Затем находим сумму произведений продаж на 1 или 0 - если больше 5 до на 1. и два результата складываем.

Автор - Mago123
Дата добавления - 11.09.2019 в 12:49
bigor Дата: Среда, 11.09.2019, 14:58 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 83
Репутация: 10 ±
Замечаний: 0% ±

Excel 2016
Правильно ли я понимаю, что формула работает так

Да, но перед этим еще условия на продавца и месяц
 
Ответить
Сообщение
Правильно ли я понимаю, что формула работает так

Да, но перед этим еще условия на продавца и месяц

Автор - bigor
Дата добавления - 11.09.2019 в 14:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма продаж по продавцу по количеству встреч или количеству (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!