Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММПРОИЗВ работает только с полным вхождением текста? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ работает только с полным вхождением текста? (Формулы/Formulas)
СУММПРОИЗВ работает только с полным вхождением текста?
Lex177 Дата: Воскресенье, 15.09.2019, 12:12 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Уважаемые гуру, здравствуйте.

Почему СУММПРОИЗВ не работает по частичному вхождению текста из диапазона? Точное вхождение работает, но стоит заменить один символ на * и сразу формула перестает работать. Как можно это обойти? Необходимо перемножить попарно два диапазона по нескольким условиям, одно из которых частичное вхождение текста.
Пример работы формулы приложил.
К сообщению приложен файл: 9592717.xlsx(9.4 Kb)
 
Ответить
СообщениеУважаемые гуру, здравствуйте.

Почему СУММПРОИЗВ не работает по частичному вхождению текста из диапазона? Точное вхождение работает, но стоит заменить один символ на * и сразу формула перестает работать. Как можно это обойти? Необходимо перемножить попарно два диапазона по нескольким условиям, одно из которых частичное вхождение текста.
Пример работы формулы приложил.

Автор - Lex177
Дата добавления - 15.09.2019 в 12:12
Lex177 Дата: Воскресенье, 15.09.2019, 12:25 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Самое интересное что СУММЕСЛИ работает. Что это такое? Баг в excel?
К сообщению приложен файл: 1021229.xlsx(9.5 Kb)
 
Ответить
СообщениеСамое интересное что СУММЕСЛИ работает. Что это такое? Баг в excel?

Автор - Lex177
Дата добавления - 15.09.2019 в 12:25
Pelena Дата: Воскресенье, 15.09.2019, 12:47 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14579
Репутация: 3192 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Как-то так.
Код
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК("яблок";A:A));B:B;C:C)

НО! Не рекомендуется использовать СУММПРОИЗВ() с целыми столбцами, будет тормозить,лучше взять диапазон с запасом, например
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК("яблок";$A$2:$A$1000))*$B$2:$B$1000*$C$2:$C$1000)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Как-то так.
Код
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК("яблок";A:A));B:B;C:C)

НО! Не рекомендуется использовать СУММПРОИЗВ() с целыми столбцами, будет тормозить,лучше взять диапазон с запасом, например
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК("яблок";$A$2:$A$1000))*$B$2:$B$1000*$C$2:$C$1000)

Автор - Pelena
Дата добавления - 15.09.2019 в 12:47
Lex177 Дата: Воскресенье, 15.09.2019, 13:23 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, благодарю за решение!
А как в таком случае прописать если массив НЕ содержит текст?
 
Ответить
СообщениеPelena, благодарю за решение!
А как в таком случае прописать если массив НЕ содержит текст?

Автор - Lex177
Дата добавления - 15.09.2019 в 13:23
Pelena Дата: Воскресенье, 15.09.2019, 13:27 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 14579
Репутация: 3192 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
ЕОШИБКА(ПОИСК("яблок";$A$2:$A$1000))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
ЕОШИБКА(ПОИСК("яблок";$A$2:$A$1000))

Автор - Pelena
Дата добавления - 15.09.2019 в 13:27
Lex177 Дата: Воскресенье, 15.09.2019, 13:38 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Супер! :up:
 
Ответить
СообщениеСупер! :up:

Автор - Lex177
Дата добавления - 15.09.2019 в 13:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ работает только с полным вхождением текста? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!