Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка значений из последнего подсчитанного столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений из последнего подсчитанного столбца (Формулы/Formulas)
Выборка значений из последнего подсчитанного столбца
Saigon Дата: Понедельник, 16.09.2019, 00:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте.

Есть две таблицы, которые постепенно наполняются данными с применением формул. Каким образом можно в отдельную область выносить значение последнего посчитанного столбца в каждой из этих таблиц без использования макросов?
Прикрепляю файл с пояснениями.

Заранее спасибо за помощь
К сообщению приложен файл: 3572481.xlsx(25.2 Kb)


Сообщение отредактировал Saigon - Понедельник, 16.09.2019, 00:42
 
Ответить
СообщениеЗдравствуйте.

Есть две таблицы, которые постепенно наполняются данными с применением формул. Каким образом можно в отдельную область выносить значение последнего посчитанного столбца в каждой из этих таблиц без использования макросов?
Прикрепляю файл с пояснениями.

Заранее спасибо за помощь

Автор - Saigon
Дата добавления - 16.09.2019 в 00:39
Светлый Дата: Понедельник, 16.09.2019, 06:28 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1299
Репутация: 326 ±
Замечаний: 0% ±

Excel 2010
Попробуйте такую формулу:
Код
=ПРОСМОТР(;-1/A14:AM14;A14:AM14)
*Диапазон выбора можете ограничить.
Для второй таблицы:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/A30:F30;A30:F30);"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 16.09.2019, 06:33
 
Ответить
СообщениеПопробуйте такую формулу:
Код
=ПРОСМОТР(;-1/A14:AM14;A14:AM14)
*Диапазон выбора можете ограничить.
Для второй таблицы:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/A30:F30;A30:F30);"")

Автор - Светлый
Дата добавления - 16.09.2019 в 06:28
Светлый Дата: Понедельник, 16.09.2019, 09:47 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1299
Репутация: 326 ±
Замечаний: 0% ±

Excel 2010


Программировать проще, чем писать стихи.
 
Ответить
СообщениеКросс

Автор - Светлый
Дата добавления - 16.09.2019 в 09:47
Saigon Дата: Понедельник, 16.09.2019, 11:36 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата Светлый, 16.09.2019 в 06:28, в сообщении № 2 ()
=ПРОСМОТР(;-1/A14:AM14;A14:AM14)

Спасибо. Но получается, что по вашей формуле он в сводную переносит последнее значение сразу для каждого столбца, а нужно именно только одно для последнего.

Смысл таблицы в том, что оператор вносит значение, формула его рассчитывает, переносит в сводную и дальше сводную с одним последним вычислением на печать для производства. Приложил файл с вашей формулой и комментарием
К сообщению приложен файл: 2112170.xlsx(24.4 Kb)


Сообщение отредактировал Saigon - Понедельник, 16.09.2019, 11:38
 
Ответить
Сообщение
Цитата Светлый, 16.09.2019 в 06:28, в сообщении № 2 ()
=ПРОСМОТР(;-1/A14:AM14;A14:AM14)

Спасибо. Но получается, что по вашей формуле он в сводную переносит последнее значение сразу для каждого столбца, а нужно именно только одно для последнего.

Смысл таблицы в том, что оператор вносит значение, формула его рассчитывает, переносит в сводную и дальше сводную с одним последним вычислением на печать для производства. Приложил файл с вашей формулой и комментарием

Автор - Saigon
Дата добавления - 16.09.2019 в 11:36
Светлый Дата: Понедельник, 16.09.2019, 12:37 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1299
Репутация: 326 ±
Замечаний: 0% ±

Excel 2010
Тогда массивная (вводится одновременным нажатием Ctrl+Shift+Enter) формула:
Код
=ИНДЕКС(2:2;;МАКС((A$2:AM$21>0)*СТОЛБЕЦ(A:AM)))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеТогда массивная (вводится одновременным нажатием Ctrl+Shift+Enter) формула:
Код
=ИНДЕКС(2:2;;МАКС((A$2:AM$21>0)*СТОЛБЕЦ(A:AM)))

Автор - Светлый
Дата добавления - 16.09.2019 в 12:37
Saigon Дата: Понедельник, 16.09.2019, 14:20 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата Светлый, 16.09.2019 в 12:37, в сообщении № 5 ()
=ИНДЕКС(2:2;;МАКС((A$2:AM$21>0)*СТОЛБЕЦ(A:AM)))

Спасибо огромное, это именно то, что нужно. В более старых версиях Excell не будет проблем с этой формулой? Там же массив
 
Ответить
Сообщение
Цитата Светлый, 16.09.2019 в 12:37, в сообщении № 5 ()
=ИНДЕКС(2:2;;МАКС((A$2:AM$21>0)*СТОЛБЕЦ(A:AM)))

Спасибо огромное, это именно то, что нужно. В более старых версиях Excell не будет проблем с этой формулой? Там же массив

Автор - Saigon
Дата добавления - 16.09.2019 в 14:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений из последнего подсчитанного столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!