Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Текстовый формат в формат даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Текстовый формат в формат даты (Формулы/Formulas)
Текстовый формат в формат даты
ovechkin1973 Дата: Понедельник, 23.09.2019, 19:23 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 348
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Приветствую. Пользуюсь на работе файлом, точнее не я, а другие люди. Недавно в файле обнаружили, что часть дат поменялась в текстовый формат. И если раньше дата была "31.05.2018", то сейчас текстом выглядит "05/31/2018".
Что сделали с файлом - не представляю. Кроме этого еще много по работе файла "поломалось", но я решил эти проблемы. А вот с датами пока не смог проблему победить... В файле больше 15000 строк... Пример урезанный приложил. Понимаю, что решение наверняка элементарное, но не для меня.
PS - файл для всех защищен от записи, кроме человека, который его заполняет. Но это очень аккуратный человек, не должен он был чего то "поломать" в файле.
К сообщению приложен файл: 4826946.xlsm(11.1 Kb)


Плохо когда не знаешь, да еще забудешь.
 
Ответить
СообщениеПриветствую. Пользуюсь на работе файлом, точнее не я, а другие люди. Недавно в файле обнаружили, что часть дат поменялась в текстовый формат. И если раньше дата была "31.05.2018", то сейчас текстом выглядит "05/31/2018".
Что сделали с файлом - не представляю. Кроме этого еще много по работе файла "поломалось", но я решил эти проблемы. А вот с датами пока не смог проблему победить... В файле больше 15000 строк... Пример урезанный приложил. Понимаю, что решение наверняка элементарное, но не для меня.
PS - файл для всех защищен от записи, кроме человека, который его заполняет. Но это очень аккуратный человек, не должен он был чего то "поломать" в файле.

Автор - ovechkin1973
Дата добавления - 23.09.2019 в 19:23
прохожий2019 Дата: Понедельник, 23.09.2019, 19:31 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 8 ±
Замечаний: 0% ±

Excel 2016
Код
=ЕСЛИ(ЕТЕКСТ(C2);--СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(C2;"/";(ПОВТОР(" ";9)));10;9)&"."&ПСТР(ПОДСТАВИТЬ(C2;"/";ПОВТОР(" ";9));1;9)&"."&ПСТР(ПОДСТАВИТЬ(C2;"/";ПОВТОР(" ";9));19;9));C2)
К сообщению приложен файл: 4118231.xlsm(13.0 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕТЕКСТ(C2);--СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(C2;"/";(ПОВТОР(" ";9)));10;9)&"."&ПСТР(ПОДСТАВИТЬ(C2;"/";ПОВТОР(" ";9));1;9)&"."&ПСТР(ПОДСТАВИТЬ(C2;"/";ПОВТОР(" ";9));19;9));C2)

Автор - прохожий2019
Дата добавления - 23.09.2019 в 19:31
ovechkin1973 Дата: Понедельник, 23.09.2019, 19:36 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 348
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Цитата прохожий2019, 23.09.2019 в 19:31, в сообщении № 2 ()
=ЕСЛИ(ЕТЕКСТ(C2);--СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(C2;"/";(ПОВТОР(" ";9)));10;9)&"."&ПСТР(ПОДСТАВИТЬ(C2;"/";ПОВТОР(" ";9));1;9)&"."&ПСТР(ПОДСТАВИТЬ(C2;"/";ПОВТОР(" ";9));19;9));C2)

Мерси... утром на работе попробую! Еще бы понять, кто и как накосячил, но это видимо останется тайной навсегда.


Плохо когда не знаешь, да еще забудешь.
 
Ответить
Сообщение
Цитата прохожий2019, 23.09.2019 в 19:31, в сообщении № 2 ()
=ЕСЛИ(ЕТЕКСТ(C2);--СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(C2;"/";(ПОВТОР(" ";9)));10;9)&"."&ПСТР(ПОДСТАВИТЬ(C2;"/";ПОВТОР(" ";9));1;9)&"."&ПСТР(ПОДСТАВИТЬ(C2;"/";ПОВТОР(" ";9));19;9));C2)

Мерси... утром на работе попробую! Еще бы понять, кто и как накосячил, но это видимо останется тайной навсегда.

Автор - ovechkin1973
Дата добавления - 23.09.2019 в 19:36
Nic70y Дата: Понедельник, 23.09.2019, 20:24 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
Код
=--ПРАВБ(ПОДСТАВИТЬ(C2;"/";"/"&ЛЕВБ(C2;(ПСТР(C2;3;1)="/")+2);2);ДЛСТР(C2))


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=--ПРАВБ(ПОДСТАВИТЬ(C2;"/";"/"&ЛЕВБ(C2;(ПСТР(C2;3;1)="/")+2);2);ДЛСТР(C2))

Автор - Nic70y
Дата добавления - 23.09.2019 в 20:24
ovechkin1973 Дата: Вторник, 24.09.2019, 13:08 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 348
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
прохожий2019, Nic70y, Благодарю.. оба варианта работают!


Плохо когда не знаешь, да еще забудешь.
 
Ответить
Сообщениепрохожий2019, Nic70y, Благодарю.. оба варианта работают!

Автор - ovechkin1973
Дата добавления - 24.09.2019 в 13:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Текстовый формат в формат даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!