Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найди предыдущие число в массиве - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найди предыдущие число в массиве (Формулы/Formulas)
Найди предыдущие число в массиве
negodyaj Дата: Суббота, 28.09.2019, 22:55 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем доброго вечера.
Голова сосвем не работает, уверен что задачка решается проще простого, но не могу сообразить.

Есть 3 столбца, в первом массив цифр, во втором статус ИСТИНА/ЛОЖЬ, при ИСТИНЕ во 2 столбце надо в 3 вывести предыдущие числовое значение, не прошлую ячейку, а найти из массива число которое было перед, игнорируя одинаковые.

Пример файла прикрепил.
К сообщению приложен файл: 4845181.xlsx(8.7 Kb)
 
Ответить
СообщениеВсем доброго вечера.
Голова сосвем не работает, уверен что задачка решается проще простого, но не могу сообразить.

Есть 3 столбца, в первом массив цифр, во втором статус ИСТИНА/ЛОЖЬ, при ИСТИНЕ во 2 столбце надо в 3 вывести предыдущие числовое значение, не прошлую ячейку, а найти из массива число которое было перед, игнорируя одинаковые.

Пример файла прикрепил.

Автор - negodyaj
Дата добавления - 28.09.2019 в 22:55
Pelena Дата: Суббота, 28.09.2019, 23:06 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14585
Репутация: 3196 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИ(B1;ПРОСМОТР(;-1/($A$1:A1<>A1);$A$1:A1))
К сообщению приложен файл: 3257371.xlsx(9.2 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИ(B1;ПРОСМОТР(;-1/($A$1:A1<>A1);$A$1:A1))

Автор - Pelena
Дата добавления - 28.09.2019 в 23:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найди предыдущие число в массиве (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!