Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выбор значений по критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выбор значений по критериям (Формулы/Formulas)
выбор значений по критериям
ddmitry Дата: Четверг, 03.10.2019, 03:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте. Есть две таблицы. в одной компании и их выручка по кварталам, плюс по каждой компании указана валюта выручки (рубль, евро). Вторая таблица эти же кварталы и список валют. Как проще сделать, чтобы в дополнительный столбик пересчета доллары вставлялся курс конкретной валюты в конкретном квартале. Сейчас сделал через функцию ЕСЛИ. В 1 квартале она действует, но в каждом новом квартале нужно видоизменять формулу. Можно сделать проше?
К сообщению приложен файл: 9652015.xlsx(9.7 Kb)


Дмитрий

Сообщение отредактировал ddmitry - Четверг, 03.10.2019, 08:20
 
Ответить
СообщениеЗдравствуйте. Есть две таблицы. в одной компании и их выручка по кварталам, плюс по каждой компании указана валюта выручки (рубль, евро). Вторая таблица эти же кварталы и список валют. Как проще сделать, чтобы в дополнительный столбик пересчета доллары вставлялся курс конкретной валюты в конкретном квартале. Сейчас сделал через функцию ЕСЛИ. В 1 квартале она действует, но в каждом новом квартале нужно видоизменять формулу. Можно сделать проше?

Автор - ddmitry
Дата добавления - 03.10.2019 в 03:06
krosav4ig Дата: Четверг, 03.10.2019, 05:08 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2182
Репутация: 913 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Здравствуйте
Можно

Можно
Как проще сделать

Тут читайте


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
СообщениеЗдравствуйте
Можно

Можно
Как проще сделать

Тут читайте

Автор - krosav4ig
Дата добавления - 03.10.2019 в 05:08
китин Дата: Четверг, 03.10.2019, 07:21 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 5882
Репутация: 914 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ddmitry, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеddmitry, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума

Автор - китин
Дата добавления - 03.10.2019 в 07:21
ddmitry Дата: Четверг, 03.10.2019, 07:45 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
вот примерный файл
К сообщению приложен файл: 2778574.xlsx(9.7 Kb)


Дмитрий
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
вот примерный файл

Автор - ddmitry
Дата добавления - 03.10.2019 в 07:45
Nic70y Дата: Четверг, 03.10.2019, 11:39 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
Код
=ГПР(B$1;$D$13:$L$19;СТРОКА();)*B2
Код
=ГПР(B$1;$D$13:$L$19;ПОИСКПОЗ($A2;$C$13:$C$19;);)*B2
Код
=СУММПРОИЗВ(($D$13:$L$13=B$1)*($C$14:$C$19=$A2);$D$14:$L$19)*B2
Код
=ВПР($A2;$C$14:$L$19;ПОИСКПОЗ(B$1;$C$13:$L$13;);)*B2
и т.п.


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Четверг, 03.10.2019, 11:41
 
Ответить
Сообщение
Код
=ГПР(B$1;$D$13:$L$19;СТРОКА();)*B2
Код
=ГПР(B$1;$D$13:$L$19;ПОИСКПОЗ($A2;$C$13:$C$19;);)*B2
Код
=СУММПРОИЗВ(($D$13:$L$13=B$1)*($C$14:$C$19=$A2);$D$14:$L$19)*B2
Код
=ВПР($A2;$C$14:$L$19;ПОИСКПОЗ(B$1;$C$13:$L$13;);)*B2
и т.п.

Автор - Nic70y
Дата добавления - 03.10.2019 в 11:39
ddmitry Дата: Четверг, 03.10.2019, 12:34 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
То есть любой из этих?


Дмитрий
 
Ответить
СообщениеТо есть любой из этих?

Автор - ddmitry
Дата добавления - 03.10.2019 в 12:34
Nic70y Дата: Четверг, 03.10.2019, 12:44 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
таки да.
только не
=СУММПРОИЗВ(($D$13:$L$13=B$1)*($C$14:$C$19=$A2);$D$14:$L$19)*B2
:)


ЯД(poison) 41001841029809
 
Ответить
Сообщениетаки да.
только не
=СУММПРОИЗВ(($D$13:$L$13=B$1)*($C$14:$C$19=$A2);$D$14:$L$19)*B2
:)

Автор - Nic70y
Дата добавления - 03.10.2019 в 12:44
ddmitry Дата: Четверг, 03.10.2019, 13:32 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо. Вечером проверю. Сейчас пробовал через Гугл шитс - что-то не пошло. До компьютера только вечером доберусь


Дмитрий
 
Ответить
СообщениеСпасибо. Вечером проверю. Сейчас пробовал через Гугл шитс - что-то не пошло. До компьютера только вечером доберусь

Автор - ddmitry
Дата добавления - 03.10.2019 в 13:32
ddmitry Дата: Четверг, 03.10.2019, 20:40 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y,
=СУММПРОИЗВ(($D$13:$L$13=B$1)*($C$14:$C$19=$A2);$D$14:$L$19)*B2

Прошу прощения. Работает. Только она видимо предполагает протаскивание по клеткам. А в виду строяния таблицы я так сделать не могу - в итоге хвостик в первой скобке не меняется


Дмитрий

Сообщение отредактировал ddmitry - Четверг, 03.10.2019, 20:54
 
Ответить
СообщениеNic70y,
=СУММПРОИЗВ(($D$13:$L$13=B$1)*($C$14:$C$19=$A2);$D$14:$L$19)*B2

Прошу прощения. Работает. Только она видимо предполагает протаскивание по клеткам. А в виду строяния таблицы я так сделать не могу - в итоге хвостик в первой скобке не меняется

Автор - ddmitry
Дата добавления - 03.10.2019 в 20:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выбор значений по критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!