Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Какую использовать формулу, чтобы выбрать самую новую дату - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Какую использовать формулу, чтобы выбрать самую новую дату (Формулы/Formulas)
Какую использовать формулу, чтобы выбрать самую новую дату
Gress08 Дата: Четверг, 03.10.2019, 11:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Есть таблица 1, в которой в первом столбце указано название контрагента, а во втором дата покупки.

Причем названия некоторых контрагентов встречаются в таблице всего 1 раз, в то время как названия других контрагентов встречаются несколько раз. (Количество соответствует количеству покупок, совершенных контрагентом).

Есть таблица 2, в которой в первом столбце указано название контрагента.

Нужно сделать так, чтобы во второй столбец таблицы 2 попали только даты последних покупок (самые новые), совершенных контрагентом.

Какую формулу для этого использовать?

Таблицу прилагаю
К сообщению приложен файл: 1931305.xls(21.0 Kb)


Сообщение отредактировал Gress08 - Четверг, 03.10.2019, 11:03
 
Ответить
СообщениеЕсть таблица 1, в которой в первом столбце указано название контрагента, а во втором дата покупки.

Причем названия некоторых контрагентов встречаются в таблице всего 1 раз, в то время как названия других контрагентов встречаются несколько раз. (Количество соответствует количеству покупок, совершенных контрагентом).

Есть таблица 2, в которой в первом столбце указано название контрагента.

Нужно сделать так, чтобы во второй столбец таблицы 2 попали только даты последних покупок (самые новые), совершенных контрагентом.

Какую формулу для этого использовать?

Таблицу прилагаю

Автор - Gress08
Дата добавления - 03.10.2019 в 11:02
Nic70y Дата: Четверг, 03.10.2019, 11:17 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
Какую формулу
новая дата = МАКСимальная, соот.
Код
=СУММПРОИЗВ(МАКС(($B$5:$B$15=E5)*C$5:C$15))


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Какую формулу
новая дата = МАКСимальная, соот.
Код
=СУММПРОИЗВ(МАКС(($B$5:$B$15=E5)*C$5:C$15))

Автор - Nic70y
Дата добавления - 03.10.2019 в 11:17
bmv98rus Дата: Четверг, 03.10.2019, 12:33 | Сообщение № 3
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2627
Репутация: 451 ±
Замечаний: 0% ±

Excel 2013/2016
Nic70y, Типа чтоб три кнопки не давить? Ведь просто массивная
Код
=MAX((B5:B15=E5)*C5:C15)

для не старых версий
Код
=AGGREGATE(14;6;C5:C15/(B5:B15=E5);1)

а для новых
Код
=MAXIFS(C5:C15;B5:B15;E5)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Четверг, 03.10.2019, 12:39
 
Ответить
СообщениеNic70y, Типа чтоб три кнопки не давить? Ведь просто массивная
Код
=MAX((B5:B15=E5)*C5:C15)

для не старых версий
Код
=AGGREGATE(14;6;C5:C15/(B5:B15=E5);1)

а для новых
Код
=MAXIFS(C5:C15;B5:B15;E5)

Автор - bmv98rus
Дата добавления - 03.10.2019 в 12:33
Nic70y Дата: Четверг, 03.10.2019, 12:45 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
Типа чтоб три кнопки не давить?
да


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Типа чтоб три кнопки не давить?
да

Автор - Nic70y
Дата добавления - 03.10.2019 в 12:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Какую использовать формулу, чтобы выбрать самую новую дату (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!