Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск времени разных форматов (Excel 2003) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск времени разных форматов (Excel 2003) (Формулы/Formulas)
поиск времени разных форматов (Excel 2003)
Gold_Barsik Дата: Понедельник, 07.10.2019, 00:43 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 398
Репутация: 6 ±
Замечаний: 0% ±

2003
Здравствуйте.
Как найти ячейки, у которых время совпадает хоть с одним из интервалов диапазонов времени?
Форматы времени разные.
К сообщению приложен файл: ___.xls(14.0 Kb)
 
Ответить
СообщениеЗдравствуйте.
Как найти ячейки, у которых время совпадает хоть с одним из интервалов диапазонов времени?
Форматы времени разные.

Автор - Gold_Barsik
Дата добавления - 07.10.2019 в 00:43
krosav4ig Дата: Понедельник, 07.10.2019, 02:37 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2182
Репутация: 913 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Здравствуйте.
Код
=ЕСЛИ(И(--ТЕКСТ(A8;"ч:м:с")>=--ПСТР(D3;1;5);--ТЕКСТ(A8;"ч:м:с")<=--ПСТР(D3;7;5));B8;"")
Код
=ЕСЛИ(ИЛИ((--ТЕКСТ(A14;"ч:м:с")>=--ПСТР(P14:P23;1;5))*(--ТЕКСТ(A14;"ч:м:с")<=--ПСТР(P14:P23;7;5)));B14;"")


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИ(И(--ТЕКСТ(A8;"ч:м:с")>=--ПСТР(D3;1;5);--ТЕКСТ(A8;"ч:м:с")<=--ПСТР(D3;7;5));B8;"")
Код
=ЕСЛИ(ИЛИ((--ТЕКСТ(A14;"ч:м:с")>=--ПСТР(P14:P23;1;5))*(--ТЕКСТ(A14;"ч:м:с")<=--ПСТР(P14:P23;7;5)));B14;"")

Автор - krosav4ig
Дата добавления - 07.10.2019 в 02:37
Gold_Barsik Дата: Понедельник, 07.10.2019, 04:11 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 398
Репутация: 6 ±
Замечаний: 0% ±

2003
Всё чётко, красиво и понятно. Ваще КРАСАВЧИК!!! СПАСИБО!
 
Ответить
СообщениеВсё чётко, красиво и понятно. Ваще КРАСАВЧИК!!! СПАСИБО!

Автор - Gold_Barsik
Дата добавления - 07.10.2019 в 04:11
bmv98rus Дата: Понедельник, 07.10.2019, 07:34 | Сообщение № 4
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2627
Репутация: 451 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=IF(AND(MOD(A8;1)-MID(D3;1;5)>=0;MOD(A8;1)-MID(D3;7;5)<=0);B8;"")


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=IF(AND(MOD(A8;1)-MID(D3;1;5)>=0;MOD(A8;1)-MID(D3;7;5)<=0);B8;"")

Автор - bmv98rus
Дата добавления - 07.10.2019 в 07:34
Gold_Barsik Дата: Понедельник, 07.10.2019, 09:12 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 398
Репутация: 6 ±
Замечаний: 0% ±

2003
bmv98rus, Спасибо!
Только вот беда, с флагами не закончил :( %)
 
Ответить
Сообщениеbmv98rus, Спасибо!
Только вот беда, с флагами не закончил :( %)

Автор - Gold_Barsik
Дата добавления - 07.10.2019 в 09:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск времени разных форматов (Excel 2003) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!