Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Добавление пробела в текстовую ячейку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Добавление пробела в текстовую ячейку (Формулы/Formulas)
Добавление пробела в текстовую ячейку
Новосибирск Дата: Пятница, 18.10.2019, 08:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2002
Здравствуйте. Имеется столбец с пяти и шестизначными цифрами типа 12 345 и 123 456. Все числа разные. Форматирую ячейки в текстовый формат, пробел уходит. получается 12345 и 123456. Задача максимум: добавить в начало пятизначных чисел ноль, и вставить пробел между вторым и третьим знаком для всех чисел. Задача минимум: вставить пробел между вторым и третьим знаком для всех чисел. Желательно в виде макроса. Спасибо.
 
Ответить
СообщениеЗдравствуйте. Имеется столбец с пяти и шестизначными цифрами типа 12 345 и 123 456. Все числа разные. Форматирую ячейки в текстовый формат, пробел уходит. получается 12345 и 123456. Задача максимум: добавить в начало пятизначных чисел ноль, и вставить пробел между вторым и третьим знаком для всех чисел. Задача минимум: вставить пробел между вторым и третьим знаком для всех чисел. Желательно в виде макроса. Спасибо.

Автор - Новосибирск
Дата добавления - 18.10.2019 в 08:03
Kostya_Ye Дата: Пятница, 18.10.2019, 08:18 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 18 ±
Замечаний: 0% ±

Excel 2016
Новосибирск, добрый день,
без файла примера и из описания не ясно, хотите ли вы изменить отображение значения в ячейке или само содержимое ячейки.
Для изменения отображения достаточно использовать пользовательский формат ячейки 000 000
 
Ответить
СообщениеНовосибирск, добрый день,
без файла примера и из описания не ясно, хотите ли вы изменить отображение значения в ячейке или само содержимое ячейки.
Для изменения отображения достаточно использовать пользовательский формат ячейки 000 000

Автор - Kostya_Ye
Дата добавления - 18.10.2019 в 08:18
Russel Дата: Пятница, 18.10.2019, 08:20 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1350
Репутация: 305 ±
Замечаний: 0% ±

Excel 2010
Доброе утро!
Обязательно макрос? Формула не пойдет?

Код
=ТЕКСТ(A1;"### 000 000")


QIWI 9173973973
 
Ответить
СообщениеДоброе утро!
Обязательно макрос? Формула не пойдет?

Код
=ТЕКСТ(A1;"### 000 000")

Автор - Russel
Дата добавления - 18.10.2019 в 08:20
Новосибирск Дата: Пятница, 18.10.2019, 08:56 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2002
Russel, Спасибо. Можно и формулу. Но эта разбивает на 123 456. А надо 12 3456.


Сообщение отредактировал Новосибирск - Пятница, 18.10.2019, 08:58
 
Ответить
СообщениеRussel, Спасибо. Можно и формулу. Но эта разбивает на 123 456. А надо 12 3456.

Автор - Новосибирск
Дата добавления - 18.10.2019 в 08:56
Новосибирск Дата: Пятница, 18.10.2019, 09:01 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2002
Kostya_Ye, Спасибо. Хочу изменить отображение. Данное форматирование требуется только для вывода на печать. Числа в расчётах не участвуют.
 
Ответить
СообщениеKostya_Ye, Спасибо. Хочу изменить отображение. Данное форматирование требуется только для вывода на печать. Числа в расчётах не участвуют.

Автор - Новосибирск
Дата добавления - 18.10.2019 в 09:01
Kostya_Ye Дата: Пятница, 18.10.2019, 09:03 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 18 ±
Замечаний: 0% ±

Excel 2016
Новосибирск,
в первом сообщении вы указали пробел после третьего знака, а не после четвертого, как все таки нужно?
приложите пример в файле эксель до 100 кб с ручным заполнение для разных вариантов как есть и как нужно получить в итоге.


Сообщение отредактировал Kostya_Ye - Пятница, 18.10.2019, 09:04
 
Ответить
СообщениеНовосибирск,
в первом сообщении вы указали пробел после третьего знака, а не после четвертого, как все таки нужно?
приложите пример в файле эксель до 100 кб с ручным заполнение для разных вариантов как есть и как нужно получить в итоге.

Автор - Kostya_Ye
Дата добавления - 18.10.2019 в 09:03
bmv98rus Дата: Пятница, 18.10.2019, 09:10 | Сообщение № 7
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
"0\ 0000"


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение"0\ 0000"

Автор - bmv98rus
Дата добавления - 18.10.2019 в 09:10
Новосибирск Дата: Пятница, 18.10.2019, 09:11 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2002
попробовал пользовательскиие форматы ##" "#### и 00 000 и 00" "0000. Чёт ничего у меня не меняет
 
Ответить
Сообщениепопробовал пользовательскиие форматы ##" "#### и 00 000 и 00" "0000. Чёт ничего у меня не меняет

Автор - Новосибирск
Дата добавления - 18.10.2019 в 09:11
Новосибирск Дата: Пятница, 18.10.2019, 09:18 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2002
Всё получилось. Спасибо, братцы. hands Сэкономили мне полжизни.


Сообщение отредактировал Новосибирск - Пятница, 18.10.2019, 09:36
 
Ответить
СообщениеВсё получилось. Спасибо, братцы. hands Сэкономили мне полжизни.

Автор - Новосибирск
Дата добавления - 18.10.2019 в 09:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Добавление пробела в текстовую ячейку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!