Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет общего количества отмеченных позиций - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет общего количества отмеченных позиций (Формулы/Formulas)
Подсчет общего количества отмеченных позиций
sivenkij Дата: Вторник, 29.10.2019, 21:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Попытаюсь объяснить, что мне нужно. Есть таблица - список товаров (столбец №1), их общее количество (столбец №2), следующие - дни месяца, некоторые из которых отмечаются "х". Нужно внизу таблицы подсчитать общую сумму товара на каждый день, если он выделен "х". Т.е. -(для примера) день первый, отмечены позиции в 11-ти строках, и необходимо что бы внизу суммировались все отмеченные позиции согласно значению из столбца №2 (в прилагаемом файле это лист2, сумму я вписал сам для понимания). Надеюсь понятно. Желательно формулой, в макросах не силен.
К сообщению приложен файл: 6112839.xlsx(27.2 Kb)


Сообщение отредактировал sivenkij - Вторник, 29.10.2019, 21:25
 
Ответить
СообщениеПопытаюсь объяснить, что мне нужно. Есть таблица - список товаров (столбец №1), их общее количество (столбец №2), следующие - дни месяца, некоторые из которых отмечаются "х". Нужно внизу таблицы подсчитать общую сумму товара на каждый день, если он выделен "х". Т.е. -(для примера) день первый, отмечены позиции в 11-ти строках, и необходимо что бы внизу суммировались все отмеченные позиции согласно значению из столбца №2 (в прилагаемом файле это лист2, сумму я вписал сам для понимания). Надеюсь понятно. Желательно формулой, в макросах не силен.

Автор - sivenkij
Дата добавления - 29.10.2019 в 21:23
dude Дата: Вторник, 29.10.2019, 22:32 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 172
Репутация: 25 ±
Замечаний: 0% ±

2016
Код
=СУММЕСЛИ(C2:C97;"х";$B$2:$B$97)
 
Ответить
Сообщение
Код
=СУММЕСЛИ(C2:C97;"х";$B$2:$B$97)

Автор - dude
Дата добавления - 29.10.2019 в 22:32
sivenkij Дата: Вторник, 29.10.2019, 22:40 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Не работает, где-то ошибка ;)
 
Ответить
СообщениеНе работает, где-то ошибка ;)

Автор - sivenkij
Дата добавления - 29.10.2019 в 22:40
Pelena Дата: Вторник, 29.10.2019, 22:46 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14715
Репутация: 3218 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Для стиля ссылок R1C1
Код
=СУММЕСЛИ(R[-96]C:R[-1]C;"х";R2C2:R97C2)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДля стиля ссылок R1C1
Код
=СУММЕСЛИ(R[-96]C:R[-1]C;"х";R2C2:R97C2)

Автор - Pelena
Дата добавления - 29.10.2019 в 22:46
sivenkij Дата: Вторник, 29.10.2019, 22:49 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Грандиозно! Спасибо! Ну и раз уж я зашел, я даже не заметил, а как вернуть стиль к привычному а не R1C1?
 
Ответить
СообщениеГрандиозно! Спасибо! Ну и раз уж я зашел, я даже не заметил, а как вернуть стиль к привычному а не R1C1?

Автор - sivenkij
Дата добавления - 29.10.2019 в 22:49
Pelena Дата: Вторник, 29.10.2019, 22:58 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14715
Репутация: 3218 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Файл -- Параметры -- Формулы -- снять галку Стиль ссылок R1C1


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл -- Параметры -- Формулы -- снять галку Стиль ссылок R1C1

Автор - Pelena
Дата добавления - 29.10.2019 в 22:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет общего количества отмеченных позиций (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!