Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/пoсчитать количествo четных/нечетных чисел - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » пoсчитать количествo четных/нечетных чисел (Формулы/Formulas)
пoсчитать количествo четных/нечетных чисел
3l33tka Дата: Четверг, 31.10.2019, 16:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
Напишите пожалуйста формулу,которая находит количество четных/нечетных чисел в столбце


3ll3tka

Сообщение отредактировал 3l33tka - Четверг, 31.10.2019, 20:43
 
Ответить
СообщениеНапишите пожалуйста формулу,которая находит количество четных/нечетных чисел в столбце

Автор - 3l33tka
Дата добавления - 31.10.2019 в 16:24
Nic70y Дата: Четверг, 31.10.2019, 16:41 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5700
Репутация: 1250 ±
Замечаний: 0% ±

ru13;10;03
массивные ессно
Код
=СУММ(--(СЧЁТЕСЛИ(A:A;ЕСЛИ(ОСТАТ(A:A;2);A:A))=1))
Код
=СУММ(--(СЧЁТЕСЛИ(A:A;ЕСЛИ(1-ОСТАТ(A:A;2);A:A))=1))


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Четверг, 31.10.2019, 16:42
 
Ответить
Сообщениемассивные ессно
Код
=СУММ(--(СЧЁТЕСЛИ(A:A;ЕСЛИ(ОСТАТ(A:A;2);A:A))=1))
Код
=СУММ(--(СЧЁТЕСЛИ(A:A;ЕСЛИ(1-ОСТАТ(A:A;2);A:A))=1))

Автор - Nic70y
Дата добавления - 31.10.2019 в 16:41
dude Дата: Четверг, 31.10.2019, 16:42 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 172
Репутация: 25 ±
Замечаний: 0% ±

2016
Код
=СУММ((СЧЁТЕСЛИ(A1:A20;A1:A20)=1)*(ОСТАТ(A1:A20;2)=0))

как массив
 
Ответить
Сообщение
Код
=СУММ((СЧЁТЕСЛИ(A1:A20;A1:A20)=1)*(ОСТАТ(A1:A20;2)=0))

как массив

Автор - dude
Дата добавления - 31.10.2019 в 16:42
bmv98rus Дата: Четверг, 31.10.2019, 17:07 | Сообщение № 4
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
IF(MOD(A:A,2),A:A)
изувер :-)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
IF(MOD(A:A,2),A:A)
изувер :-)

Автор - bmv98rus
Дата добавления - 31.10.2019 в 17:07
3l33tka Дата: Четверг, 31.10.2019, 18:13 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
массивные ессно

=СУММ(--(СЧЁТЕСЛИ(A:A;ЕСЛИ(ОСТАТ(A:A;2);A:A))=1))

=СУММ(--(СЧЁТЕСЛИ(A:A;ЕСЛИ(1-ОСТАТ(A:A;2);A:A))=1))

эта формула находит все четные/нечетные числа, а надо было НЕ ПОВТОРЯЮЩИЕСЯ ЧЕТНЫЕ/НЕЧЕТНЫЕ ЧИСЛА))


3ll3tka

Сообщение отредактировал 3l33tka - Четверг, 31.10.2019, 18:14
 
Ответить
Сообщение
массивные ессно

=СУММ(--(СЧЁТЕСЛИ(A:A;ЕСЛИ(ОСТАТ(A:A;2);A:A))=1))

=СУММ(--(СЧЁТЕСЛИ(A:A;ЕСЛИ(1-ОСТАТ(A:A;2);A:A))=1))

эта формула находит все четные/нечетные числа, а надо было НЕ ПОВТОРЯЮЩИЕСЯ ЧЕТНЫЕ/НЕЧЕТНЫЕ ЧИСЛА))

Автор - 3l33tka
Дата добавления - 31.10.2019 в 18:13
bmv98rus Дата: Четверг, 31.10.2019, 19:06 | Сообщение № 6
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
3l33tka, Вам бы файлик приложить и в нем еще и показать. что считаем, а что нет, что вы под НЕ ПОВТОРЯЮЩИЕСЯ понимаете...


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение3l33tka, Вам бы файлик приложить и в нем еще и показать. что считаем, а что нет, что вы под НЕ ПОВТОРЯЮЩИЕСЯ понимаете...

Автор - bmv98rus
Дата добавления - 31.10.2019 в 19:06
Pelena Дата: Четверг, 31.10.2019, 19:07 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 14761
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Варианты для чётных
Код
=СУММ(ЕСЛИ(ОСТАТ(A1:A20;2)=0;1/СЧЁТЕСЛИ(A1:A20;A1:A20);0))

Код
=СУММ(ЕСЛИ(ЕЧЁТН(+A1:A20);1/СЧЁТЕСЛИ(A1:A20;A1:A20);0))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВарианты для чётных
Код
=СУММ(ЕСЛИ(ОСТАТ(A1:A20;2)=0;1/СЧЁТЕСЛИ(A1:A20;A1:A20);0))

Код
=СУММ(ЕСЛИ(ЕЧЁТН(+A1:A20);1/СЧЁТЕСЛИ(A1:A20;A1:A20);0))

Автор - Pelena
Дата добавления - 31.10.2019 в 19:07
bmv98rus Дата: Четверг, 31.10.2019, 19:25 | Сообщение № 8
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
ну тогда количество четных
Код
=SUM(MOD(A1:A20+1;2)/COUNTIF(A1:A20;A1:A20))
и не четных
Код
=SUM(MOD(A1:A20;2)/COUNTIF(A1:A20;A1:A20))


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Четверг, 31.10.2019, 19:25
 
Ответить
Сообщениену тогда количество четных
Код
=SUM(MOD(A1:A20+1;2)/COUNTIF(A1:A20;A1:A20))
и не четных
Код
=SUM(MOD(A1:A20;2)/COUNTIF(A1:A20;A1:A20))

Автор - bmv98rus
Дата добавления - 31.10.2019 в 19:25
Nic70y Дата: Пятница, 01.11.2019, 13:05 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 5700
Репутация: 1250 ±
Замечаний: 0% ±

ru13;10;03
находит все
неправда Ваша (см. файл)
изувер :-)

чисел в столбце
а всем остальным:
изначально были перечислены функции, которые нужно было использовать в формуле,
но чет автор редактнул.
К сообщению приложен файл: 2690825.xlsx(8.8 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
находит все
неправда Ваша (см. файл)
изувер :-)

чисел в столбце
а всем остальным:
изначально были перечислены функции, которые нужно было использовать в формуле,
но чет автор редактнул.

Автор - Nic70y
Дата добавления - 01.11.2019 в 13:05
bmv98rus Дата: Пятница, 01.11.2019, 15:16 | Сообщение № 10
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
Nic70y, я на самом деле только про диапазон всего столбца :-)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеNic70y, я на самом деле только про диапазон всего столбца :-)

Автор - bmv98rus
Дата добавления - 01.11.2019 в 15:16
Светлый Дата: Пятница, 01.11.2019, 17:35 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 1339
Репутация: 333 ±
Замечаний: 0% ±

Excel 2010
Ну и мои массивные варианты:
Код
=СУММ(ЕЧЁТН(+A1:A20)/СЧЁТЕСЛИ(A1:A20;A1:A20))
Код
=СУММ(ЕНЕЧЁТ(+A1:A20)/СЧЁТЕСЛИ(A1:A20;A1:A20))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеНу и мои массивные варианты:
Код
=СУММ(ЕЧЁТН(+A1:A20)/СЧЁТЕСЛИ(A1:A20;A1:A20))
Код
=СУММ(ЕНЕЧЁТ(+A1:A20)/СЧЁТЕСЛИ(A1:A20;A1:A20))

Автор - Светлый
Дата добавления - 01.11.2019 в 17:35
Nic70y Дата: Пятница, 01.11.2019, 22:12 | Сообщение № 12
Группа: Друзья
Ранг: Экселист
Сообщений: 5700
Репутация: 1250 ±
Замечаний: 0% ±

ru13;10;03
только про диапазон всего столбца :-)
я таки понял :)
какой вопрос - такой и ответ (и типа студент)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
только про диапазон всего столбца :-)
я таки понял :)
какой вопрос - такой и ответ (и типа студент)

Автор - Nic70y
Дата добавления - 01.11.2019 в 22:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » пoсчитать количествo четных/нечетных чисел (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!