Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММЕСЛИМН к нескольким страницам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММЕСЛИМН к нескольким страницам (Формулы/Formulas)
СУММЕСЛИМН к нескольким страницам
lev-c1c Дата: Воскресенье, 03.11.2019, 02:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Надо просуммировать время по условию с нескольких страниц, EXCEL в лоб не может посчитать:

Код
=СУММЕСЛИМН(START:END!B2:B11;START:END!A2:A11;A2;START:END!C2:C11;B1)


Но может посчитать с помощью итераций что не очень удобно и не подходит для решения поставленной задачи ,потому как формулы будут заполнятся с помощью программы и можно вылезти за ограничение по длине формулы так как могут быть 100+ страниц

Код
=СУММЕСЛИМН(START!B2:B11;START!A2:A11;A2;START!C2:C11;B1)+СУММЕСЛИМН(MIDDLE!B2:B11;MIDDLE!A2:A11;A2;MIDDLE!C2:C11;B1)+СУММЕСЛИМН(END!B2:B11;END!A2:A11;A2;END!C2:C11;B1)


Существуют еще какие либо варианты решить эту задачу ?
К сообщению приложен файл: 2462007.xlsx(12.8 Kb)
 
Ответить
СообщениеНадо просуммировать время по условию с нескольких страниц, EXCEL в лоб не может посчитать:

Код
=СУММЕСЛИМН(START:END!B2:B11;START:END!A2:A11;A2;START:END!C2:C11;B1)


Но может посчитать с помощью итераций что не очень удобно и не подходит для решения поставленной задачи ,потому как формулы будут заполнятся с помощью программы и можно вылезти за ограничение по длине формулы так как могут быть 100+ страниц

Код
=СУММЕСЛИМН(START!B2:B11;START!A2:A11;A2;START!C2:C11;B1)+СУММЕСЛИМН(MIDDLE!B2:B11;MIDDLE!A2:A11;A2;MIDDLE!C2:C11;B1)+СУММЕСЛИМН(END!B2:B11;END!A2:A11;A2;END!C2:C11;B1)


Существуют еще какие либо варианты решить эту задачу ?

Автор - lev-c1c
Дата добавления - 03.11.2019 в 02:08
bmv98rus Дата: Воскресенье, 03.11.2019, 08:16 | Сообщение № 2
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
думаете что-то поменялось с тех пор? Вы там даже не отписались.

Если смущает длина, то список листов можно хранить хоть в именах, хоть на листе
Код
=SUM(SUMIFS(INDIRECT(SheetsList&"!B2:B11");INDIRECT(SheetsList&"!A2:A11");A2;INDIRECT(SheetsList&"!C2:C11");B1))

хоть в именах, хоть на листе
Код
=SUM(SUMIFS(INDIRECT(D19:D21&"!B2:B11");INDIRECT(D19:D21&"!A2:A11");A2;INDIRECT(D19:D21&"!C2:C11");B1))
К сообщению приложен файл: Copy_of_1249.xlsx(13.0 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениедумаете что-то поменялось с тех пор? Вы там даже не отписались.

Если смущает длина, то список листов можно хранить хоть в именах, хоть на листе
Код
=SUM(SUMIFS(INDIRECT(SheetsList&"!B2:B11");INDIRECT(SheetsList&"!A2:A11");A2;INDIRECT(SheetsList&"!C2:C11");B1))

хоть в именах, хоть на листе
Код
=SUM(SUMIFS(INDIRECT(D19:D21&"!B2:B11");INDIRECT(D19:D21&"!A2:A11");A2;INDIRECT(D19:D21&"!C2:C11");B1))

Автор - bmv98rus
Дата добавления - 03.11.2019 в 08:16
lev-c1c Дата: Воскресенье, 03.11.2019, 23:37 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо помогло, но просто вставкой формула не заработала спасибо что приложили вариант
 
Ответить
СообщениеСпасибо помогло, но просто вставкой формула не заработала спасибо что приложили вариант

Автор - lev-c1c
Дата добавления - 03.11.2019 в 23:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММЕСЛИМН к нескольким страницам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!