Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать сумму в диапазоне дат - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сумму в диапазоне дат (Формулы/Formulas)
Посчитать сумму в диапазоне дат
l-lisa Дата: Вторник, 05.11.2019, 19:10 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 225
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
здравствуйте, подскажите какую формулу можно использовать, чтобы посчитать сумму за последние шесть месяцев? не используя просто функцию сумм() с выбором необходимых дат.....дат может быть много и они могут быть расположены непоследовательно
К сообщению приложен файл: 3174401.xlsx(7.5 Kb)
 
Ответить
Сообщениездравствуйте, подскажите какую формулу можно использовать, чтобы посчитать сумму за последние шесть месяцев? не используя просто функцию сумм() с выбором необходимых дат.....дат может быть много и они могут быть расположены непоследовательно

Автор - l-lisa
Дата добавления - 05.11.2019 в 19:10
krosav4ig Дата: Вторник, 05.11.2019, 19:21 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2198
Репутация: 916 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Здравствуйте
Код
=СУММПРОИЗВ((ДАТАМЕС(+B1:J1;6)>=СЕГОДНЯ())*B2:J2)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
СообщениеЗдравствуйте
Код
=СУММПРОИЗВ((ДАТАМЕС(+B1:J1;6)>=СЕГОДНЯ())*B2:J2)

Автор - krosav4ig
Дата добавления - 05.11.2019 в 19:21
l-lisa Дата: Вторник, 05.11.2019, 19:32 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 225
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
спасибо, ноу меня выдает отшибку #знач
К сообщению приложен файл: 0070560.xlsx(7.9 Kb)


Сообщение отредактировал l-lisa - Вторник, 05.11.2019, 19:32
 
Ответить
Сообщениеспасибо, ноу меня выдает отшибку #знач

Автор - l-lisa
Дата добавления - 05.11.2019 в 19:32
Pelena Дата: Вторник, 05.11.2019, 19:55 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14761
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Странно, у меня считает
К сообщению приложен файл: 5936160.jpg(18.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеСтранно, у меня считает

Автор - Pelena
Дата добавления - 05.11.2019 в 19:55
l-lisa Дата: Вторник, 05.11.2019, 20:53 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 225
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
А скажите пожалуйста, что означает знак + перед диапазоном в функции датамес()?
 
Ответить
СообщениеА скажите пожалуйста, что означает знак + перед диапазоном в функции датамес()?

Автор - l-lisa
Дата добавления - 05.11.2019 в 20:53
Pelena Дата: Вторник, 05.11.2019, 21:23 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14761
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
знак + перед диапазоном
позволяет "скормить" функции ДАТАМЕС массив в качестве первого аргумента


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
знак + перед диапазоном
позволяет "скормить" функции ДАТАМЕС массив в качестве первого аргумента

Автор - Pelena
Дата добавления - 05.11.2019 в 21:23
bmv98rus Дата: Вторник, 05.11.2019, 21:30 | Сообщение № 7
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
позволяет "скормить" функции ДАТАМЕС массив
а не преобразовать этот массив в даты?


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
позволяет "скормить" функции ДАТАМЕС массив
а не преобразовать этот массив в даты?

Автор - bmv98rus
Дата добавления - 05.11.2019 в 21:30
Pelena Дата: Вторник, 05.11.2019, 21:47 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 14761
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Даже если в диапазоне будут правильные даты, ДАТАМЕС не примет диапазон в качестве первого аргумента


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДаже если в диапазоне будут правильные даты, ДАТАМЕС не примет диапазон в качестве первого аргумента

Автор - Pelena
Дата добавления - 05.11.2019 в 21:47
l-lisa Дата: Вторник, 05.11.2019, 21:57 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 225
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
не пойму этого выражения: ДАТАМЕС(+B1:J1;6)>=СЕГОДНЯ()....ведь надо же получить даты еньшие или равно сегодня()
 
Ответить
Сообщениене пойму этого выражения: ДАТАМЕС(+B1:J1;6)>=СЕГОДНЯ()....ведь надо же получить даты еньшие или равно сегодня()

Автор - l-lisa
Дата добавления - 05.11.2019 в 21:57
Pelena Дата: Вторник, 05.11.2019, 22:08 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 14761
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
К датам прибавляется 6 месяцев, и уже эти даты должны быть больше сегодняшней


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеК датам прибавляется 6 месяцев, и уже эти даты должны быть больше сегодняшней

Автор - Pelena
Дата добавления - 05.11.2019 в 22:08
l-lisa Дата: Вторник, 05.11.2019, 22:19 | Сообщение № 11
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 225
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
поняла, спасибо большое!
 
Ответить
Сообщениепоняла, спасибо большое!

Автор - l-lisa
Дата добавления - 05.11.2019 в 22:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сумму в диапазоне дат (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!