Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/массив, чтоб перенести остатки счета в баланс - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » массив, чтоб перенести остатки счета в баланс (Формулы/Formulas)
массив, чтоб перенести остатки счета в баланс
eqo03 Дата: Среда, 06.11.2019, 23:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер!
В отчетную форму листа F1 нужно вставить формулу массива. Где из листа DCedveli выбрать остатки счета и перенести в Отчет, но с условием сложения и вычитания. Желтым маркером показаны результаты сложения
К сообщению приложен файл: Elave.xls(71.5 Kb)


«ДЕБЕТ — СЛЕВА, КРЕДИТ — СПРАВА»
 
Ответить
СообщениеДобрый вечер!
В отчетную форму листа F1 нужно вставить формулу массива. Где из листа DCedveli выбрать остатки счета и перенести в Отчет, но с условием сложения и вычитания. Желтым маркером показаны результаты сложения

Автор - eqo03
Дата добавления - 06.11.2019 в 23:07
Светлый Дата: Четверг, 07.11.2019, 06:18 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1368
Репутация: 363 ±
Замечаний: 0% ±

Excel 2010, 2013
Доброе утро!
По имеющейся информации до лучшего не додумался:
Код
=ВПР(101;DCedveli!B:I;7;)+ВПР(103;DCedveli!B:I;7;)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДоброе утро!
По имеющейся информации до лучшего не додумался:
Код
=ВПР(101;DCedveli!B:I;7;)+ВПР(103;DCedveli!B:I;7;)

Автор - Светлый
Дата добавления - 07.11.2019 в 06:18
eqo03 Дата: Четверг, 07.11.2019, 09:19 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата Светлый, 07.11.2019 в 06:18, в сообщении № 2 ()
По имеющейся информации до лучшего не додумался:

То что нужно. Спасибо))) огромное)))


«ДЕБЕТ — СЛЕВА, КРЕДИТ — СПРАВА»
 
Ответить
Сообщение
Цитата Светлый, 07.11.2019 в 06:18, в сообщении № 2 ()
По имеющейся информации до лучшего не додумался:

То что нужно. Спасибо))) огромное)))

Автор - eqo03
Дата добавления - 07.11.2019 в 09:19
eqo03 Дата: Воскресенье, 10.11.2019, 18:37 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата Светлый, 07.11.2019 в 06:18, в сообщении № 2 ()
=ВПР(101;DCedveli!B:I;7;)+ВПР(103;DCedveli!B:I;7;)

формула превосходно работает, но когда счет баланса указан не в возрастающем порядке, или какой то определенный счет не использован в проводках, то расчет не верный. Счета нет в проводках, но формула суммирует последнюю сумму рабочего счета. Т.е. счет 221 - 5000, счет 222 - 0 или отсутствует, происходит суммирование 5000+5000. Если счет указан 2 раза, то видит только первую позицию. Даже не знаю - смогла объяснить


«ДЕБЕТ — СЛЕВА, КРЕДИТ — СПРАВА»
 
Ответить
Сообщение
Цитата Светлый, 07.11.2019 в 06:18, в сообщении № 2 ()
=ВПР(101;DCedveli!B:I;7;)+ВПР(103;DCedveli!B:I;7;)

формула превосходно работает, но когда счет баланса указан не в возрастающем порядке, или какой то определенный счет не использован в проводках, то расчет не верный. Счета нет в проводках, но формула суммирует последнюю сумму рабочего счета. Т.е. счет 221 - 5000, счет 222 - 0 или отсутствует, происходит суммирование 5000+5000. Если счет указан 2 раза, то видит только первую позицию. Даже не знаю - смогла объяснить

Автор - eqo03
Дата добавления - 10.11.2019 в 18:37
Светлый Дата: Понедельник, 11.11.2019, 06:46 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1368
Репутация: 363 ±
Замечаний: 0% ±

Excel 2010, 2013
А Вы в те столбцы вводите данные?
Проверил Ваши числа. Всё работает, как должно работать. Но я заносил числа в правильные столбцы.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеА Вы в те столбцы вводите данные?
Проверил Ваши числа. Всё работает, как должно работать. Но я заносил числа в правильные столбцы.

Автор - Светлый
Дата добавления - 11.11.2019 в 06:46
eqo03 Дата: Понедельник, 11.11.2019, 09:58 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата Светлый, 11.11.2019 в 06:46, в сообщении № 5 ()
А Вы в те столбцы вводите данные?
Проверил Ваши числа. Всё работает, как должно работать. Но я заносил числа в правильные столбцы.

Проблема не в столбце, проблемы в очередности. если. например после 200 счета занести 150 счет, то происходит не верный расчет. Иди если указать 2 одинаковых счета один в начале, а другой позже. то второй счет не суммирует. Если счет не указан в столбце листа DCedveli но в таблице баланса указано что надо суммировать все счета данного класса - опять возникает проблема. (сумма отсутствующего счета берется как сумма последнего действующего счета) - 200 =500, 201 = 1000, 202 = нет, 203 = 400. Рассчитывает так 500+1000+1000+400


«ДЕБЕТ — СЛЕВА, КРЕДИТ — СПРАВА»
 
Ответить
Сообщение
Цитата Светлый, 11.11.2019 в 06:46, в сообщении № 5 ()
А Вы в те столбцы вводите данные?
Проверил Ваши числа. Всё работает, как должно работать. Но я заносил числа в правильные столбцы.

Проблема не в столбце, проблемы в очередности. если. например после 200 счета занести 150 счет, то происходит не верный расчет. Иди если указать 2 одинаковых счета один в начале, а другой позже. то второй счет не суммирует. Если счет не указан в столбце листа DCedveli но в таблице баланса указано что надо суммировать все счета данного класса - опять возникает проблема. (сумма отсутствующего счета берется как сумма последнего действующего счета) - 200 =500, 201 = 1000, 202 = нет, 203 = 400. Рассчитывает так 500+1000+1000+400

Автор - eqo03
Дата добавления - 11.11.2019 в 09:58
eqo03 Дата: Понедельник, 11.11.2019, 10:02 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=ВПР(101;DCedveli!B:I;7;)+ВПР(103;DCedveli!B:I;7;)

этот расчет я использую во многих других таблицах, Очень удобная и легкая формула. Спасибо


«ДЕБЕТ — СЛЕВА, КРЕДИТ — СПРАВА»
 
Ответить
Сообщение
=ВПР(101;DCedveli!B:I;7;)+ВПР(103;DCedveli!B:I;7;)

этот расчет я использую во многих других таблицах, Очень удобная и легкая формула. Спасибо

Автор - eqo03
Дата добавления - 11.11.2019 в 10:02
eqo03 Дата: Понедельник, 11.11.2019, 10:17 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата Светлый, 11.11.2019 в 06:46, в сообщении № 5 ()
=ВПР(101;DCedveli!B:I;7;)+ВПР(103;DCedveli!B:I;7;)

Так нагляднее
К сообщению приложен файл: 5059173.xls(57.0 Kb)


«ДЕБЕТ — СЛЕВА, КРЕДИТ — СПРАВА»
 
Ответить
Сообщение
Цитата Светлый, 11.11.2019 в 06:46, в сообщении № 5 ()
=ВПР(101;DCedveli!B:I;7;)+ВПР(103;DCedveli!B:I;7;)

Так нагляднее

Автор - eqo03
Дата добавления - 11.11.2019 в 10:17
eqo03 Дата: Среда, 13.11.2019, 19:06 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
сделала через сумма производные, а можно проще?
Код
=СУММПРОИЗВ((DCedveli!B5:B18=101)*DCedveli!H5:H18)+СУММПРОИЗВ((DCedveli!B5:B18=102)*DCedveli!H5:H18)+СУММПРОИЗВ((DCedveli!B5:B18=103)*DCedveli!H5:H18)+СУММПРОИЗВ((DCedveli!B5:B18=104)*DCedveli!H5:H18)+СУММПРОИЗВ((DCedveli!B5:B18=105)*DCedveli!H5:H18)
К сообщению приложен файл: 8912902.xls(54.5 Kb)


«ДЕБЕТ — СЛЕВА, КРЕДИТ — СПРАВА»

Сообщение отредактировал eqo03 - Среда, 13.11.2019, 19:08
 
Ответить
Сообщениесделала через сумма производные, а можно проще?
Код
=СУММПРОИЗВ((DCedveli!B5:B18=101)*DCedveli!H5:H18)+СУММПРОИЗВ((DCedveli!B5:B18=102)*DCedveli!H5:H18)+СУММПРОИЗВ((DCedveli!B5:B18=103)*DCedveli!H5:H18)+СУММПРОИЗВ((DCedveli!B5:B18=104)*DCedveli!H5:H18)+СУММПРОИЗВ((DCedveli!B5:B18=105)*DCedveli!H5:H18)

Автор - eqo03
Дата добавления - 13.11.2019 в 19:06
Pelena Дата: Среда, 13.11.2019, 19:42 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 14877
Репутация: 3251 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Можно немного короче
Код
=СУММПРОИЗВ((DCedveli!B5:B18>=101)*(DCedveli!B5:B18<=105)*DCedveli!H5:H18)

Или для Excel 2010 и выше
Код
=СУММЕСЛИМН(DCedveli!H5:H18;DCedveli!B5:B18;">=101";DCedveli!B5:B18;"<=105")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожно немного короче
Код
=СУММПРОИЗВ((DCedveli!B5:B18>=101)*(DCedveli!B5:B18<=105)*DCedveli!H5:H18)

Или для Excel 2010 и выше
Код
=СУММЕСЛИМН(DCedveli!H5:H18;DCedveli!B5:B18;">=101";DCedveli!B5:B18;"<=105")

Автор - Pelena
Дата добавления - 13.11.2019 в 19:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » массив, чтоб перенести остатки счета в баланс (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!