Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Форматирование чисел с разделением разрядов и точкой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Форматирование чисел с разделением разрядов и точкой (Формулы/Formulas)
Форматирование чисел с разделением разрядов и точкой
Mezhik Дата: Пятница, 08.11.2019, 14:45 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 20% ±

Добрый день!
Прошу подсказать, поступил файл с большим массивом цифр. Все их нужно перевести в необходимый единый формат, через стандартные функции экселя сделать не получается. К примеру: число -1093,4 перевести в формат -1 093.40 Есть ли какая то формула или возможно я упустил какой то стандартный метод, прошу помочь.
К сообщению приложен файл: 111111111111.xlsx(8.1 Kb)


Сообщение отредактировал Pelena - Суббота, 09.11.2019, 22:08
 
Ответить
СообщениеДобрый день!
Прошу подсказать, поступил файл с большим массивом цифр. Все их нужно перевести в необходимый единый формат, через стандартные функции экселя сделать не получается. К примеру: число -1093,4 перевести в формат -1 093.40 Есть ли какая то формула или возможно я упустил какой то стандартный метод, прошу помочь.

Автор - Mezhik
Дата добавления - 08.11.2019 в 14:45
китин Дата: Пятница, 08.11.2019, 15:07 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5905
Репутация: 918 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вот только так наспех придумал
Код
=ЕСЛИОШИБКА(ТЕКСТ(ЛЕВБ(A2;ПОИСК(",";A2)-1);"# ##0")&"."&ПСТР(A2;ПОИСК(",";A2)+1;ДЛСТР(A2))&"0";ТЕКСТ(A2;"# ##0")&".00")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениевот только так наспех придумал
Код
=ЕСЛИОШИБКА(ТЕКСТ(ЛЕВБ(A2;ПОИСК(",";A2)-1);"# ##0")&"."&ПСТР(A2;ПОИСК(",";A2)+1;ДЛСТР(A2))&"0";ТЕКСТ(A2;"# ##0")&".00")

Автор - китин
Дата добавления - 08.11.2019 в 15:07
Mezhik Дата: Пятница, 08.11.2019, 15:27 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 20% ±

китин, большое вам спасибо, то что нужно было)))
 
Ответить
Сообщениекитин, большое вам спасибо, то что нужно было)))

Автор - Mezhik
Дата добавления - 08.11.2019 в 15:27
bmv98rus Дата: Пятница, 08.11.2019, 15:37 | Сообщение № 4
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2720
Репутация: 467 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUBSTITUTE(TEXT(A2;"# ##0,00");",";".")


[p.s.]Виктор бы порадовался названию темы :D [/p.s.]
[admin]Надеюсь Виктор успел порадоваться)
Исправила название[/admin]


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Пятница, 08.11.2019, 18:28
 
Ответить
Сообщение
Код
=SUBSTITUTE(TEXT(A2;"# ##0,00");",";".")


[p.s.]Виктор бы порадовался названию темы :D [/p.s.]
[admin]Надеюсь Виктор успел порадоваться)
Исправила название[/admin]

Автор - bmv98rus
Дата добавления - 08.11.2019 в 15:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Форматирование чисел с разделением разрядов и точкой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!