Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сделать коррекцию адресов (строк) в одном табе при встав - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать коррекцию адресов (строк) в одном табе при встав (Формулы/Formulas)
Как сделать коррекцию адресов (строк) в одном табе при встав
LouD Дата: Понедельник, 11.11.2019, 18:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Как сделать коррекцию адресов (строк) в одном табе при вставке строки в другом?

Суть в следующем:
В одном табе ведется сводный учет-анализ.
Исходные данные для него - в другом табе. При этом, чтобы исходные данные попадали в нужные ячейки в анализе, вручную указывается адрес.
Формула в табе анализа (в каждой ячейке для сумм) выглядит так:
=СУММЕСЛИМН('Список операций'!$E$2:$E$429;'Список операций'!$F$2:$F$429;ПОДСТАВИТЬ(АДРЕС(СТРОКА();СТОЛБЕЦ());"$";""))

И вот возникла ситуация (в принципе логичная, наверное) - был добавлен еще один подвид данных в анализе, вставлены несколько строк. И все, в табе исходных данных все поехало :(
Соответственно желание, чтобы как в пределах одного таба ир вставке новых строк и колонок адреса в формулах автоматически меняются, также сделать и в моей ситуации, в разных табах.

P.S. Вот структура файла - рисунок на хостинге: https://priscree.ru/img/e32cccad723e2d.jpg

P.P.S. К сожалению, прикрепить целый файл не могу, это реальные финансовые данные компании.
 
Ответить
СообщениеКак сделать коррекцию адресов (строк) в одном табе при вставке строки в другом?

Суть в следующем:
В одном табе ведется сводный учет-анализ.
Исходные данные для него - в другом табе. При этом, чтобы исходные данные попадали в нужные ячейки в анализе, вручную указывается адрес.
Формула в табе анализа (в каждой ячейке для сумм) выглядит так:
=СУММЕСЛИМН('Список операций'!$E$2:$E$429;'Список операций'!$F$2:$F$429;ПОДСТАВИТЬ(АДРЕС(СТРОКА();СТОЛБЕЦ());"$";""))

И вот возникла ситуация (в принципе логичная, наверное) - был добавлен еще один подвид данных в анализе, вставлены несколько строк. И все, в табе исходных данных все поехало :(
Соответственно желание, чтобы как в пределах одного таба ир вставке новых строк и колонок адреса в формулах автоматически меняются, также сделать и в моей ситуации, в разных табах.

P.S. Вот структура файла - рисунок на хостинге: https://priscree.ru/img/e32cccad723e2d.jpg

P.P.S. К сожалению, прикрепить целый файл не могу, это реальные финансовые данные компании.

Автор - LouD
Дата добавления - 11.11.2019 в 18:07
bmv98rus Дата: Понедельник, 11.11.2019, 18:45 | Сообщение № 2
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2787
Репутация: 479 ±
Замечаний: 0% ±

Excel 2013/2016
Кросс на планете


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Понедельник, 11.11.2019, 19:25
 
Ответить
СообщениеКросс на планете

Автор - bmv98rus
Дата добавления - 11.11.2019 в 18:45
Pelena Дата: Понедельник, 11.11.2019, 18:50 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14863
Репутация: 3248 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
LouD, оформите формулу тегами с помощью кнопки fx в режиме правки поста и прикрепите файл с небольшим примером а соответствии с Правилами форума


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеLouD, оформите формулу тегами с помощью кнопки fx в режиме правки поста и прикрепите файл с небольшим примером а соответствии с Правилами форума

Автор - Pelena
Дата добавления - 11.11.2019 в 18:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать коррекцию адресов (строк) в одном табе при встав (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!