Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/есть ли функция подсчета количества слагаемых? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » есть ли функция подсчета количества слагаемых? (Формулы/Formulas)
есть ли функция подсчета количества слагаемых?
Wildmechanic Дата: Вторник, 12.11.2019, 08:20 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго здравия!
вопрос такой...
В несколько ячеек (пусть с 1А по 1Z, но диапазон может быть и больше) первой строки вводятся исходные данные - числа - "Слагаемые".
В ячейки первой строки с 1AA по 1АZ (диапазон так же может быть любой) вводятся формулы - считается сумма некоторого, в каждой ячейке разного, набора этих чисел. (например, (1АА)=(1А)+(1С)+(1D) ; (1AB)=(1F)+(1G)+(1H)+(1J)+3*(1K)+(1R)+5*(1S)+(1Y) и так далее).
В ячейку 1BA вводится сумма всех этих сумм ("Конечная сумма")

Возможно ли подсчитать, сколько раз каждое "Слагаемое" используется в "Конечной сумме"?
В идеале - ячейках второй строки, под каждым слагаемым, должно "выдаваться" количество раз использования этого слагаемого в "Конечной сумме".

не представляю даже, в каком направлении надо "копать"...

Файл не прикрепляю - его пока нет...


"Сделать сложно - это очень просто, а вот сделать просто - это очень сложно" (С)

Сообщение отредактировал Wildmechanic - Вторник, 12.11.2019, 08:23
 
Ответить
СообщениеДоброго здравия!
вопрос такой...
В несколько ячеек (пусть с 1А по 1Z, но диапазон может быть и больше) первой строки вводятся исходные данные - числа - "Слагаемые".
В ячейки первой строки с 1AA по 1АZ (диапазон так же может быть любой) вводятся формулы - считается сумма некоторого, в каждой ячейке разного, набора этих чисел. (например, (1АА)=(1А)+(1С)+(1D) ; (1AB)=(1F)+(1G)+(1H)+(1J)+3*(1K)+(1R)+5*(1S)+(1Y) и так далее).
В ячейку 1BA вводится сумма всех этих сумм ("Конечная сумма")

Возможно ли подсчитать, сколько раз каждое "Слагаемое" используется в "Конечной сумме"?
В идеале - ячейках второй строки, под каждым слагаемым, должно "выдаваться" количество раз использования этого слагаемого в "Конечной сумме".

не представляю даже, в каком направлении надо "копать"...

Файл не прикрепляю - его пока нет...

Автор - Wildmechanic
Дата добавления - 12.11.2019 в 08:20
bmv98rus Дата: Вторник, 12.11.2019, 11:26 | Сообщение № 2
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2785
Репутация: 479 ±
Замечаний: 0% ±

Excel 2013/2016
Файл не прикрепляю - его пока нет...

решение не выкладываю, его пока тоже нет.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Файл не прикрепляю - его пока нет...

решение не выкладываю, его пока тоже нет.

Автор - bmv98rus
Дата добавления - 12.11.2019 в 11:26
Светлый Дата: Вторник, 12.11.2019, 18:50 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1365
Репутация: 361 ±
Замечаний: 0% ±

Excel 2010, 2013
Доброго!
Для офиса 2013 и выше формула массива. Что-то типа этого:
Код
=СУММ(ЕСЛИОШИБКА(ДЛСТР(Ф.ТЕКСТ($AA1:$AZ1))-ДЛСТР(ПОДСТАВИТЬ(Ф.ТЕКСТ($AA1:$AZ1);АДРЕС(1;СТОЛБЕЦ(A1);4);));))/2
но будет считать неправильно, если формулы из более широкого диапазона (AA1) или будет использована абсолютная адресация для строки (A$1)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДоброго!
Для офиса 2013 и выше формула массива. Что-то типа этого:
Код
=СУММ(ЕСЛИОШИБКА(ДЛСТР(Ф.ТЕКСТ($AA1:$AZ1))-ДЛСТР(ПОДСТАВИТЬ(Ф.ТЕКСТ($AA1:$AZ1);АДРЕС(1;СТОЛБЕЦ(A1);4);));))/2
но будет считать неправильно, если формулы из более широкого диапазона (AA1) или будет использована абсолютная адресация для строки (A$1)

Автор - Светлый
Дата добавления - 12.11.2019 в 18:50
bmv98rus Дата: Вторник, 12.11.2019, 20:22 | Сообщение № 4
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2785
Репутация: 479 ±
Замечаний: 0% ±

Excel 2013/2016
Светлый, что-то мне подсказывает что 5*(1S) ну или как мы запишем 5*S1 это 5 и мало посчитать сколько раз в формуле использовано S1, а нужно посчитать коэффициенты, стоящие рядом. Без примера с примером ручного подсчета можно только предполагать, что надо.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеСветлый, что-то мне подсказывает что 5*(1S) ну или как мы запишем 5*S1 это 5 и мало посчитать сколько раз в формуле использовано S1, а нужно посчитать коэффициенты, стоящие рядом. Без примера с примером ручного подсчета можно только предполагать, что надо.

Автор - bmv98rus
Дата добавления - 12.11.2019 в 20:22
Светлый Дата: Вторник, 12.11.2019, 21:39 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1365
Репутация: 361 ±
Замечаний: 0% ±

Excel 2010, 2013
можно только предполагать, что надо
совершенно согласен. Попробовал показать
в каком направлении надо "копать"
Если направление не то, будем копать в другую сторону. Этакие диггеры-формулисты. :)


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
можно только предполагать, что надо
совершенно согласен. Попробовал показать
в каком направлении надо "копать"
Если направление не то, будем копать в другую сторону. Этакие диггеры-формулисты. :)

Автор - Светлый
Дата добавления - 12.11.2019 в 21:39
Wildmechanic Дата: Среда, 13.11.2019, 08:13 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, В формуле ровным счетом ничего не понятно, но попробую разобраться... Спасибо!


"Сделать сложно - это очень просто, а вот сделать просто - это очень сложно" (С)
 
Ответить
СообщениеСветлый, В формуле ровным счетом ничего не понятно, но попробую разобраться... Спасибо!

Автор - Wildmechanic
Дата добавления - 13.11.2019 в 08:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » есть ли функция подсчета количества слагаемых? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!