Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Скрыть нумерацию при незаполненных строках справа от ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Скрыть нумерацию при незаполненных строках справа от ячейки (Формулы/Formulas)
Скрыть нумерацию при незаполненных строках справа от ячейки
DrMini Дата: Вторник, 12.11.2019, 11:01 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 394
Репутация: 5 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019,
Здравствуйте форумчане.
Помогите пожалуйста скрыть данные ячеек (выделил жёлтым) если незаполненна строка с права от ячейки.
Может возможно как-то формулу "допилить" или через формат ячейки?
К сообщению приложен файл: 20191112.xlsm(24.4 Kb)
 
Ответить
СообщениеЗдравствуйте форумчане.
Помогите пожалуйста скрыть данные ячеек (выделил жёлтым) если незаполненна строка с права от ячейки.
Может возможно как-то формулу "допилить" или через формат ячейки?

Автор - DrMini
Дата добавления - 12.11.2019 в 11:01
китин Дата: Вторник, 12.11.2019, 11:16 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5968
Репутация: 927 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так надо?
Код
=ЕСЛИ($B6="";"";ЕСЛИ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;B5);A5+1;A5))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак надо?
Код
=ЕСЛИ($B6="";"";ЕСЛИ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;B5);A5+1;A5))

Автор - китин
Дата добавления - 12.11.2019 в 11:16
DrMini Дата: Вторник, 12.11.2019, 11:29 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 394
Репутация: 5 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019,
так надо?

Да. Большое спасибо. Работает. Единственное желание (если можно) продолжать нумерацию если случайно пропустили строку.
К сообщению приложен файл: 20191112-2.xlsm(24.4 Kb)
 
Ответить
Сообщение
так надо?

Да. Большое спасибо. Работает. Единственное желание (если можно) продолжать нумерацию если случайно пропустили строку.

Автор - DrMini
Дата добавления - 12.11.2019 в 11:29
alexa1965 Дата: Вторник, 12.11.2019, 12:08 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 152
Репутация: 8 ±
Замечаний: 0% ±

2003, 2010
Для ячейки А5 =ЕСЛИ(ЕПУСТО(B5);"";СЧЁТЗ(B$5:$B5))
наверно так надо
К сообщению приложен файл: 4296297.xlsm(24.4 Kb)


Главное не быть балабастиком

Сообщение отредактировал alexa1965 - Вторник, 12.11.2019, 12:10
 
Ответить
СообщениеДля ячейки А5 =ЕСЛИ(ЕПУСТО(B5);"";СЧЁТЗ(B$5:$B5))
наверно так надо

Автор - alexa1965
Дата добавления - 12.11.2019 в 12:08
amfor Дата: Вторник, 12.11.2019, 12:15 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 53 ±
Замечаний: 0% ±

Excel 2016
Так?
Код
=ЕСЛИ($B6="";"";ЕСЛИ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;B5);A5+1;СЧЁТ($A$5:A5)+1))
К сообщению приложен файл: 9588045.xlsm(24.9 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеТак?
Код
=ЕСЛИ($B6="";"";ЕСЛИ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;B5);A5+1;СЧЁТ($A$5:A5)+1))

Автор - amfor
Дата добавления - 12.11.2019 в 12:15
DrMini Дата: Вторник, 12.11.2019, 12:24 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 394
Репутация: 5 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019,
так надо

Спасибо за ответ. Когда выбираю фильтрами то подсчёт строк идёт не с единицы.
 
Ответить
Сообщение
так надо

Спасибо за ответ. Когда выбираю фильтрами то подсчёт строк идёт не с единицы.

Автор - DrMini
Дата добавления - 12.11.2019 в 12:24
alexa1965 Дата: Вторник, 12.11.2019, 12:27 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 152
Репутация: 8 ±
Замечаний: 0% ±

2003, 2010
Когда выбираю фильтрами то подсчёт строк идёт не с единицы.

Не понимаю вопроса? Если исключить пустые строки в столбце В, то покажет ФИО по порядку


Главное не быть балабастиком
 
Ответить
Сообщение
Когда выбираю фильтрами то подсчёт строк идёт не с единицы.

Не понимаю вопроса? Если исключить пустые строки в столбце В, то покажет ФИО по порядку

Автор - alexa1965
Дата добавления - 12.11.2019 в 12:27
DrMini Дата: Вторник, 12.11.2019, 12:27 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 394
Репутация: 5 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019,

Спасибо за ответ. Когда выбираю фильтрами то подсчёт строк идёт не с единицы. А надо с "1" и по порядку. Важно количество строк. Диспетчера смотрят по последнему числу в колонке "A".
 
Ответить
Сообщение
Спасибо за ответ. Когда выбираю фильтрами то подсчёт строк идёт не с единицы. А надо с "1" и по порядку. Важно количество строк. Диспетчера смотрят по последнему числу в колонке "A".

Автор - DrMini
Дата добавления - 12.11.2019 в 12:27
DrMini Дата: Вторник, 12.11.2019, 12:33 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 394
Репутация: 5 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019,
Не понимаю вопроса?

Первый вариант от китин, работает, как надо. Но проблема если пропустить одну строку. У нас приходит мастер и задаёт фильтрами "месяц" и например прорывы. Ему надо узнать количество прорывов.
 
Ответить
Сообщение
Не понимаю вопроса?

Первый вариант от китин, работает, как надо. Но проблема если пропустить одну строку. У нас приходит мастер и задаёт фильтрами "месяц" и например прорывы. Ему надо узнать количество прорывов.

Автор - DrMini
Дата добавления - 12.11.2019 в 12:33
gling Дата: Вторник, 12.11.2019, 13:09 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1985
Репутация: 493 ±
Замечаний: 0% ±

2010
А может так надо?
Код
=ЕСЛИ(B5="";"";ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;$B$5:B5))
Цитата
Ему надо узнать количество прорывов.
Или нужно ещё както пустые посчитать?


ЯД-41001506838083

Сообщение отредактировал gling - Вторник, 12.11.2019, 13:12
 
Ответить
СообщениеА может так надо?
Код
=ЕСЛИ(B5="";"";ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;$B$5:B5))
Цитата
Ему надо узнать количество прорывов.
Или нужно ещё както пустые посчитать?

Автор - gling
Дата добавления - 12.11.2019 в 13:09
DrMini Дата: Вторник, 12.11.2019, 13:16 | Сообщение № 11
Группа: Проверенные
Ранг: Обитатель
Сообщений: 394
Репутация: 5 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019,
gling,
А может так надо?

ДА! Именно так и надо. Пока проверил на кусочке файла. Сегодня "привинчу" на рабочую базу. Поработаем. Поглядим. Ещё раз Всем огромное СПАСИБО!
 
Ответить
Сообщениеgling,
А может так надо?

ДА! Именно так и надо. Пока проверил на кусочке файла. Сегодня "привинчу" на рабочую базу. Поработаем. Поглядим. Ещё раз Всем огромное СПАСИБО!

Автор - DrMini
Дата добавления - 12.11.2019 в 13:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Скрыть нумерацию при незаполненных строках справа от ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!