Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск строк в таблице(диапазоне) содержащих значение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск строк в таблице(диапазоне) содержащих значение (Формулы/Formulas)
Поиск строк в таблице(диапазоне) содержащих значение
drovosek777 Дата: Вторник, 12.11.2019, 18:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер!

есть некая ячейка со значениями(на разной раскладке)
есть соответствие: если исковое слово входит в перечень значений из этой ячейке, то должно определяться необходимое значение из другой ячейки(=ВПР)
Но, как я понимаю, из за большого количества значений в ячейке со значениями, формула возвращает ошибку.
как то можно решить(обойти данную проблему)

прикрепил примерный файл.
К сообщению приложен файл: 8554523.xlsx(10.3 Kb)


Office 2019
 
Ответить
СообщениеДобрый вечер!

есть некая ячейка со значениями(на разной раскладке)
есть соответствие: если исковое слово входит в перечень значений из этой ячейке, то должно определяться необходимое значение из другой ячейки(=ВПР)
Но, как я понимаю, из за большого количества значений в ячейке со значениями, формула возвращает ошибку.
как то можно решить(обойти данную проблему)

прикрепил примерный файл.

Автор - drovosek777
Дата добавления - 12.11.2019 в 18:24
Pelena Дата: Вторник, 12.11.2019, 19:36 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14888
Репутация: 3254 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Можно попробовать формулой массива
Код
=ИНДЕКС(E4:E5;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК(D2;D4:D5));0))
К сообщению приложен файл: 5546162.xlsx(10.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Можно попробовать формулой массива
Код
=ИНДЕКС(E4:E5;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК(D2;D4:D5));0))

Автор - Pelena
Дата добавления - 12.11.2019 в 19:36
drovosek777 Дата: Среда, 13.11.2019, 10:44 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Спасибо. Действительно помогло.


Office 2019

Сообщение отредактировал китин - Среда, 13.11.2019, 10:53
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Спасибо. Действительно помогло.

Автор - drovosek777
Дата добавления - 13.11.2019 в 10:44
drovosek777 Дата: Среда, 13.11.2019, 13:17 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, еще вопрос появился:

как теперь сделать формулу для получения списка всех строк содержащих искомое значение?
вроде по логике все правильно делаю, но не получается и не пойму почему
подскажите пожалуйста.

добавил ячейки e12 и e13 - смысл в том чтобы в этих ячейках изменялся диапазон массива в котором следует искать значение, исходя из результата в предыдущей строке.

спасибо.
К сообщению приложен файл: 5546162-1-.xlsx(10.8 Kb)


Office 2019
 
Ответить
СообщениеPelena, еще вопрос появился:

как теперь сделать формулу для получения списка всех строк содержащих искомое значение?
вроде по логике все правильно делаю, но не получается и не пойму почему
подскажите пожалуйста.

добавил ячейки e12 и e13 - смысл в том чтобы в этих ячейках изменялся диапазон массива в котором следует искать значение, исходя из результата в предыдущей строке.

спасибо.

Автор - drovosek777
Дата добавления - 13.11.2019 в 13:17
китин Дата: Среда, 13.11.2019, 13:21 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 5981
Репутация: 928 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
drovosek777, - п.4 Правил форума: один вопрос - одна тема


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеdrovosek777, - п.4 Правил форума: один вопрос - одна тема

Автор - китин
Дата добавления - 13.11.2019 в 13:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск строк в таблице(диапазоне) содержащих значение (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!