Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для табеля учета рабочего времени - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для табеля учета рабочего времени (Формулы/Formulas)
Формула для табеля учета рабочего времени
dutlove Дата: Четверг, 14.11.2019, 11:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Будьте добры построить формулу для табеля учета рабочего времени. Есть явки (в табеле Я) и есть ночные (в табеле Н). Необходимо отдельно посчитать Я и отдельно Н. Файл прикладываю
К сообщению приложен файл: 0000000000.xls(75.0 Kb)
 
Ответить
СообщениеБудьте добры построить формулу для табеля учета рабочего времени. Есть явки (в табеле Я) и есть ночные (в табеле Н). Необходимо отдельно посчитать Я и отдельно Н. Файл прикладываю

Автор - dutlove
Дата добавления - 14.11.2019 в 11:14
китин Дата: Четверг, 14.11.2019, 11:29 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5981
Репутация: 928 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так?
для "Я"
Код
=СУММ(--СЖПРОБЕЛЫ(ЕСЛИОШИБКА(ПОДСТАВИТЬ(ПСТР($G25:$AK25;1;ПОИСК("Н";$G25:$AK25)-1);"Я";"");0)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
для "Н"
Код
=СУММ(--ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР($G25:$AK25;ПОИСК("Н";$G25:$AK25)+1;10));0))


Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 3162892.xlsm(48.2 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак?
для "Я"
Код
=СУММ(--СЖПРОБЕЛЫ(ЕСЛИОШИБКА(ПОДСТАВИТЬ(ПСТР($G25:$AK25;1;ПОИСК("Н";$G25:$AK25)-1);"Я";"");0)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
для "Н"
Код
=СУММ(--ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР($G25:$AK25;ПОИСК("Н";$G25:$AK25)+1;10));0))


Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 14.11.2019 в 11:29
gling Дата: Четверг, 14.11.2019, 11:35 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1986
Репутация: 493 ±
Замечаний: 0% ±

2010
Может быть так?
Код
=СЧЁТЕСЛИ(G25:AK25;"*я*")

Надо посчитать часы явок и ночных.


ЯД-41001506838083

Сообщение отредактировал gling - Четверг, 14.11.2019, 11:41
 
Ответить
СообщениеМожет быть так?
Код
=СЧЁТЕСЛИ(G25:AK25;"*я*")

Надо посчитать часы явок и ночных.

Автор - gling
Дата добавления - 14.11.2019 в 11:35
dutlove Дата: Четверг, 14.11.2019, 11:43 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, Благодарю. Там еще праздничные могут быть. чуть позже скину исходный файл. Реально помогли! И так быстро.
 
Ответить
Сообщениекитин, Благодарю. Там еще праздничные могут быть. чуть позже скину исходный файл. Реально помогли! И так быстро.

Автор - dutlove
Дата добавления - 14.11.2019 в 11:43
Светлый Дата: Четверг, 14.11.2019, 13:41 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1375
Репутация: 366 ±
Замечаний: 0% ±

Excel 2010, 2013
Массивные:
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР($G25:$AK25;2;ПОИСК("Н";$G25:$AK25)-2);))
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР($G25:$AK25;ПОИСК("Н";$G25:$AK25)+1;9);))
*А лучше, чтобы работало в старом офисе:
Код
=СУММ(--(0&ПСТР($G25:$AK25;3;ПОИСК("Н";$G25:$AK25&"   Н")-4)))
Код
=СУММ(--(0&ПСТР($G25:$AK25;ПОИСК("Н";$G25:$AK25&"   Н")+2;9)))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 14.11.2019, 13:52
 
Ответить
СообщениеМассивные:
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР($G25:$AK25;2;ПОИСК("Н";$G25:$AK25)-2);))
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР($G25:$AK25;ПОИСК("Н";$G25:$AK25)+1;9);))
*А лучше, чтобы работало в старом офисе:
Код
=СУММ(--(0&ПСТР($G25:$AK25;3;ПОИСК("Н";$G25:$AK25&"   Н")-4)))
Код
=СУММ(--(0&ПСТР($G25:$AK25;ПОИСК("Н";$G25:$AK25&"   Н")+2;9)))

Автор - Светлый
Дата добавления - 14.11.2019 в 13:41
dutlove Дата: Четверг, 14.11.2019, 15:08 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, в табеле появились праздничные (обозначается РП). Формула по явкам сбилась сразу. ночные вроде норм. Нужно еще чтобы отдельно считалось РП. Ну и явки чтобы тоже счилались. Благодарю за помощь!
К сообщению приложен файл: 1700279.xls(72.5 Kb)
 
Ответить
Сообщениекитин, в табеле появились праздничные (обозначается РП). Формула по явкам сбилась сразу. ночные вроде норм. Нужно еще чтобы отдельно считалось РП. Ну и явки чтобы тоже счилались. Благодарю за помощь!

Автор - dutlove
Дата добавления - 14.11.2019 в 15:08
Светлый Дата: Четверг, 14.11.2019, 18:31 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1375
Репутация: 366 ±
Замечаний: 0% ±

Excel 2010, 2013
Массивные формулы:
Код
=СУММ(--ЛЕВБ(ЕСЛИ(ЛЕВБ(G25:AK25)="Я";ПОДСТАВИТЬ(ПСТР(G25:AK25;2;3);" ";"  "););3))
Код
=СУММ(--(0&ПСТР($G25:$AK25;ПОИСК("Н";$G25:$AK25&"Н")+1;9)))
Код
=СУММ(--ЛЕВБ(ЕСЛИ(ЛЕВБ(G25:AK25)="Р";ПОДСТАВИТЬ(ПСТР(G25:AK25;3;3);" ";"  "););3))
*Или простая формула для Н:
Код
=СУММПРОИЗВ(--ПРАВБ(ПОДСТАВИТЬ(0&G25:AK25;"Н";" ");3))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 14.11.2019, 18:38
 
Ответить
СообщениеМассивные формулы:
Код
=СУММ(--ЛЕВБ(ЕСЛИ(ЛЕВБ(G25:AK25)="Я";ПОДСТАВИТЬ(ПСТР(G25:AK25;2;3);" ";"  "););3))
Код
=СУММ(--(0&ПСТР($G25:$AK25;ПОИСК("Н";$G25:$AK25&"Н")+1;9)))
Код
=СУММ(--ЛЕВБ(ЕСЛИ(ЛЕВБ(G25:AK25)="Р";ПОДСТАВИТЬ(ПСТР(G25:AK25;3;3);" ";"  "););3))
*Или простая формула для Н:
Код
=СУММПРОИЗВ(--ПРАВБ(ПОДСТАВИТЬ(0&G25:AK25;"Н";" ");3))

Автор - Светлый
Дата добавления - 14.11.2019 в 18:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для табеля учета рабочего времени (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!