Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Распределить значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределить значения (Формулы/Formulas)
Распределить значения
l-lisa Дата: Четверг, 21.11.2019, 11:29 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 230
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, подскажите пожалуйста, разместить значения в таблице по такой логике: в пределах каждой отдельной карточки: нужно в столбец НАДО поместить значения из столбца "Переместить" если сумма значений в этом столбце не превышает значения в столбце "Есть".
Если же сумма значений превышает сумму в столбце "Есть", то перемещаем эту сумму в том кол-ве какое имеется(желтым выделила такие случаи)
К сообщению приложен файл: 2840827.xlsx(10.7 Kb)
 
Ответить
СообщениеЗдравствуйте, подскажите пожалуйста, разместить значения в таблице по такой логике: в пределах каждой отдельной карточки: нужно в столбец НАДО поместить значения из столбца "Переместить" если сумма значений в этом столбце не превышает значения в столбце "Есть".
Если же сумма значений превышает сумму в столбце "Есть", то перемещаем эту сумму в том кол-ве какое имеется(желтым выделила такие случаи)

Автор - l-lisa
Дата добавления - 21.11.2019 в 11:29
Светлый Дата: Четверг, 21.11.2019, 12:39 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1375
Репутация: 366 ±
Замечаний: 0% ±

Excel 2010, 2013
Здравствуйте!
Можно такой формулой:
Код
=ЕСЛИ(E2="";"";МИН(СУММЕСЛИ(A:A;A2;C:C)-СУММЕСЛИ(A$1:A1;A2;E$1:E1);E2))
*Немного не так понял задание. Исправил формулу (E2 и протянуть):
Код
=ЕСЛИ(D2="";"";МИН(СУММЕСЛИ(A:A;A2;C:C)-СУММЕСЛИ(A$1:A1;A2;E$1:E1);D2))
, но она не распределяет, а раздаёт сверху вниз всё, что можно. С жёлтыми не совпадает.
**Зато можно задать приоритет. Чем выше в списке, тем больше приоритет.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 21.11.2019, 13:02
 
Ответить
СообщениеЗдравствуйте!
Можно такой формулой:
Код
=ЕСЛИ(E2="";"";МИН(СУММЕСЛИ(A:A;A2;C:C)-СУММЕСЛИ(A$1:A1;A2;E$1:E1);E2))
*Немного не так понял задание. Исправил формулу (E2 и протянуть):
Код
=ЕСЛИ(D2="";"";МИН(СУММЕСЛИ(A:A;A2;C:C)-СУММЕСЛИ(A$1:A1;A2;E$1:E1);D2))
, но она не распределяет, а раздаёт сверху вниз всё, что можно. С жёлтыми не совпадает.
**Зато можно задать приоритет. Чем выше в списке, тем больше приоритет.

Автор - Светлый
Дата добавления - 21.11.2019 в 12:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределить значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!