Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти в строке значение и сравнить со справочником - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти в строке значение и сравнить со справочником (Формулы/Formulas)
Найти в строке значение и сравнить со справочником
l-lisa Дата: Пятница, 22.11.2019, 18:55 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 230
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, помогите пожалуйста с формулой, которая бы учитывала: Если в строке есть словосочетание из Харьков(оно находится всегда в конце строки) то сверяем из справочника Харьков: если находим в нем первое слово в предложение(это всегда город) из списка, то проставляем "свой", иначе "чужой"
Если же в строке есть словосочетание из Киев то сверяем из справочника Киев и аналогично проставляем свой если нашли город в начале строки из справочника Киев
К сообщению приложен файл: 4716236.xlsx(9.8 Kb)
 
Ответить
СообщениеЗдравствуйте, помогите пожалуйста с формулой, которая бы учитывала: Если в строке есть словосочетание из Харьков(оно находится всегда в конце строки) то сверяем из справочника Харьков: если находим в нем первое слово в предложение(это всегда город) из списка, то проставляем "свой", иначе "чужой"
Если же в строке есть словосочетание из Киев то сверяем из справочника Киев и аналогично проставляем свой если нашли город в начале строки из справочника Киев

Автор - l-lisa
Дата добавления - 22.11.2019 в 18:55
Nic70y Дата: Суббота, 23.11.2019, 09:18 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5737
Репутация: 1259 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(A2;" ";ПОВТОР(" ";99));99));ИНДЕКС($1:$1048576;;ПОИСКПОЗ("справочник "&СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(A2;" ";ПОВТОР(" ";99));99));$1:$1;));));"свой";"чужой")


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(A2;" ";ПОВТОР(" ";99));99));ИНДЕКС($1:$1048576;;ПОИСКПОЗ("справочник "&СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(A2;" ";ПОВТОР(" ";99));99));$1:$1;));));"свой";"чужой")

Автор - Nic70y
Дата добавления - 23.11.2019 в 09:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти в строке значение и сравнить со справочником (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!