Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет остатков склада и средней цены - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет остатков склада и средней цены (Формулы/Formulas)
Подсчет остатков склада и средней цены
pavel058 Дата: Четверг, 05.12.2019, 20:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день.
Есть задача.
нужно рассчитать среднюю цену на остаток, т.е. на складе было 1000 ед. товара по цене 19 руб. за 1 шт.. Продали 600 ед. товара и осталось 400 ед. товара по цене 19.2 руб
потом закупили еще 2000 ед. товара по цене 19,2 руб т.е. (400*19+2000*19,2)/2400 и получаем среднюю цену за 1 ед. товара после закупки.
После продали еще 300 ед. товара уже по 19,166- это средняя цена после подсчета, соответственно после продажи цена средняя не поменяется, но тут мы покупаем еще 1000 ед.товара
по цене 19,1 за 1 ед.товара. и теперь формула получается (2100*19,166+1000*19,1)/3100
Как это реализовать в Exel что бы все считалось автоматически при указании нами только цены и кол-ва ед. товара на 1 день. ( одна строка это 1 день )
Заранее спасибо, всю голову сломал.
К сообщению приложен файл: 7003642.xls(27.5 Kb)


Сообщение отредактировал pavel058 - Четверг, 05.12.2019, 20:04
 
Ответить
СообщениеДобрый день.
Есть задача.
нужно рассчитать среднюю цену на остаток, т.е. на складе было 1000 ед. товара по цене 19 руб. за 1 шт.. Продали 600 ед. товара и осталось 400 ед. товара по цене 19.2 руб
потом закупили еще 2000 ед. товара по цене 19,2 руб т.е. (400*19+2000*19,2)/2400 и получаем среднюю цену за 1 ед. товара после закупки.
После продали еще 300 ед. товара уже по 19,166- это средняя цена после подсчета, соответственно после продажи цена средняя не поменяется, но тут мы покупаем еще 1000 ед.товара
по цене 19,1 за 1 ед.товара. и теперь формула получается (2100*19,166+1000*19,1)/3100
Как это реализовать в Exel что бы все считалось автоматически при указании нами только цены и кол-ва ед. товара на 1 день. ( одна строка это 1 день )
Заранее спасибо, всю голову сломал.

Автор - pavel058
Дата добавления - 05.12.2019 в 20:03
Светлый Дата: Четверг, 05.12.2019, 22:14 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1742
Репутация: 478 ±
Замечаний: 0% ±

Excel 2013, 2016
Добрый вечер!
Может быть, так:
Код
=ЕСЛИ(F1;(E1*F1+A2*C2)/(E1+A2);C2)
К сообщению приложен файл: 7003642-1.xls(29.0 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый вечер!
Может быть, так:
Код
=ЕСЛИ(F1;(E1*F1+A2*C2)/(E1+A2);C2)

Автор - Светлый
Дата добавления - 05.12.2019 в 22:14
krosav4ig Дата: Четверг, 05.12.2019, 23:00 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2346
Репутация: 989 ±
Замечаний: 0% ±

Excel 2007,2010,2013
у меня как-то так получилось
средняя по остаткам
Код
=ОКРУГЛВВЕРХ(СРЗНАЧ(ПРОСМОТР(СТРОКА(ИНДЕКС(A:A;СУММ($D$2:D2)):ИНДЕКС(A:A;СУММ($A$1:A2)))-1;МУМНОЖ(--(СТРОКА($A$1:A2)>=ТРАНСП(СТРОКА($A$1:A2)));Ч(+A$1:A2));C$2:C$3));2)

средняя по продаже
Код
=ОКРУГЛВВЕРХ(ОТБР(СРЗНАЧ(ПРОСМОТР(СТРОКА(ИНДЕКС(A:A;СУММ($D$1:D1)+1):ИНДЕКС(A:A;СУММ($D$1:D1)+D2))-1;МУМНОЖ(--(СТРОКА($A$1:A2)>=ТРАНСП(СТРОКА($A$1:A2)));Ч(+A$1:A2));C$2:C$3));4);2)
К сообщению приложен файл: 0581693.xls(30.5 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениеу меня как-то так получилось
средняя по остаткам
Код
=ОКРУГЛВВЕРХ(СРЗНАЧ(ПРОСМОТР(СТРОКА(ИНДЕКС(A:A;СУММ($D$2:D2)):ИНДЕКС(A:A;СУММ($A$1:A2)))-1;МУМНОЖ(--(СТРОКА($A$1:A2)>=ТРАНСП(СТРОКА($A$1:A2)));Ч(+A$1:A2));C$2:C$3));2)

средняя по продаже
Код
=ОКРУГЛВВЕРХ(ОТБР(СРЗНАЧ(ПРОСМОТР(СТРОКА(ИНДЕКС(A:A;СУММ($D$1:D1)+1):ИНДЕКС(A:A;СУММ($D$1:D1)+D2))-1;МУМНОЖ(--(СТРОКА($A$1:A2)>=ТРАНСП(СТРОКА($A$1:A2)));Ч(+A$1:A2));C$2:C$3));4);2)

Автор - krosav4ig
Дата добавления - 05.12.2019 в 23:00
pavel058 Дата: Пятница, 06.12.2019, 09:05 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое за оперативный ответ. действительно очень помогли!!!
first first first
 
Ответить
СообщениеСпасибо большое за оперативный ответ. действительно очень помогли!!!
first first first

Автор - pavel058
Дата добавления - 06.12.2019 в 09:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет остатков склада и средней цены (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!