Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Добавить текст в ячейку, если в ней нет определенного текста - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Добавить текст в ячейку, если в ней нет определенного текста (Формулы/Formulas)
Добавить текст в ячейку, если в ней нет определенного текста
kioki Дата: Воскресенье, 08.12.2019, 16:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте! Все ячейки, содержащие текст "Remix" должны остаться как есть, однако в каждую, в которой он отсутствует надо добавить текст "-Remix" в конце.
К сообщению приложен файл: dubstep.xlsx(84.3 Kb)


Сообщение отредактировал kioki - Воскресенье, 08.12.2019, 16:55
 
Ответить
СообщениеЗдравствуйте! Все ячейки, содержащие текст "Remix" должны остаться как есть, однако в каждую, в которой он отсутствует надо добавить текст "-Remix" в конце.

Автор - kioki
Дата добавления - 08.12.2019 в 16:54
_Boroda_ Дата: Воскресенье, 08.12.2019, 17:37 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16363
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В соседнем столбце напишите
Код
=C2&ЕСЛИ(ПРАВБ(C2;5)="Remix";"";"-Remix")

Если нужно, потом оттуда скопируйте, вставьте через спецвставку значениями в столбец С, а столбец D удалите
К сообщению приложен файл: dubstep_1.xlsx(9.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ соседнем столбце напишите
Код
=C2&ЕСЛИ(ПРАВБ(C2;5)="Remix";"";"-Remix")

Если нужно, потом оттуда скопируйте, вставьте через спецвставку значениями в столбец С, а столбец D удалите

Автор - _Boroda_
Дата добавления - 08.12.2019 в 17:37
Che79 Дата: Воскресенье, 08.12.2019, 17:43 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1649
Репутация: 306 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Здравствуйте. Так нужно?
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("Remix";Таблица1[@Столбец3]));Таблица1[@Столбец3];Таблица1[@Столбец3]&"-Remix")

Затем выделяете столбец - копируете и вставляете как значения в соседний.
Часть данных в файле удалил - какой-то он тяжелый у Вас...
К сообщению приложен файл: dubstep_001.xlsb(9.6 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте. Так нужно?
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("Remix";Таблица1[@Столбец3]));Таблица1[@Столбец3];Таблица1[@Столбец3]&"-Remix")

Затем выделяете столбец - копируете и вставляете как значения в соседний.
Часть данных в файле удалил - какой-то он тяжелый у Вас...

Автор - Che79
Дата добавления - 08.12.2019 в 17:43
kioki Дата: Воскресенье, 08.12.2019, 18:42 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Che79, Спасибо!
 
Ответить
Сообщение_Boroda_, Che79, Спасибо!

Автор - kioki
Дата добавления - 08.12.2019 в 18:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Добавить текст в ячейку, если в ней нет определенного текста (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!