Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Числа по возратающей. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Числа по возратающей. (Формулы/Formulas)
Числа по возратающей.
mironi Дата: Среда, 11.12.2019, 21:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер! Помогите подправить формулу. Необходимо чтобы цифры начиная от ячейки «А9» -которая должна ровняться единице заполняли столбец А вниз по нарастающей, до свободной ячейки.Пробую по этому примеру не получается.
К сообщению приложен файл: ..3.xlsm(22.3 Kb)
 
Ответить
СообщениеДобрый вечер! Помогите подправить формулу. Необходимо чтобы цифры начиная от ячейки «А9» -которая должна ровняться единице заполняли столбец А вниз по нарастающей, до свободной ячейки.Пробую по этому примеру не получается.

Автор - mironi
Дата добавления - 11.12.2019 в 21:54
Pelena Дата: Среда, 11.12.2019, 22:01 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Так Вам формулой или макросом?
Формула для А9
Код
=ЕСЛИ(B9<>"";МАКС($A$8:A8)+1;"")


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеТак Вам формулой или макросом?
Формула для А9
Код
=ЕСЛИ(B9<>"";МАКС($A$8:A8)+1;"")

Автор - Pelena
Дата добавления - 11.12.2019 в 22:01
mironi Дата: Среда, 11.12.2019, 22:13 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Хотелось бы макросом, но видно я не в тот раздел обратился.Извените!
 
Ответить
СообщениеХотелось бы макросом, но видно я не в тот раздел обратился.Извените!

Автор - mironi
Дата добавления - 11.12.2019 в 22:13
Pelena Дата: Среда, 11.12.2019, 22:24 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Вариант
[vba]
Код
Sub FormatRange()
    i = 9
    Do While Cells(i, 2) <> ""
        Cells(i, 1) = Cells(i - 1, 1) + 1
        i = i + 1
    Loop
End Sub
[/vba]


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеВариант
[vba]
Код
Sub FormatRange()
    i = 9
    Do While Cells(i, 2) <> ""
        Cells(i, 1) = Cells(i - 1, 1) + 1
        i = i + 1
    Loop
End Sub
[/vba]

Автор - Pelena
Дата добавления - 11.12.2019 в 22:24
_Boroda_ Дата: Среда, 11.12.2019, 22:31 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16356
Репутация: 6351 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
[vba]
Код
Sub Zap()
    r0_ = 9
    Cells(r0_, 1) = 1
    If Cells(r0_ + 1, 2) <> "" Then
        Cells(r0_, 1).Resize(Cells(r0_, 2).End(4).Row - r0_ + 1).DataSeries
    End If
End Sub
[/vba]


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
[vba]
Код
Sub Zap()
    r0_ = 9
    Cells(r0_, 1) = 1
    If Cells(r0_ + 1, 2) <> "" Then
        Cells(r0_, 1).Resize(Cells(r0_, 2).End(4).Row - r0_ + 1).DataSeries
    End If
End Sub
[/vba]

Автор - _Boroda_
Дата добавления - 11.12.2019 в 22:31
mironi Дата: Среда, 11.12.2019, 22:35 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Pelena, Попробовал ваш макрос.То что надо.Очень и очень благодарен!!!
 
Ответить
СообщениеPelena, Попробовал ваш макрос.То что надо.Очень и очень благодарен!!!

Автор - mironi
Дата добавления - 11.12.2019 в 22:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Числа по возратающей. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!