Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/формула с подсчётом данных под требуемой ячейкой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула с подсчётом данных под требуемой ячейкой (Формулы/Formulas)
формула с подсчётом данных под требуемой ячейкой
Bodrichkom Дата: Среда, 18.12.2019, 11:25 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброе утро!
Подскажите пожалуйста, пытаюсь состряпать формулу, которая бы считала сумму чисел от выбранной даты в массиве, но встал вопрос, как посчитать сумму всех ниже сумм под выбранным числом учитывая "За какой срок (в днях)" если 7 то 7 чисел ниже, если ячейка пуста считать её как ноль
пробовал состряпать через ВПР, ЕСЛИ, ПОВТОР, но он повторяет постоянно указанную формулу n количество раз, а надо с прогрессией или заданным вертикальным подсчётом.
К сообщению приложен файл: 180.xlsx(9.5 Kb)


Сообщение отредактировал Bodrichkom - Среда, 18.12.2019, 11:50
 
Ответить
СообщениеДоброе утро!
Подскажите пожалуйста, пытаюсь состряпать формулу, которая бы считала сумму чисел от выбранной даты в массиве, но встал вопрос, как посчитать сумму всех ниже сумм под выбранным числом учитывая "За какой срок (в днях)" если 7 то 7 чисел ниже, если ячейка пуста считать её как ноль
пробовал состряпать через ВПР, ЕСЛИ, ПОВТОР, но он повторяет постоянно указанную формулу n количество раз, а надо с прогрессией или заданным вертикальным подсчётом.

Автор - Bodrichkom
Дата добавления - 18.12.2019 в 11:25
_Boroda_ Дата: Среда, 18.12.2019, 11:57 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15946
Репутация: 6201 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИМН(D4:D61;A4:A61;">="&B2;A4:A61;"<"&B2+E2)

Код
=СУММПРОИЗВ(D4:D61*(A4:A61>=B2)*(A4:A61<B2+E2))

Код
=СУММ(ИНДЕКС(D4:D61;B2-A4+1):ИНДЕКС(D4:D61;B2-A4+E2))
К сообщению приложен файл: 180_1.xlsx(10.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИМН(D4:D61;A4:A61;">="&B2;A4:A61;"<"&B2+E2)

Код
=СУММПРОИЗВ(D4:D61*(A4:A61>=B2)*(A4:A61<B2+E2))

Код
=СУММ(ИНДЕКС(D4:D61;B2-A4+1):ИНДЕКС(D4:D61;B2-A4+E2))

Автор - _Boroda_
Дата добавления - 18.12.2019 в 11:57
Bodrichkom Дата: Среда, 18.12.2019, 12:51 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, не совсем то, наверно не верно излагаю мысль. Требуется найти в таблице дату, такую же, как указано в B2 и по ней взять сумму из столбца "Сумма" суммировать сумму с суммами ниже на количество ячеек, как E2, ессли брать по примеру то в графе D2 должно получиться 1558
К сообщению приложен файл: 4250047.jpg(33.3 Kb)
 
Ответить
Сообщение_Boroda_, не совсем то, наверно не верно излагаю мысль. Требуется найти в таблице дату, такую же, как указано в B2 и по ней взять сумму из столбца "Сумма" суммировать сумму с суммами ниже на количество ячеек, как E2, ессли брать по примеру то в графе D2 должно получиться 1558

Автор - Bodrichkom
Дата добавления - 18.12.2019 в 12:51
_Boroda_ Дата: Среда, 18.12.2019, 12:57 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15946
Репутация: 6201 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вы мой файл открывали? Смотрели? Вводили туда свои данные? Попробуйте

К сообщению приложен файл: 6294871.gif(29.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВы мой файл открывали? Смотрели? Вводили туда свои данные? Попробуйте


Автор - _Boroda_
Дата добавления - 18.12.2019 в 12:57
Bodrichkom Дата: Среда, 18.12.2019, 13:54 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Работает, спасибо большое, аж в 3-х вариантах, сейчас буду разбираться как это работает и запускать в ход)
Извините что не протестировал, смутили данные с прогрессией +1, ещё раз спасибо большое.
 
Ответить
Сообщение_Boroda_, Работает, спасибо большое, аж в 3-х вариантах, сейчас буду разбираться как это работает и запускать в ход)
Извините что не протестировал, смутили данные с прогрессией +1, ещё раз спасибо большое.

Автор - Bodrichkom
Дата добавления - 18.12.2019 в 13:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула с подсчётом данных под требуемой ячейкой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!