Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула зависимости по нескольким критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула зависимости по нескольким критериям (Формулы/Formulas)
Формула зависимости по нескольким критериям
dv33 Дата: Среда, 18.12.2019, 11:33 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Необходимо написать формулу зависимости по нескольким критериям, показатели критериев занести в формулу в ручную. Можно начать формулу, а я продолжу по аналогии. Спасибо.
К сообщению приложен файл: 5977048.xls(50.0 Kb)
 
Ответить
СообщениеДобрый день! Необходимо написать формулу зависимости по нескольким критериям, показатели критериев занести в формулу в ручную. Можно начать формулу, а я продолжу по аналогии. Спасибо.

Автор - dv33
Дата добавления - 18.12.2019 в 11:33
китин Дата: Среда, 18.12.2019, 11:44 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6249
Репутация: 961 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
интересно: что трудозатратнее создать файл и нарисовать в нем табличку и 5 столбцов и 5 строк или найти картинку, отсканировать ее и вставить в файл?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеинтересно: что трудозатратнее создать файл и нарисовать в нем табличку и 5 столбцов и 5 строк или найти картинку, отсканировать ее и вставить в файл?

Автор - китин
Дата добавления - 18.12.2019 в 11:44
_Boroda_ Дата: Среда, 18.12.2019, 11:44 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15946
Репутация: 6201 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Непонятно где проверять соответствия чему - строки, столбцы таблицы? Тем более, что сама таблица в картинке, а не на листе
Так?
Код
=суммпроизв(C3:F9*(B3:B9=G6)*(C2:F2=H6))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНепонятно где проверять соответствия чему - строки, столбцы таблицы? Тем более, что сама таблица в картинке, а не на листе
Так?
Код
=суммпроизв(C3:F9*(B3:B9=G6)*(C2:F2=H6))

Автор - _Boroda_
Дата добавления - 18.12.2019 в 11:44
dv33 Дата: Среда, 18.12.2019, 11:53 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо за ответ. Хотелось, чтобы формула брала критерии не из таблички(ее не сложно сделать), а прям в формулу записать эти критерии из таблицы.
 
Ответить
СообщениеСпасибо за ответ. Хотелось, чтобы формула брала критерии не из таблички(ее не сложно сделать), а прям в формулу записать эти критерии из таблицы.

Автор - dv33
Дата добавления - 18.12.2019 в 11:53
dv33 Дата: Среда, 18.12.2019, 11:56 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Файлы будут разные, не хотелось таскать в каждый файл таблицу. Удобнее было копировать формулу.
 
Ответить
СообщениеФайлы будут разные, не хотелось таскать в каждый файл таблицу. Удобнее было копировать формулу.

Автор - dv33
Дата добавления - 18.12.2019 в 11:56
_Boroda_ Дата: Среда, 18.12.2019, 12:03 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15946
Репутация: 6201 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А нам удобнее было бы сначала увидеть табличку, поскольку
Непонятно где проверять соответствия чему


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА нам удобнее было бы сначала увидеть табличку, поскольку
Непонятно где проверять соответствия чему

Автор - _Boroda_
Дата добавления - 18.12.2019 в 12:03
dv33 Дата: Среда, 18.12.2019, 12:07 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Сделал табличку, Вы все правильно поняли, мне так и нужно сделать, только хотелось, чтобы показатели из таблички, были в ручную в формулы проставлены
К сообщению приложен файл: 5977048-1-.xls(51.0 Kb)
 
Ответить
СообщениеСделал табличку, Вы все правильно поняли, мне так и нужно сделать, только хотелось, чтобы показатели из таблички, были в ручную в формулы проставлены

Автор - dv33
Дата добавления - 18.12.2019 в 12:07
_Boroda_ Дата: Среда, 18.12.2019, 12:11 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15946
Репутация: 6201 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Удобнее было копировать формулу

Наслаждайтесь :D

Код
=СУММПРОИЗВ({0;-2550;-3675;-6390;-10821:2550;0;-1125;-3840;-8271:3675;1125;0;-2715;-7146:6390;3840;2715;0;-4431:10821;8271;7146;4431;0}*({"Без отделки":"Косметический":"Эконом":"Стандарт":"Премиум"}="Премиум")*({"Без отделки";"Косметический";"Эконом";"Стандарт";"Премиум"}="Эконом"))


Код
=ВПР("Премиум";{"Без отделки";0;-2550;-3675;-6390;-10821:"Косметический";2550;0;-1125;-3840;-8271:"Эконом";3675;1125;0;-2715;-7146:"Стандарт";6390;3840;2715;0;-4431:"Премиум";10821;8271;7146;4431;0};ПОИСКПОЗ("Эконом";{0;"Без отделки";"Косметический";"Эконом";"Стандарт";"Премиум"};);)


Код
=ИНДЕКС({0;-2550;-3675;-6390;-10821:2550;0;-1125;-3840;-8271:3675;1125;0;-2715;-7146:6390;3840;2715;0;-4431:10821;8271;7146;4431;0};ПОИСКПОЗ("Премиум";{"Без отделки":"Косметический":"Эконом":"Стандарт":"Премиум"};);ПОИСКПОЗ("Эконом";{"Без отделки";"Косметический";"Эконом";"Стандарт";"Премиум"};))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Удобнее было копировать формулу

Наслаждайтесь :D

Код
=СУММПРОИЗВ({0;-2550;-3675;-6390;-10821:2550;0;-1125;-3840;-8271:3675;1125;0;-2715;-7146:6390;3840;2715;0;-4431:10821;8271;7146;4431;0}*({"Без отделки":"Косметический":"Эконом":"Стандарт":"Премиум"}="Премиум")*({"Без отделки";"Косметический";"Эконом";"Стандарт";"Премиум"}="Эконом"))


Код
=ВПР("Премиум";{"Без отделки";0;-2550;-3675;-6390;-10821:"Косметический";2550;0;-1125;-3840;-8271:"Эконом";3675;1125;0;-2715;-7146:"Стандарт";6390;3840;2715;0;-4431:"Премиум";10821;8271;7146;4431;0};ПОИСКПОЗ("Эконом";{0;"Без отделки";"Косметический";"Эконом";"Стандарт";"Премиум"};);)


Код
=ИНДЕКС({0;-2550;-3675;-6390;-10821:2550;0;-1125;-3840;-8271:3675;1125;0;-2715;-7146:6390;3840;2715;0;-4431:10821;8271;7146;4431;0};ПОИСКПОЗ("Премиум";{"Без отделки":"Косметический":"Эконом":"Стандарт":"Премиум"};);ПОИСКПОЗ("Эконом";{"Без отделки";"Косметический";"Эконом";"Стандарт";"Премиум"};))

Автор - _Boroda_
Дата добавления - 18.12.2019 в 12:11
dv33 Дата: Среда, 18.12.2019, 12:12 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Соответствие ячейки Н6 ячейки I7, по критериям в таблице
 
Ответить
СообщениеСоответствие ячейки Н6 ячейки I7, по критериям в таблице

Автор - dv33
Дата добавления - 18.12.2019 в 12:12
dv33 Дата: Среда, 18.12.2019, 12:31 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
А как в эти формулы включить ячейки сравнения Н6 ячейке I7?
 
Ответить
СообщениеА как в эти формулы включить ячейки сравнения Н6 ячейке I7?

Автор - dv33
Дата добавления - 18.12.2019 в 12:31
_Boroda_ Дата: Среда, 18.12.2019, 12:45 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15946
Репутация: 6201 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=СУММПРОИЗВ({0;-2550;-3675;-6390;-10821:2550;0;-1125;-3840;-8271:3675;1125;0;-2715;-7146:6390;3840;2715;0;-4431:10821;8271;7146;4431;0}*({"Без отделки":"Косметический":"Эконом":"Стандарт":"Премиум"}=H6)*({"Без отделки";"Косметический";"Эконом";"Стандарт";"Премиум"}=I6))


ячейки сравнения Н6 ячейке I7?
- Это Вы о чем? I7 сравниваем с Н6? И что получим?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=СУММПРОИЗВ({0;-2550;-3675;-6390;-10821:2550;0;-1125;-3840;-8271:3675;1125;0;-2715;-7146:6390;3840;2715;0;-4431:10821;8271;7146;4431;0}*({"Без отделки":"Косметический":"Эконом":"Стандарт":"Премиум"}=H6)*({"Без отделки";"Косметический";"Эконом";"Стандарт";"Премиум"}=I6))


ячейки сравнения Н6 ячейке I7?
- Это Вы о чем? I7 сравниваем с Н6? И что получим?

Автор - _Boroda_
Дата добавления - 18.12.2019 в 12:45
dv33 Дата: Среда, 18.12.2019, 13:10 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
то что нужно, спасибо
 
Ответить
Сообщението что нужно, спасибо

Автор - dv33
Дата добавления - 18.12.2019 в 13:10
dv33 Дата: Среда, 18.12.2019, 13:13 | Сообщение № 13
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
и маленькая благодарность в кошелек
 
Ответить
Сообщениеи маленькая благодарность в кошелек

Автор - dv33
Дата добавления - 18.12.2019 в 13:13
_Boroda_ Дата: Среда, 18.12.2019, 23:14 | Сообщение № 14
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15946
Репутация: 6201 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Получил, спасибо


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПолучил, спасибо

Автор - _Boroda_
Дата добавления - 18.12.2019 в 23:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула зависимости по нескольким критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!