Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение массива данных значениями с дополнительным индекс - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение массива данных значениями с дополнительным индекс (Формулы/Formulas)
Заполнение массива данных значениями с дополнительным индекс
CJIaueP Дата: Четверг, 19.12.2019, 13:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день.
Задача такая.
Дан массив данных, где даны: часы работы, (только одна цифра) и паузы - указаны как (1).
Пояснение: Пауза начинается, когда в колонке "Паузы" появляется цифра 1, заканчивается на следующей паузе (когда будет следующая цифра 1), Индекс целой паузы нужно выводить в цифрах 1,2,3. В час может быть Максимум 3 паузы, НО может быть и две и даже одна.
Задача. Подсчитать индексы пауз(1,2,3).

Если вдруг не очень понятно объяснил, прошу извинить меня. Более понятно будет взглянув на пример. Главное внимание нужно сосредоточить на 84-98 строчку, где в часе всего одна пауза.

Заранее спасибо за ответы!
К сообщению приложен файл: Example.xlsx(12.2 Kb)


KKKKKKKKK

Сообщение отредактировал CJIaueP - Четверг, 19.12.2019, 13:43
 
Ответить
СообщениеДобрый день.
Задача такая.
Дан массив данных, где даны: часы работы, (только одна цифра) и паузы - указаны как (1).
Пояснение: Пауза начинается, когда в колонке "Паузы" появляется цифра 1, заканчивается на следующей паузе (когда будет следующая цифра 1), Индекс целой паузы нужно выводить в цифрах 1,2,3. В час может быть Максимум 3 паузы, НО может быть и две и даже одна.
Задача. Подсчитать индексы пауз(1,2,3).

Если вдруг не очень понятно объяснил, прошу извинить меня. Более понятно будет взглянув на пример. Главное внимание нужно сосредоточить на 84-98 строчку, где в часе всего одна пауза.

Заранее спасибо за ответы!

Автор - CJIaueP
Дата добавления - 19.12.2019 в 13:42
amfor Дата: Четверг, 19.12.2019, 14:13 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 189
Репутация: 53 ±
Замечаний: 0% ±

Excel 2016
Добрый. Так?
Код
=СЧЁТЕСЛИМН($A$3:A3;A3;$B$3:B3;">0")
К сообщению приложен файл: 5155772.xlsx(14.3 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеДобрый. Так?
Код
=СЧЁТЕСЛИМН($A$3:A3;A3;$B$3:B3;">0")

Автор - amfor
Дата добавления - 19.12.2019 в 14:13
bigor Дата: Четверг, 19.12.2019, 14:14 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 25 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте.

Так?
в e3
Код
=COUNTIFS($A$3:$A3;A3;$B$3:B3;1)

и протянуть вниз
 
Ответить
СообщениеЗдравствуйте.

Так?
в e3
Код
=COUNTIFS($A$3:$A3;A3;$B$3:B3;1)

и протянуть вниз

Автор - bigor
Дата добавления - 19.12.2019 в 14:14
Светлый Дата: Четверг, 19.12.2019, 14:59 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1398
Репутация: 370 ±
Замечаний: 0% ±

Excel 2010, 2013
Можно так:
Код
=СУММПРОИЗВ((A3=A$3:A3)*B$3:B3)
или массивная:
Код
=СУММ((A3=A$3:A3)*B$3:B3)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМожно так:
Код
=СУММПРОИЗВ((A3=A$3:A3)*B$3:B3)
или массивная:
Код
=СУММ((A3=A$3:A3)*B$3:B3)

Автор - Светлый
Дата добавления - 19.12.2019 в 14:59
_Boroda_ Дата: Четверг, 19.12.2019, 15:11 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15747
Репутация: 6143 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты
Код
=ЕСЛИ(A3<>A2;B3;B3+E2)

Код
=B3+(A3=A2)*E2
К сообщению приложен файл: Example88_1.xlsx(14.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты
Код
=ЕСЛИ(A3<>A2;B3;B3+E2)

Код
=B3+(A3=A2)*E2

Автор - _Boroda_
Дата добавления - 19.12.2019 в 15:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение массива данных значениями с дополнительным индекс (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!