Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сбор данных из таблиц по 3 условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных из таблиц по 3 условиям (Формулы/Formulas)
Сбор данных из таблиц по 3 условиям
heaven33rus Дата: Пятница, 20.12.2019, 10:39 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день
Есть таблица, которая должна автоматически заполняться, в зависимости от выбранных значений в выпадающих списках (зеленым закрасил)
Делал раньше через индекс и поискпоз, но это хорошо работает когда одно условие или 2, с тремя у меня не работает, может так и нельзя.

Единственное что, хотелось бы чтобы все работало именно при такой конфигурации таблицы из которой собираются данные.

Если надо, для удобства можно заменить класс и объект на числа (класс это 10, 20, 30 например), . В моей задаче я так и сделал, тут текстом записал, чтоб понятнее было, что хочется получить.

В G3 вписал формулу, но она не работает :(
К сообщению приложен файл: 8018408.xlsx(10.7 Kb)
 
Ответить
СообщениеДобрый день
Есть таблица, которая должна автоматически заполняться, в зависимости от выбранных значений в выпадающих списках (зеленым закрасил)
Делал раньше через индекс и поискпоз, но это хорошо работает когда одно условие или 2, с тремя у меня не работает, может так и нельзя.

Единственное что, хотелось бы чтобы все работало именно при такой конфигурации таблицы из которой собираются данные.

Если надо, для удобства можно заменить класс и объект на числа (класс это 10, 20, 30 например), . В моей задаче я так и сделал, тут текстом записал, чтоб понятнее было, что хочется получить.

В G3 вписал формулу, но она не работает :(

Автор - heaven33rus
Дата добавления - 20.12.2019 в 10:39
_Boroda_ Дата: Пятница, 20.12.2019, 10:51 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15748
Репутация: 6143 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС($D$25:$W$26;ПОИСКПОЗ(G$8;$D$25:$D$26;);ПОИСКПОЗ($B$3;$D$27:$W$27;)+$F3-1)

Код
=ИНДЕКС($D$25:$W$26;ПРАВБ(G$8);ПОИСКПОЗ($B$3;$D$27:$W$27;)+$F3-1)
К сообщению приложен файл: 8018408_1.xlsx(11.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС($D$25:$W$26;ПОИСКПОЗ(G$8;$D$25:$D$26;);ПОИСКПОЗ($B$3;$D$27:$W$27;)+$F3-1)

Код
=ИНДЕКС($D$25:$W$26;ПРАВБ(G$8);ПОИСКПОЗ($B$3;$D$27:$W$27;)+$F3-1)

Автор - _Boroda_
Дата добавления - 20.12.2019 в 10:51
heaven33rus Дата: Пятница, 20.12.2019, 10:58 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Так нужно?

Ой, это я туплю, не выбрал условия.


Сообщение отредактировал heaven33rus - Пятница, 20.12.2019, 10:59
 
Ответить
Сообщение
Так нужно?

Ой, это я туплю, не выбрал условия.

Автор - heaven33rus
Дата добавления - 20.12.2019 в 10:58
YouGreed Дата: Пятница, 20.12.2019, 10:59 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 477
Репутация: 101 ±
Замечаний: 0% ±

Excel 2010
heaven33rus, Всегда смотрите файл пример)

У Вас скорей всего в классе не выбран "Стандарт" или "Люкс"
 
Ответить
Сообщениеheaven33rus, Всегда смотрите файл пример)

У Вас скорей всего в классе не выбран "Стандарт" или "Люкс"

Автор - YouGreed
Дата добавления - 20.12.2019 в 10:59
heaven33rus Дата: Пятница, 20.12.2019, 11:02 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Так нужно?

У Вас скорей всего в классе не выбран "Стандарт" или "Люкс"


Да, все так как надо! Спасибо большое!!!!
 
Ответить
Сообщение
Так нужно?

У Вас скорей всего в классе не выбран "Стандарт" или "Люкс"


Да, все так как надо! Спасибо большое!!!!

Автор - heaven33rus
Дата добавления - 20.12.2019 в 11:02
китин Дата: Пятница, 20.12.2019, 11:02 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 6067
Репутация: 938 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
малость поизвращался со СМЕЩ
Код
=ИНДЕКС(Класс;ПОИСКПОЗ(G$8;Объект;0);ПОИСКПОЗ($F3;Номер;0))

имена смотрите в диспетчере имен
К сообщению приложен файл: 0809754.xlsx(11.1 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениемалость поизвращался со СМЕЩ
Код
=ИНДЕКС(Класс;ПОИСКПОЗ(G$8;Объект;0);ПОИСКПОЗ($F3;Номер;0))

имена смотрите в диспетчере имен

Автор - китин
Дата добавления - 20.12.2019 в 11:02
heaven33rus Дата: Пятница, 20.12.2019, 11:07 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
малость поизвращался со СМЕЩ


у меня этот кусочек в очень большом проекте используется и там в диспетчере имен уже такой лес что просто пипец :))) мне чем проще тем лучше. Но в копилку свою я это сохранил !
Спасибо большое!
 
Ответить
Сообщение
малость поизвращался со СМЕЩ


у меня этот кусочек в очень большом проекте используется и там в диспетчере имен уже такой лес что просто пипец :))) мне чем проще тем лучше. Но в копилку свою я это сохранил !
Спасибо большое!

Автор - heaven33rus
Дата добавления - 20.12.2019 в 11:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных из таблиц по 3 условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!