Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск макс. значений из подкласса, по заданому условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск макс. значений из подкласса, по заданому условию (Формулы/Formulas)
Поиск макс. значений из подкласса, по заданому условию
CJIaueP Дата: Пятница, 27.12.2019, 08:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Нужно найти макс значения из подкласса, по условию. Если они повторяються, то выводить любой из низ. Спасибо!
К сообщению приложен файл: bb.xlsx(10.9 Kb)


KKKKKKKKK
 
Ответить
СообщениеДобрый день. Нужно найти макс значения из подкласса, по условию. Если они повторяються, то выводить любой из низ. Спасибо!

Автор - CJIaueP
Дата добавления - 27.12.2019 в 08:48
Nic70y Дата: Пятница, 27.12.2019, 09:02 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5815
Репутация: 1273 ±
Замечаний: 0% ±

ru13;10;03
Код
=ИНДЕКС(B:B;ПОИСКПОЗ(МАКС(ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)):ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)+СЧЁТЕСЛИ(A:A;G1)-1));ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)):ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)+СЧЁТЕСЛИ(A:A;G1)-1);)+ПОИСКПОЗ(G1;A:A;)-1)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(B:B;ПОИСКПОЗ(МАКС(ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)):ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)+СЧЁТЕСЛИ(A:A;G1)-1));ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)):ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)+СЧЁТЕСЛИ(A:A;G1)-1);)+ПОИСКПОЗ(G1;A:A;)-1)

Автор - Nic70y
Дата добавления - 27.12.2019 в 09:02
_Boroda_ Дата: Пятница, 27.12.2019, 10:05 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15748
Репутация: 6143 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
CJIaueP, у Вас подклассы реально так и есть - цифры? Если да, то такой вариант (до 9, если больше, то немного изменить формулу можно, она в файле)
Код
=--ПРАВБ(МАКС(--(ОКРУГЛ(СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)+,1;9)&B2:B51)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: bb_1.xlsx(10.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеCJIaueP, у Вас подклассы реально так и есть - цифры? Если да, то такой вариант (до 9, если больше, то немного изменить формулу можно, она в файле)
Код
=--ПРАВБ(МАКС(--(ОКРУГЛ(СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)+,1;9)&B2:B51)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 27.12.2019 в 10:05
bmv98rus Дата: Пятница, 27.12.2019, 10:35 | Сообщение № 4
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2895
Репутация: 501 ±
Замечаний: 0% ±

Excel 2013/2016
Массивная
Код
=INDEX(B2:B51;MATCH(MAX(SUMIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51)/COUNTIFS(A2:A51;G1;B2:B51;B2:B51));SUMIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51)/COUNTIFS(A2:A51;G1;B2:B51;B2:B51);))

Код
=LOOKUP(MAX(SUMIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51)/COUNTIFS(A2:A51;G1;B2:B51;B2:B51));SUMIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51)/COUNTIFS(A2:A51;G1;B2:B51;B2:B51);B2:B51)
ну и если есть AVERAGEIFS, то
Код
=INDEX(B2:B51;MATCH(MAX(AVERAGEIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51));AVERAGEIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51);))

Код
=LOOKUP(MAX(AVERAGEIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51));AVERAGEIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51);B2:B51)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Пятница, 27.12.2019, 10:53
 
Ответить
СообщениеМассивная
Код
=INDEX(B2:B51;MATCH(MAX(SUMIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51)/COUNTIFS(A2:A51;G1;B2:B51;B2:B51));SUMIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51)/COUNTIFS(A2:A51;G1;B2:B51;B2:B51);))

Код
=LOOKUP(MAX(SUMIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51)/COUNTIFS(A2:A51;G1;B2:B51;B2:B51));SUMIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51)/COUNTIFS(A2:A51;G1;B2:B51;B2:B51);B2:B51)
ну и если есть AVERAGEIFS, то
Код
=INDEX(B2:B51;MATCH(MAX(AVERAGEIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51));AVERAGEIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51);))

Код
=LOOKUP(MAX(AVERAGEIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51));AVERAGEIFS(C2:C51;A2:A51;G1;B2:B51;B2:B51);B2:B51)

Автор - bmv98rus
Дата добавления - 27.12.2019 в 10:35
CJIaueP Дата: Воскресенье, 29.12.2019, 13:52 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Массивная
[Перевод / Translate]
=ИНДЕКС(B2:B51;ПОИСКПОЗ(МАКС(СУММЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)/СЧЁТЕСЛИМН(A2:A51;G1;B2:B51;B2:B51));СУММЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)/СЧЁТЕСЛИМН(A2:A51;G1;B2:B51;B2:B51);))

[Перевод / Translate]
=ПРОСМОТР(МАКС(СУММЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)/СЧЁТЕСЛИМН(A2:A51;G1;B2:B51;B2:B51));СУММЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)/СЧЁТЕСЛИМН(A2:A51;G1;B2:B51;B2:B51);B2:B51)
ну и если есть AVERAGEIFS, то
[Перевод / Translate]
=ИНДЕКС(B2:B51;ПОИСКПОЗ(МАКС(СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51));СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51);))

[Перевод / Translate]
=ПРОСМОТР(МАКС(СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51));СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51);B2:B51)


Я может что-то не понимаю, но не одна из предложенных формул не работает. Возможно получить пример? :)


KKKKKKKKK
 
Ответить
Сообщение
Массивная
[Перевод / Translate]
=ИНДЕКС(B2:B51;ПОИСКПОЗ(МАКС(СУММЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)/СЧЁТЕСЛИМН(A2:A51;G1;B2:B51;B2:B51));СУММЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)/СЧЁТЕСЛИМН(A2:A51;G1;B2:B51;B2:B51);))

[Перевод / Translate]
=ПРОСМОТР(МАКС(СУММЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)/СЧЁТЕСЛИМН(A2:A51;G1;B2:B51;B2:B51));СУММЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)/СЧЁТЕСЛИМН(A2:A51;G1;B2:B51;B2:B51);B2:B51)
ну и если есть AVERAGEIFS, то
[Перевод / Translate]
=ИНДЕКС(B2:B51;ПОИСКПОЗ(МАКС(СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51));СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51);))

[Перевод / Translate]
=ПРОСМОТР(МАКС(СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51));СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51);B2:B51)


Я может что-то не понимаю, но не одна из предложенных формул не работает. Возможно получить пример? :)

Автор - CJIaueP
Дата добавления - 29.12.2019 в 13:52
CJIaueP Дата: Воскресенье, 29.12.2019, 13:55 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=ИНДЕКС(B:B;ПОИСКПОЗ(МАКС(ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)):ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)+СЧЁТЕСЛИ(A:A;G1)-1));ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)):ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)+СЧЁТЕСЛИ(A:A;G1)-1);)+ПОИСКПОЗ(G1;A:A;)-1)


=--ПРАВБ(МАКС(--(ОКРУГЛ(СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)+,1;9)&B2:B51)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter


Спасибо, все работает)


KKKKKKKKK
 
Ответить
Сообщение
=ИНДЕКС(B:B;ПОИСКПОЗ(МАКС(ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)):ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)+СЧЁТЕСЛИ(A:A;G1)-1));ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)):ИНДЕКС(D:D;ПОИСКПОЗ(G1;A:A;)+СЧЁТЕСЛИ(A:A;G1)-1);)+ПОИСКПОЗ(G1;A:A;)-1)


=--ПРАВБ(МАКС(--(ОКРУГЛ(СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)+,1;9)&B2:B51)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter


Спасибо, все работает)

Автор - CJIaueP
Дата добавления - 29.12.2019 в 13:55
bmv98rus Дата: Воскресенье, 29.12.2019, 13:56 | Сообщение № 7
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2895
Репутация: 501 ±
Замечаний: 0% ±

Excel 2013/2016
Я может что-то не понимаю
все может быть
К сообщению приложен файл: Copy_of_1373.xlsx(10.8 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Я может что-то не понимаю
все может быть

Автор - bmv98rus
Дата добавления - 29.12.2019 в 13:56
Pelena Дата: Воскресенье, 29.12.2019, 13:56 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 15023
Репутация: 3283 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
CJIaueP, не надо цитировать пост целиком. Это нарушение Правил форума. Исправьте.

По теме: Не забыли, что формула массива вводится сочетанием клавиш Ctrl+Shift+Enter?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеCJIaueP, не надо цитировать пост целиком. Это нарушение Правил форума. Исправьте.

По теме: Не забыли, что формула массива вводится сочетанием клавиш Ctrl+Shift+Enter?

Автор - Pelena
Дата добавления - 29.12.2019 в 13:56
Светлый Дата: Воскресенье, 29.12.2019, 16:43 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1400
Репутация: 370 ±
Замечаний: 0% ±

Excel 2010, 2013
цифры? Если да, то такой вариант
Классный ход! Немного причесал:
Код
=--ПРАВБ(МИН(-(ЛЕВБ(СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)%;9)&B2:B51)))


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
цифры? Если да, то такой вариант
Классный ход! Немного причесал:
Код
=--ПРАВБ(МИН(-(ЛЕВБ(СРЗНАЧЕСЛИМН(C2:C51;A2:A51;G1;B2:B51;B2:B51)%;9)&B2:B51)))

Автор - Светлый
Дата добавления - 29.12.2019 в 16:43
BvvN Дата: Четверг, 02.01.2020, 17:30 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо за помощь) помогло )
 
Ответить
СообщениеСпасибо за помощь) помогло )

Автор - BvvN
Дата добавления - 02.01.2020 в 17:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск макс. значений из подкласса, по заданому условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!