Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос "не нулевых" значений из одной таблицы в другую - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос "не нулевых" значений из одной таблицы в другую (Формулы/Formulas)
Перенос "не нулевых" значений из одной таблицы в другую
андрей804 Дата: Пятница, 03.01.2020, 17:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Необходимо перенести не нулевые значения из одной таблицы в другую(желтого цвета справа от основной). Необходимо чтобы значения переносились построчно, т.е "ненулевые" значения каждой строки основной таблицы также оказывались на одной строке желтой таблицы. Предполагал сделать сам путем сравнения с "0" значения ячеек основной табл. с последующим присвоением не нулевого значения ячейке в желтой табл. но что-то не получается у меня с этим алгоритмом %) если возможно решить другим путем, то тоже можно, главное чтоб значения остались на одних строках.
К сообщению приложен файл: __.xlsx(12.4 Kb)


ищу, уже почти нашел
 
Ответить
СообщениеДобрый день!
Необходимо перенести не нулевые значения из одной таблицы в другую(желтого цвета справа от основной). Необходимо чтобы значения переносились построчно, т.е "ненулевые" значения каждой строки основной таблицы также оказывались на одной строке желтой таблицы. Предполагал сделать сам путем сравнения с "0" значения ячеек основной табл. с последующим присвоением не нулевого значения ячейке в желтой табл. но что-то не получается у меня с этим алгоритмом %) если возможно решить другим путем, то тоже можно, главное чтоб значения остались на одних строках.

Автор - андрей804
Дата добавления - 03.01.2020 в 17:16
Che79 Дата: Пятница, 03.01.2020, 17:41 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1416
Репутация: 254 ±
Замечаний: 0% ±

Excel 2013
андрей804, здравствуйте! Так нужно? Формула массива (ввод Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС($B3:$AT3;НАИМЕНЬШИЙ(ЕСЛИ($B3:$AT3<>"";СТОЛБЕЦ($B3:$AT3)-1);СТОЛБЕЦ(A3)));)
См. желтую таблицу. Проверьте на реальном файле.

Upd
Для Вашего примера можно короче
Код
=НАИМЕНЬШИЙ(ЕСЛИ($B3:$AT3<>"";$B3:$AT3);СТОЛБЕЦ(A3))
Формула массива (ввод Ctrl+Shift+Enter)
К сообщению приложен файл: -newyear123.xlsx(14.4 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Пятница, 03.01.2020, 17:55
 
Ответить
Сообщениеандрей804, здравствуйте! Так нужно? Формула массива (ввод Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС($B3:$AT3;НАИМЕНЬШИЙ(ЕСЛИ($B3:$AT3<>"";СТОЛБЕЦ($B3:$AT3)-1);СТОЛБЕЦ(A3)));)
См. желтую таблицу. Проверьте на реальном файле.

Upd
Для Вашего примера можно короче
Код
=НАИМЕНЬШИЙ(ЕСЛИ($B3:$AT3<>"";$B3:$AT3);СТОЛБЕЦ(A3))
Формула массива (ввод Ctrl+Shift+Enter)

Автор - Che79
Дата добавления - 03.01.2020 в 17:41
андрей804 Дата: Суббота, 04.01.2020, 19:47 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Che79 -большой респект и "+" Вам в карму ))) в реальный файл перенес (кое-как), все работает. Спасибо :D :D :D


ищу, уже почти нашел
 
Ответить
СообщениеChe79 -большой респект и "+" Вам в карму ))) в реальный файл перенес (кое-как), все работает. Спасибо :D :D :D

Автор - андрей804
Дата добавления - 04.01.2020 в 19:47
GLR Дата: Среда, 08.01.2020, 04:33 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Che79 "++++++" Спасибо, тоже помогло.
 
Ответить
СообщениеChe79 "++++++" Спасибо, тоже помогло.

Автор - GLR
Дата добавления - 08.01.2020 в 04:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос "не нулевых" значений из одной таблицы в другую (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!