Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Значение в ячейке по двум критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Значение в ячейке по двум критериям (Формулы/Formulas)
Значение в ячейке по двум критериям
SerJant Дата: Суббота, 11.01.2020, 11:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, друзья.
Просьба помочь с реализацией задачи на примере:
Есть две ячейки, каждая из них в функции "Проверка данных => Тип данных => Список", в таблице это А2 и В2. В зависимости от того, какое значение из списков там выбрано - в желтую ячейку должно записывать определенное число баллов. Т.е. на примере если в ячейке А2 стоит значение из выбранного списка Общий, а в В2 стоит значение из выбранного списка Черный, то в ячейке С2 выводится 17 баллов (таблица с точными значениями баллов к своему цвету и виду (столбцы) указано в табличке Е2:G9).
Скажите пожалуйста, как лучше это сделать?
К сообщению приложен файл: Primer1.xlsx(10.2 Kb)
 
Ответить
СообщениеДобрый день, друзья.
Просьба помочь с реализацией задачи на примере:
Есть две ячейки, каждая из них в функции "Проверка данных => Тип данных => Список", в таблице это А2 и В2. В зависимости от того, какое значение из списков там выбрано - в желтую ячейку должно записывать определенное число баллов. Т.е. на примере если в ячейке А2 стоит значение из выбранного списка Общий, а в В2 стоит значение из выбранного списка Черный, то в ячейке С2 выводится 17 баллов (таблица с точными значениями баллов к своему цвету и виду (столбцы) указано в табличке Е2:G9).
Скажите пожалуйста, как лучше это сделать?

Автор - SerJant
Дата добавления - 11.01.2020 в 11:28
Nic70y Дата: Суббота, 11.01.2020, 12:02 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6313
Репутация: 1393 ±
Замечаний: 0% ±

ru13;10;03
Код
=ИНДЕКС((G2:G5;G6:G9);ПОИСКПОЗ(B2;F2:F5;);;ПОИСКПОЗ(A2;E2:E9;)/4+1)
Код
=ИНДЕКС(G:G;ПОИСКПОЗ(B2;ИНДЕКС(F:F;ПОИСКПОЗ(A2;E:E;)):F18000;)+ПОИСКПОЗ(A2;E:E;)-1)


Яндекс Деньги 41001841029809

Сообщение отредактировал Nic70y - Суббота, 11.01.2020, 12:05
 
Ответить
Сообщение
Код
=ИНДЕКС((G2:G5;G6:G9);ПОИСКПОЗ(B2;F2:F5;);;ПОИСКПОЗ(A2;E2:E9;)/4+1)
Код
=ИНДЕКС(G:G;ПОИСКПОЗ(B2;ИНДЕКС(F:F;ПОИСКПОЗ(A2;E:E;)):F18000;)+ПОИСКПОЗ(A2;E:E;)-1)

Автор - Nic70y
Дата добавления - 11.01.2020 в 12:02
SerJant Дата: Суббота, 11.01.2020, 14:10 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Помогло! Спасибо большое!
 
Ответить
СообщениеПомогло! Спасибо большое!

Автор - SerJant
Дата добавления - 11.01.2020 в 14:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Значение в ячейке по двум критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!