Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/найти сумму значений справа от текста - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » найти сумму значений справа от текста (Формулы/Formulas)
найти сумму значений справа от текста
STnmsk Дата: Суббота, 11.01.2020, 14:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Не смог создать новую тему на форуме, т.к. я новичок и не имею трёх сообщений.
[admin]Разделила тему[/admin]
Помогите, пожалуйста. Не могу сообразить какую формулу нужно использовать. Необходимо в заданном диапазоне B2:O2 найти и посчитать сумму стоящих справа от букв "ГА" значений.
Т.е. надо пройтись по диапазону, найти ячейки, содержащие символы "ГА" и сложить значения ячеек, которые находятся справа от ячеек, содержащие символы "ГА"
К сообщению приложен файл: 0679102.xlsx(9.4 Kb)


Сообщение отредактировал Pelena - Суббота, 11.01.2020, 14:42
 
Ответить
СообщениеДобрый день! Не смог создать новую тему на форуме, т.к. я новичок и не имею трёх сообщений.
[admin]Разделила тему[/admin]
Помогите, пожалуйста. Не могу сообразить какую формулу нужно использовать. Необходимо в заданном диапазоне B2:O2 найти и посчитать сумму стоящих справа от букв "ГА" значений.
Т.е. надо пройтись по диапазону, найти ячейки, содержащие символы "ГА" и сложить значения ячеек, которые находятся справа от ячеек, содержащие символы "ГА"

Автор - STnmsk
Дата добавления - 11.01.2020 в 14:11
Che79 Дата: Суббота, 11.01.2020, 15:46 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1610
Репутация: 299 ±
Замечаний: 0% ±

2013 Win, 365 Mac
STnmsk, здравствуйте. Так нужно?
Код
=СУММЕСЛИ(B$2:N$2;Q2;C$2:O$2)
Посмотрите желтые ячейки в файле.
К сообщению приложен файл: 0679102_1.xlsx(9.6 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеSTnmsk, здравствуйте. Так нужно?
Код
=СУММЕСЛИ(B$2:N$2;Q2;C$2:O$2)
Посмотрите желтые ячейки в файле.

Автор - Che79
Дата добавления - 11.01.2020 в 15:46
Pelena Дата: Суббота, 11.01.2020, 15:47 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16485
Репутация: 3563 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Можно так
Код
=СУММЕСЛИ(B2:N2;"ГА";C2:O2)
К сообщению приложен файл: 5003847.xlsx(9.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Можно так
Код
=СУММЕСЛИ(B2:N2;"ГА";C2:O2)

Автор - Pelena
Дата добавления - 11.01.2020 в 15:47
Che79 Дата: Суббота, 11.01.2020, 16:01 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1610
Репутация: 299 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Еще вариант, пусть тоже будет
Код
=СУММ(ЕСЛИОШИБКА(C$2:O$2*(B$2:N$2=Q2);))
Формула массива (вводится одновременным нажатием на Ctrl+Shift+Enter)
К сообщению приложен файл: 0679102_2.xlsx(9.6 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЕще вариант, пусть тоже будет
Код
=СУММ(ЕСЛИОШИБКА(C$2:O$2*(B$2:N$2=Q2);))
Формула массива (вводится одновременным нажатием на Ctrl+Shift+Enter)

Автор - Che79
Дата добавления - 11.01.2020 в 16:01
STnmsk Дата: Четверг, 16.01.2020, 08:42 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо всем за помощь!

Воспользовался вот этим вариантом.
Код
=СУММЕСЛИ(B2:N2;"ГА";C2:O2)
 
Ответить
СообщениеСпасибо всем за помощь!

Воспользовался вот этим вариантом.
Код
=СУММЕСЛИ(B2:N2;"ГА";C2:O2)

Автор - STnmsk
Дата добавления - 16.01.2020 в 08:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » найти сумму значений справа от текста (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!