Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение двух массивов с подсчетом совпадений построчно - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух массивов с подсчетом совпадений построчно (Формулы/Formulas)
Сравнение двух массивов с подсчетом совпадений построчно
андрей804 Дата: Воскресенье, 12.01.2020, 23:40 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет! Помогите реализовать алгоритм- необходимо сравнить построчно значения двух массивов(желтый и белый) и в зеленом столбце указать количество совпадений
К сообщению приложен файл: 14-14__.xlsx(11.2 Kb)


ищу, уже почти нашел
 
Ответить
СообщениеВсем привет! Помогите реализовать алгоритм- необходимо сравнить построчно значения двух массивов(желтый и белый) и в зеленом столбце указать количество совпадений

Автор - андрей804
Дата добавления - 12.01.2020 в 23:40
krosav4ig Дата: Воскресенье, 12.01.2020, 23:52 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2323
Репутация: 975 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Добрый вечер
Для N8 массивная формула
Код
=СУММ(СЧЁТЕСЛИ(B8:G8;H8:M8))
К сообщению приложен файл: 14-14_.xlsx(11.9 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
СообщениеДобрый вечер
Для N8 массивная формула
Код
=СУММ(СЧЁТЕСЛИ(B8:G8;H8:M8))

Автор - krosav4ig
Дата добавления - 12.01.2020 в 23:52
андрей804 Дата: Понедельник, 13.01.2020, 00:06 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибки!!! То что нужно!!!!!!!! hands hands :D :D "+" в карму добавил :)


ищу, уже почти нашел
 
Ответить
СообщениеСпасибки!!! То что нужно!!!!!!!! hands hands :D :D "+" в карму добавил :)

Автор - андрей804
Дата добавления - 13.01.2020 в 00:06
андрей804 Дата: Суббота, 11.04.2020, 17:47 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
krosav4ig,
Добрый вечер
Для N8 массивная формула

=СУММ(СЧЁТЕСЛИ(B8:G8;H8:M8))
К сообщению приложен файл: 14-14_.xlsx(11.9 Kb)


Еще раз здравствуйте!
Такой вопрос, почему если применять формулу к массивам с различным количеством столбцов, она перестает работать??? Копирую в другую табл(или даже забиваю вручную), корректирую диапазон и результат становится "0". В чем подвох?


ищу, уже почти нашел
 
Ответить
Сообщениеkrosav4ig,
Добрый вечер
Для N8 массивная формула

=СУММ(СЧЁТЕСЛИ(B8:G8;H8:M8))
К сообщению приложен файл: 14-14_.xlsx(11.9 Kb)


Еще раз здравствуйте!
Такой вопрос, почему если применять формулу к массивам с различным количеством столбцов, она перестает работать??? Копирую в другую табл(или даже забиваю вручную), корректирую диапазон и результат становится "0". В чем подвох?

Автор - андрей804
Дата добавления - 11.04.2020 в 17:47
_Boroda_ Дата: Суббота, 11.04.2020, 21:52 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
андрей804, покажите в файле как есть и как нужно, чтобы было

Да, Вы формулу Красавчика вводите как формулу массива, одновременным нажатием Контрл Шифт Ентер?
Можно чуть переписать и использовать обычный ввод
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B8:G8;H8:M8))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеандрей804, покажите в файле как есть и как нужно, чтобы было

Да, Вы формулу Красавчика вводите как формулу массива, одновременным нажатием Контрл Шифт Ентер?
Можно чуть переписать и использовать обычный ввод
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B8:G8;H8:M8))

Автор - _Boroda_
Дата добавления - 11.04.2020 в 21:52
андрей804 Дата: Вторник, 21.04.2020, 20:39 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Да, Вы формулу Красавчика вводите как формулу массива, одновременным нажатием Контрл Шифт Ентер?

Копировал через клавишу мыши и так же вставлял, или забивал вручную, после чего корректировал диапазон и получался "0".

Можно чуть переписать и использовать обычный ввод

=СУММПРОИЗВ(СЧЁТЕСЛИ(B8:G8;H8:M8))

А так заработало вроде hands hands hands Спасибки, "+" в карму отправил yes


ищу, уже почти нашел
 
Ответить
Сообщение
Да, Вы формулу Красавчика вводите как формулу массива, одновременным нажатием Контрл Шифт Ентер?

Копировал через клавишу мыши и так же вставлял, или забивал вручную, после чего корректировал диапазон и получался "0".

Можно чуть переписать и использовать обычный ввод

=СУММПРОИЗВ(СЧЁТЕСЛИ(B8:G8;H8:M8))

А так заработало вроде hands hands hands Спасибки, "+" в карму отправил yes

Автор - андрей804
Дата добавления - 21.04.2020 в 20:39
андрей804 Дата: Суббота, 02.05.2020, 00:57 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер! Пытаюсь решить еще одну задачку. Необходимо в синем массиве(№3) построчно посчитать количество совпадений(оранжевый столбец), удовлетворяющим нескольким условиям:
- значение ячейки массива должно быть больше значения соответствующей ячейки предъидущей строки (например F3>F2)
- значение ячейки предъидущей строки F2> заданного значения(например 3)
У меня какая-то абракадабра получается, не могу понять вообще что считается
К сообщению приложен файл: 8644375_1_2.xlsx(13.8 Kb)


ищу, уже почти нашел
 
Ответить
СообщениеДобрый вечер! Пытаюсь решить еще одну задачку. Необходимо в синем массиве(№3) построчно посчитать количество совпадений(оранжевый столбец), удовлетворяющим нескольким условиям:
- значение ячейки массива должно быть больше значения соответствующей ячейки предъидущей строки (например F3>F2)
- значение ячейки предъидущей строки F2> заданного значения(например 3)
У меня какая-то абракадабра получается, не могу понять вообще что считается

Автор - андрей804
Дата добавления - 02.05.2020 в 00:57
gling Дата: Суббота, 02.05.2020, 02:01 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2163
Репутация: 540 ±
Замечаний: 0% ±

2010
Так?
Код
=СУММПРОИЗВ((J3:N3>J2:N2)*(J2:N2>3))


ЯД-41001506838083
 
Ответить
СообщениеТак?
Код
=СУММПРОИЗВ((J3:N3>J2:N2)*(J2:N2>3))

Автор - gling
Дата добавления - 02.05.2020 в 02:01
андрей804 Дата: Суббота, 02.05.2020, 03:28 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016


=СУММПРОИЗВ((J3:N3>J2:N2)*(J2:N2>3))


Нет. файл не тот прикрепил я в прошлый раз, кстати. на скриншоте видно, 7>4, а 4>3. Условия выполнены, а совпадение не посчитано. И ниже тоже непонятно, ни одно условие не выполнено, а 1 посчитал. У меня такие же непонятки были.
К сообщению приложен файл: 8513663.jpg(48.9 Kb)


ищу, уже почти нашел
 
Ответить
Сообщение


=СУММПРОИЗВ((J3:N3>J2:N2)*(J2:N2>3))


Нет. файл не тот прикрепил я в прошлый раз, кстати. на скриншоте видно, 7>4, а 4>3. Условия выполнены, а совпадение не посчитано. И ниже тоже непонятно, ни одно условие не выполнено, а 1 посчитал. У меня такие же непонятки были.

Автор - андрей804
Дата добавления - 02.05.2020 в 03:28
андрей804 Дата: Суббота, 02.05.2020, 03:29 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Скрин
К сообщению приложен файл: 7179161.jpg(48.9 Kb)


ищу, уже почти нашел
 
Ответить
СообщениеСкрин

Автор - андрей804
Дата добавления - 02.05.2020 в 03:29
андрей804 Дата: Суббота, 02.05.2020, 03:33 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
файл
К сообщению приложен файл: 1933692.xlsx(14.0 Kb)


ищу, уже почти нашел
 
Ответить
Сообщениефайл

Автор - андрей804
Дата добавления - 02.05.2020 в 03:33
gling Дата: Суббота, 02.05.2020, 08:03 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 2163
Репутация: 540 ±
Замечаний: 0% ±

2010
Цитата андрей804, 02.05.2020 в 03:28, в сообщении № 9 ()
У меня такие же непонятки были.
Понятное дело, вы в формуле сравниваете 2 и 3 строки а 7 выделили в 4 строке. Для 4 строки результат смотрите в Q5. Формула которая на скрине должна находиться в ячейке Q3.
К сообщению приложен файл: 5322303.xlsx(14.8 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Суббота, 02.05.2020, 08:09
 
Ответить
Сообщение
Цитата андрей804, 02.05.2020 в 03:28, в сообщении № 9 ()
У меня такие же непонятки были.
Понятное дело, вы в формуле сравниваете 2 и 3 строки а 7 выделили в 4 строке. Для 4 строки результат смотрите в Q5. Формула которая на скрине должна находиться в ячейке Q3.

Автор - gling
Дата добавления - 02.05.2020 в 08:03
андрей804 Дата: Суббота, 02.05.2020, 14:46 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Понятное дело, вы в формуле сравниваете 2 и 3 строки а 7 выделили в 4 строке. Для 4 строки результат смотрите в Q5. Формула которая на скрине должна находиться в ячейке Q3.

Вот я затупил....)))

спасибо, gling. И "+" в карму hands hands hands


ищу, уже почти нашел
 
Ответить
Сообщение
Понятное дело, вы в формуле сравниваете 2 и 3 строки а 7 выделили в 4 строке. Для 4 строки результат смотрите в Q5. Формула которая на скрине должна находиться в ячейке Q3.

Вот я затупил....)))

спасибо, gling. И "+" в карму hands hands hands

Автор - андрей804
Дата добавления - 02.05.2020 в 14:46
Hugo Дата: Суббота, 02.05.2020, 14:54 | Сообщение № 14
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3070
Репутация: 662 ±
Замечаний: 0% ±

андрей804, я думаю что Вы так и не поняли что такое формула массива и как она вводится. А это полезное знание.


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069
 
Ответить
Сообщениеандрей804, я думаю что Вы так и не поняли что такое формула массива и как она вводится. А это полезное знание.

Автор - Hugo
Дата добавления - 02.05.2020 в 14:54
андрей804 Дата: Суббота, 02.05.2020, 15:14 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Hugo, не вгоняйте меня в комплексы ))) Я понимаю логику формул, но в плане формул и их написания, знаний у меня действительно не достаточно. Сначала пробую сам разобраться, если что-то не получается иду за помощью.


ищу, уже почти нашел
 
Ответить
СообщениеHugo, не вгоняйте меня в комплексы ))) Я понимаю логику формул, но в плане формул и их написания, знаний у меня действительно не достаточно. Сначала пробую сам разобраться, если что-то не получается иду за помощью.

Автор - андрей804
Дата добавления - 02.05.2020 в 15:14
Hugo Дата: Суббота, 02.05.2020, 15:16 | Сообщение № 16
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3070
Репутация: 662 ±
Замечаний: 0% ±

Ещё раз продублирую то, что как мне кажется Вы не заметили:
Да, Вы формулу Красавчика вводите как формулу массива, одновременным нажатием Контрл Шифт Ентер?


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069
 
Ответить
СообщениеЕщё раз продублирую то, что как мне кажется Вы не заметили:
Да, Вы формулу Красавчика вводите как формулу массива, одновременным нажатием Контрл Шифт Ентер?

Автор - Hugo
Дата добавления - 02.05.2020 в 15:16
андрей804 Дата: Суббота, 02.05.2020, 22:46 | Сообщение № 17
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Я это заметил, но не понял в чем нюанс


ищу, уже почти нашел
 
Ответить
СообщениеЯ это заметил, но не понял в чем нюанс

Автор - андрей804
Дата добавления - 02.05.2020 в 22:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух массивов с подсчетом совпадений построчно (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!