Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР и сумм строк начинающихся с 11 и имеющие 4 цифры. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР и сумм строк начинающихся с 11 и имеющие 4 цифры. (Формулы/Formulas)
ВПР и сумм строк начинающихся с 11 и имеющие 4 цифры.
Kaiyr Дата: Понедельник, 13.01.2020, 08:10 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Как сделать что бы ВПР делал сумму строк начинающихся с 11 и имеющие 4 цифры? Пример прикреплен.

Еще вопрос как по ВПР найти коды 643 и поставить сумму их второго столбца.
К сообщению приложен файл: 9888270.xlsx(12.5 Kb)


Активный участник Википедии, могу проконсультировать. Также по казахской генеалогии и программам.

Сообщение отредактировал Kaiyr - Понедельник, 13.01.2020, 08:26
 
Ответить
СообщениеДобрый день! Как сделать что бы ВПР делал сумму строк начинающихся с 11 и имеющие 4 цифры? Пример прикреплен.

Еще вопрос как по ВПР найти коды 643 и поставить сумму их второго столбца.

Автор - Kaiyr
Дата добавления - 13.01.2020 в 08:10
Pelena Дата: Понедельник, 13.01.2020, 08:27 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15023
Репутация: 3283 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Вариант
Код
=СУММЕСЛИМН(ИНДЕКС($B$4:$G$32;0;ПОИСКПОЗ(K$3;$B$3:$G$3;0));$A$4:$A$32;$I5)
К сообщению приложен файл: 7298600.xlsx(13.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Вариант
Код
=СУММЕСЛИМН(ИНДЕКС($B$4:$G$32;0;ПОИСКПОЗ(K$3;$B$3:$G$3;0));$A$4:$A$32;$I5)

Автор - Pelena
Дата добавления - 13.01.2020 в 08:27
Nic70y Дата: Понедельник, 13.01.2020, 08:30 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 5815
Репутация: 1273 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММЕСЛИ($A$4:$A$32;$I5;B$4:B$32)
только в столбце А везде должен быть текст
К сообщению приложен файл: 9945599.xlsx(13.0 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=СУММЕСЛИ($A$4:$A$32;$I5;B$4:B$32)
только в столбце А везде должен быть текст

Автор - Nic70y
Дата добавления - 13.01.2020 в 08:30
китин Дата: Понедельник, 13.01.2020, 08:45 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 6063
Репутация: 938 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а без ВПР можно?
Код
=СУММПРОИЗВ($B$4:$G$32*(ЛЕВБ($A$4:$A$32;2)="11")*($B$3:$G$3=K$3))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа без ВПР можно?
Код
=СУММПРОИЗВ($B$4:$G$32*(ЛЕВБ($A$4:$A$32;2)="11")*($B$3:$G$3=K$3))

Автор - китин
Дата добавления - 13.01.2020 в 08:45
bmv98rus Дата: Понедельник, 13.01.2020, 09:25 | Сообщение № 5
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2895
Репутация: 501 ±
Замечаний: 0% ±

Excel 2013/2016
Для разнообразия паразтититруя на вариантe #2
Код
=SUMIF($A$4:$A$32;$I5;INDEX($B$4:$G$32;;RIGHT(K$3)))

Естественно с ограничением по годам.
или
Код
=SUMIF($A$4:$A$32;$I5;INDEX($B$4:$G$32;;K$3-2010))


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Понедельник, 13.01.2020, 09:29
 
Ответить
СообщениеДля разнообразия паразтититруя на вариантe #2
Код
=SUMIF($A$4:$A$32;$I5;INDEX($B$4:$G$32;;RIGHT(K$3)))

Естественно с ограничением по годам.
или
Код
=SUMIF($A$4:$A$32;$I5;INDEX($B$4:$G$32;;K$3-2010))

Автор - bmv98rus
Дата добавления - 13.01.2020 в 09:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР и сумм строк начинающихся с 11 и имеющие 4 цифры. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!