Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение значений в массиве - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение значений в массиве (Формулы/Formulas)
Сравнение значений в массиве
Tkach93 Дата: Понедельник, 13.01.2020, 16:12 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток. Подскажите пожалуйста как будет выглядеть формула если нужно сравнить два массива построчно на больше/меньше и вывести количество ячеек соответствующих заданному критерию? Пример в массиве А числа 1 2 3, в массиве Б числа 2 2 2, нужно узнать сколько чисел в массиве больше соответствующих чисел в массиве Б. В этом примере получается что только число в 3 строке массива А больше числа в 3 строке массива Б
 
Ответить
СообщениеДоброго времени суток. Подскажите пожалуйста как будет выглядеть формула если нужно сравнить два массива построчно на больше/меньше и вывести количество ячеек соответствующих заданному критерию? Пример в массиве А числа 1 2 3, в массиве Б числа 2 2 2, нужно узнать сколько чисел в массиве больше соответствующих чисел в массиве Б. В этом примере получается что только число в 3 строке массива А больше числа в 3 строке массива Б

Автор - Tkach93
Дата добавления - 13.01.2020 в 16:12
Nic70y Дата: Понедельник, 13.01.2020, 16:34 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6313
Репутация: 1393 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММПРОИЗВ(--(A1:A3>B1:B3))


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--(A1:A3>B1:B3))

Автор - Nic70y
Дата добавления - 13.01.2020 в 16:34
Tkach93 Дата: Понедельник, 13.01.2020, 16:40 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Tkach93, Благодарю, а подскажите какой смысл несет проставление двух минусов, так как я пробовал уже эту формулу, но без минусов и она выводила значение 0?
 
Ответить
СообщениеTkach93, Благодарю, а подскажите какой смысл несет проставление двух минусов, так как я пробовал уже эту формулу, но без минусов и она выводила значение 0?

Автор - Tkach93
Дата добавления - 13.01.2020 в 16:40
Nic70y Дата: Понедельник, 13.01.2020, 16:41 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6313
Репутация: 1393 ±
Замечаний: 0% ±

ru13;10;03
--ИСТИНА = 1
--ЛОЖЬ = 0


Яндекс Деньги 41001841029809
 
Ответить
Сообщение--ИСТИНА = 1
--ЛОЖЬ = 0

Автор - Nic70y
Дата добавления - 13.01.2020 в 16:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение значений в массиве (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!