Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет комбинаций из обновляющихся данных - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет комбинаций из обновляющихся данных (Формулы/Formulas)
Подсчет комбинаций из обновляющихся данных
ddmitry Дата: Четверг, 16.01.2020, 22:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Есть таблица, где постепенно добавляются личные коды персонала (1234.2578,2422 и т.д.) Помогите, пожалуйста, как можно сделать чтобы во второй таблице - в первом столбце собирались все варианты личных кодов, которое есть и появятся в таблице 1, а во второй столбце считалось число таких комбинаций в таблице 1. Пример в приложении
К сообщению приложен файл: 3594623.xlsx(10.0 Kb)


Дмитрий
 
Ответить
СообщениеЕсть таблица, где постепенно добавляются личные коды персонала (1234.2578,2422 и т.д.) Помогите, пожалуйста, как можно сделать чтобы во второй таблице - в первом столбце собирались все варианты личных кодов, которое есть и появятся в таблице 1, а во второй столбце считалось число таких комбинаций в таблице 1. Пример в приложении

Автор - ddmitry
Дата добавления - 16.01.2020 в 22:44
Che79 Дата: Пятница, 17.01.2020, 00:10 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1649
Репутация: 306 ±
Замечаний: 0% ±

2013 Win, 365 Mac
И Вам здравствуйте. Так нужно?
Уникальные коды
Формула массива (ввод Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$8;ПОИСКПОЗ(;СЧЁТЕСЛИ($G$1:G1;$A$2:$A$8);));"")
Их количество
Код
=ЕСЛИ(A2="";"";СЧЁТЕСЛИ(A$2:A$8;G2))
И в качестве рекомендаций - избавляйтесь в файле от объединенных ячеек
К сообщению приложен файл: 3594623_1.xlsx(11.5 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Пятница, 17.01.2020, 00:11
 
Ответить
СообщениеИ Вам здравствуйте. Так нужно?
Уникальные коды
Формула массива (ввод Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$8;ПОИСКПОЗ(;СЧЁТЕСЛИ($G$1:G1;$A$2:$A$8);));"")
Их количество
Код
=ЕСЛИ(A2="";"";СЧЁТЕСЛИ(A$2:A$8;G2))
И в качестве рекомендаций - избавляйтесь в файле от объединенных ячеек

Автор - Che79
Дата добавления - 17.01.2020 в 00:10
Xenus91 Дата: Пятница, 17.01.2020, 01:00 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 11 ±
Замечаний: 0% ±

Excel 2016
ddmitry, кажется работа для сводной таблицы, при измененной структуре
К сообщению приложен файл: _3594623-1.xlsx(13.8 Kb)
 
Ответить
Сообщениеddmitry, кажется работа для сводной таблицы, при измененной структуре

Автор - Xenus91
Дата добавления - 17.01.2020 в 01:00
Kostya_Ye Дата: Пятница, 17.01.2020, 16:41 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 271
Репутация: 228 ±
Замечаний: 0% ±

Excel 2016
ddmitry,
ну и Power Query для комплекта
К сообщению приложен файл: 3073689.xlsx(21.8 Kb)
 
Ответить
Сообщениеddmitry,
ну и Power Query для комплекта

Автор - Kostya_Ye
Дата добавления - 17.01.2020 в 16:41
ddmitry Дата: Понедельник, 20.01.2020, 21:05 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Che79, спасибо огромное


Дмитрий
 
Ответить
СообщениеChe79, спасибо огромное

Автор - ddmitry
Дата добавления - 20.01.2020 в 21:05
ddmitry Дата: Понедельник, 20.01.2020, 21:06 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Xenus91, спасибо


Дмитрий
 
Ответить
СообщениеXenus91, спасибо

Автор - ddmitry
Дата добавления - 20.01.2020 в 21:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет комбинаций из обновляющихся данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!