Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Правильно вытащить числа из текста и подчитать их количество - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Правильно вытащить числа из текста и подчитать их количество (Формулы/Formulas)
Правильно вытащить числа из текста и подчитать их количество
Ericbek Дата: Суббота, 18.01.2020, 09:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003/2007/2010 и 2013
Приветствую всех пользователей и гостей форума!

В файле имеются данные тиражей с выпавшими числами.
Вытащил номер и дату тиража.
Затем вытащил числа из текста.
И после всего этого подсчитал количество выпавших чисел (отдельно по номеру чисел и по всем тиражам).
Использованные мной формулы не дали мне корректного результата.

Код
=ЛЕВСИМВ(ПРАВСИМВ(B9; 18); 4)


Код
=СЧЁТЕСЛИ($G$9:$G$490; O9)


Данные имеют следуюший вид
1) Тираж: "№ 482 от 04.01.2020"

2) Выпавшие числа: "32   16   7   1   10  "

Кавычек нет. Присутствуют до двух лишних пробелов.

Подскажите пожалуйста более результативные и правильные решения данной задачи!
К сообщению приложен файл: Loto.zip(74.0 Kb)


Сообщение отредактировал Ericbek - Суббота, 18.01.2020, 10:37
 
Ответить
СообщениеПриветствую всех пользователей и гостей форума!

В файле имеются данные тиражей с выпавшими числами.
Вытащил номер и дату тиража.
Затем вытащил числа из текста.
И после всего этого подсчитал количество выпавших чисел (отдельно по номеру чисел и по всем тиражам).
Использованные мной формулы не дали мне корректного результата.

Код
=ЛЕВСИМВ(ПРАВСИМВ(B9; 18); 4)


Код
=СЧЁТЕСЛИ($G$9:$G$490; O9)


Данные имеют следуюший вид
1) Тираж: "№ 482 от 04.01.2020"

2) Выпавшие числа: "32   16   7   1   10  "

Кавычек нет. Присутствуют до двух лишних пробелов.

Подскажите пожалуйста более результативные и правильные решения данной задачи!

Автор - Ericbek
Дата добавления - 18.01.2020 в 09:30
Pelena Дата: Суббота, 18.01.2020, 09:46 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Ericbek, оформите формулы тегами с помощью кнопки fx в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеEricbek, оформите формулы тегами с помощью кнопки fx в режиме правки поста

Автор - Pelena
Дата добавления - 18.01.2020 в 09:46
Ericbek Дата: Суббота, 18.01.2020, 10:38 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003/2007/2010 и 2013
Pelena, понял! Сделал.
 
Ответить
СообщениеPelena, понял! Сделал.

Автор - Ericbek
Дата добавления - 18.01.2020 в 10:38
Nic70y Дата: Суббота, 18.01.2020, 10:54 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
Код
=--ПСТР(СЖПРОБЕЛЫ(ПОДСТАВИТЬ($C9;СИМВОЛ(160);" "));ПОИСК("\";ПОДСТАВИТЬ(" "&СЖПРОБЕЛЫ(ПОДСТАВИТЬ($C9;СИМВОЛ(160);" "));" ";"\";СТОЛБЕЦ(A1)));2)
в G9:K490
АпдЭйт
Код
=СЧЁТЕСЛИ()
в Вашем случае как массивную вводить не нужно.


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Суббота, 18.01.2020, 10:57
 
Ответить
Сообщение
Код
=--ПСТР(СЖПРОБЕЛЫ(ПОДСТАВИТЬ($C9;СИМВОЛ(160);" "));ПОИСК("\";ПОДСТАВИТЬ(" "&СЖПРОБЕЛЫ(ПОДСТАВИТЬ($C9;СИМВОЛ(160);" "));" ";"\";СТОЛБЕЦ(A1)));2)
в G9:K490
АпдЭйт
Код
=СЧЁТЕСЛИ()
в Вашем случае как массивную вводить не нужно.

Автор - Nic70y
Дата добавления - 18.01.2020 в 10:54
Pelena Дата: Суббота, 18.01.2020, 10:59 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Если сами числа разделены правильно, то можно
Код
=СЧЁТЕСЛИ(G$9:G$490; "*"&$O9&"*")


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЕсли сами числа разделены правильно, то можно
Код
=СЧЁТЕСЛИ(G$9:G$490; "*"&$O9&"*")

Автор - Pelena
Дата добавления - 18.01.2020 в 10:59
Nic70y Дата: Суббота, 18.01.2020, 11:03 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
то можно
думаю, что нет.
*1* = 11, 12, 13 и т.д


ЮMoney 41001841029809
 
Ответить
Сообщение
то можно
думаю, что нет.
*1* = 11, 12, 13 и т.д

Автор - Nic70y
Дата добавления - 18.01.2020 в 11:03
Ericbek Дата: Суббота, 18.01.2020, 11:40 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003/2007/2010 и 2013
Nic70y, Ваша формула подошла. Только почему-то суммы выпавших чисел найденных по столбцу и по нескольким стобцам не совпадают.

Число №1 по количеству раздельно найденных по каждому столбцу (результаты в столбцах P, Q, R, S, T) составляет 57 штук.
А по количеству найденных сразу по нескольким столбцам (G, H, I, J, K) составляет 63 штук.

Форматы столбцов одинаковые. В чём может быть ошибка?
К сообщению приложен файл: Loto_2.zip(91.8 Kb)
 
Ответить
СообщениеNic70y, Ваша формула подошла. Только почему-то суммы выпавших чисел найденных по столбцу и по нескольким стобцам не совпадают.

Число №1 по количеству раздельно найденных по каждому столбцу (результаты в столбцах P, Q, R, S, T) составляет 57 штук.
А по количеству найденных сразу по нескольким столбцам (G, H, I, J, K) составляет 63 штук.

Форматы столбцов одинаковые. В чём может быть ошибка?

Автор - Ericbek
Дата добавления - 18.01.2020 в 11:40
Nic70y Дата: Суббота, 18.01.2020, 11:49 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
держите
К сообщению приложен файл: Loto.xlsx(85.3 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениедержите

Автор - Nic70y
Дата добавления - 18.01.2020 в 11:49
Ericbek Дата: Суббота, 18.01.2020, 12:01 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003/2007/2010 и 2013
Nic70y, большое спасибо! Благодарю Вас и Pelena за участие и оказанную помощь!
 
Ответить
СообщениеNic70y, большое спасибо! Благодарю Вас и Pelena за участие и оказанную помощь!

Автор - Ericbek
Дата добавления - 18.01.2020 в 12:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Правильно вытащить числа из текста и подчитать их количество (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!