Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск-замена на актуальную дату между листам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск-замена на актуальную дату между листам (Формулы/Formulas)
Поиск-замена на актуальную дату между листам
SonG Дата: Воскресенье, 19.01.2020, 21:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Приветствую!
Подскажите пожалуйста решение для подобной задачи.
В Листе "Январь" (будут и другие месяцы), вписываются данные в столбец. Хочется чтобы последняя дата, которая всегда будет повышаться до конца месяца, автоматически вписывалась в поле той фамилии, перед которой она вписана
:fear:

Лучше посмотреть вложение т.к. словами пока тяжело сформулировать задачу)
К сообщению приложен файл: 0017704.xlsx(12.7 Kb)


Сообщение отредактировал SonG - Воскресенье, 19.01.2020, 21:13
 
Ответить
СообщениеПриветствую!
Подскажите пожалуйста решение для подобной задачи.
В Листе "Январь" (будут и другие месяцы), вписываются данные в столбец. Хочется чтобы последняя дата, которая всегда будет повышаться до конца месяца, автоматически вписывалась в поле той фамилии, перед которой она вписана
:fear:

Лучше посмотреть вложение т.к. словами пока тяжело сформулировать задачу)

Автор - SonG
Дата добавления - 19.01.2020 в 21:11
Che79 Дата: Воскресенье, 19.01.2020, 21:15 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1649
Репутация: 306 ±
Замечаний: 0% ±

2013 Win, 365 Mac
И Вам здравствуйте! Видимо, вложение было более 100 кб, продублируйте.
UPD
Файл выложили, но лично мне понятней не стало. Нарисуйте вручную в файле какой результат Вы ожидаете получить?


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Воскресенье, 19.01.2020, 21:21
 
Ответить
СообщениеИ Вам здравствуйте! Видимо, вложение было более 100 кб, продублируйте.
UPD
Файл выложили, но лично мне понятней не стало. Нарисуйте вручную в файле какой результат Вы ожидаете получить?

Автор - Che79
Дата добавления - 19.01.2020 в 21:15
SonG Дата: Воскресенье, 19.01.2020, 21:43 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Нарисуйте вручную в файле какой результат Вы ожидаете получить?

Выделил зелёным на первом листе
К сообщению приложен файл: 2409363.xlsx(12.7 Kb)
 
Ответить
Сообщение
Нарисуйте вручную в файле какой результат Вы ожидаете получить?

Выделил зелёным на первом листе

Автор - SonG
Дата добавления - 19.01.2020 в 21:43
Che79 Дата: Воскресенье, 19.01.2020, 21:58 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1649
Репутация: 306 ±
Замечаний: 0% ±

2013 Win, 365 Mac
SonG, так нужно?
Код
=ПРОСМОТР(;-1/(Январь!C2:C100=A2);Январь!A2:A100)
Желтые ячейки на первом листе. Красным на листе Январь контрольная проверка формулы вручную)
К сообщению приложен файл: 2409363_1.xlsx(13.0 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеSonG, так нужно?
Код
=ПРОСМОТР(;-1/(Январь!C2:C100=A2);Январь!A2:A100)
Желтые ячейки на первом листе. Красным на листе Январь контрольная проверка формулы вручную)

Автор - Che79
Дата добавления - 19.01.2020 в 21:58
SonG Дата: Воскресенье, 19.01.2020, 22:19 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Che79, Да, именно так)
Только есть 2 вопроса:
1. Получается что он берёт данные по возрастанию самой даты, а по порядковому количеству (но это не критично совсем). Как сюда добавить условие "Если искомая дата на листах > чем была, то ставим её" ?
2. Если добавляется лист "Февраль", "Март", и т.д., как быть тогда?

Выделил красным примеры
К сообщению приложен файл: 2409363_2.xlsx(15.1 Kb)
 
Ответить
СообщениеChe79, Да, именно так)
Только есть 2 вопроса:
1. Получается что он берёт данные по возрастанию самой даты, а по порядковому количеству (но это не критично совсем). Как сюда добавить условие "Если искомая дата на листах > чем была, то ставим её" ?
2. Если добавляется лист "Февраль", "Март", и т.д., как быть тогда?

Выделил красным примеры

Автор - SonG
Дата добавления - 19.01.2020 в 22:19
Che79 Дата: Воскресенье, 19.01.2020, 22:56 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1649
Репутация: 306 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Как сюда добавить условие

Если добавляется лист

С этого и надо было начинать, прописать все возможные случаи. Вот вариант к п.1 Формула массива (вводится одновременным нажатием Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(МАКС(ЕСЛИ(Январь!$C$2:$C$100=A2;Январь!$A$2:$A$100));"")
К сообщению приложен файл: 2409363_4.xlsx(14.5 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
Как сюда добавить условие

Если добавляется лист

С этого и надо было начинать, прописать все возможные случаи. Вот вариант к п.1 Формула массива (вводится одновременным нажатием Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(МАКС(ЕСЛИ(Январь!$C$2:$C$100=A2;Январь!$A$2:$A$100));"")

Автор - Che79
Дата добавления - 19.01.2020 в 22:56
SonG Дата: Воскресенье, 19.01.2020, 23:24 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вот вариант к п.1

Супер!) По п.1 всё топчик hands )) Спасибо большое
 
Ответить
Сообщение
Вот вариант к п.1

Супер!) По п.1 всё топчик hands )) Спасибо большое

Автор - SonG
Дата добавления - 19.01.2020 в 23:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск-замена на актуальную дату между листам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!