Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет ячеек в диапазоне дат с учетом выбора ячейки сравнен - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет ячеек в диапазоне дат с учетом выбора ячейки сравнен (Формулы/Formulas)
Подсчет ячеек в диапазоне дат с учетом выбора ячейки сравнен
ipkiller Дата: Вторник, 21.01.2020, 10:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
Во вложении файл.
изначально "лист1" это внешние данные подгружаемые из другого файла, а значит править или что то считать на нем нельзя. количество строк все время разное
дальше надо понять сколько продуктов на какую дату актуальны по техподдержки
Для этого на ссумировать значения лист1!Е:Е
при условии что дата столбца А лист2 попадает в диапазон между
лист1!В:В и наибольшую из лист1!с:с или лист1!d:d

такое вообще возможно?
К сообщению приложен файл: test.xlsx(47.9 Kb)


Сообщение отредактировал ipkiller - Вторник, 21.01.2020, 10:02
 
Ответить
СообщениеВо вложении файл.
изначально "лист1" это внешние данные подгружаемые из другого файла, а значит править или что то считать на нем нельзя. количество строк все время разное
дальше надо понять сколько продуктов на какую дату актуальны по техподдержки
Для этого на ссумировать значения лист1!Е:Е
при условии что дата столбца А лист2 попадает в диапазон между
лист1!В:В и наибольшую из лист1!с:с или лист1!d:d

такое вообще возможно?

Автор - ipkiller
Дата добавления - 21.01.2020 в 10:00
Pelena Дата: Вторник, 21.01.2020, 11:57 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
Такой вариант
Код
=СУММПРОИЗВ(Лист1!$E$2:$E$5000*(Лист1!$B$2:$B$5000<=$A3)*((Лист1!$C$2:$C$5000+ТЕКСТ(Лист1!$D$2:$D$5000-Лист1!$C$2:$C$5000;"0;\0"))>=$A3)*ЕЧИСЛО(ПОИСК(Лист2!$B$1;Лист1!$A$2:$A$5000)))
К сообщению приложен файл: 4935228.xlsx(48.0 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеТакой вариант
Код
=СУММПРОИЗВ(Лист1!$E$2:$E$5000*(Лист1!$B$2:$B$5000<=$A3)*((Лист1!$C$2:$C$5000+ТЕКСТ(Лист1!$D$2:$D$5000-Лист1!$C$2:$C$5000;"0;\0"))>=$A3)*ЕЧИСЛО(ПОИСК(Лист2!$B$1;Лист1!$A$2:$A$5000)))

Автор - Pelena
Дата добавления - 21.01.2020 в 11:57
ipkiller Дата: Вторник, 21.01.2020, 13:14 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
:'(
Похоже что работает..
но понять что поисхот пока не могу )))))
Спасибо. Буду разбираться!!!!!
hands
 
Ответить
Сообщение:'(
Похоже что работает..
но понять что поисхот пока не могу )))))
Спасибо. Буду разбираться!!!!!
hands

Автор - ipkiller
Дата добавления - 21.01.2020 в 13:14
Pelena Дата: Вторник, 21.01.2020, 13:44 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеКак разобраться в работе сложной формулы

Автор - Pelena
Дата добавления - 21.01.2020 в 13:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет ячеек в диапазоне дат с учетом выбора ячейки сравнен (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!