Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать количество ячеек во временном диапазоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать количество ячеек во временном диапазоне (Формулы/Formulas)
Как посчитать количество ячеек во временном диапазоне
BeastMaster Дата: Среда, 22.01.2020, 11:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день!
Как посчитать количество значений (ячеек) во временных интервалах, например с 9:00:00 до 10:00:00?
Помогите, пожалуйста, уже всю клавиатуру стер пока ответ в интернете искал(((
Файл во вложении
К сообщению приложен файл: report.xlsx(16.4 Kb)


Oleg Yu
 
Ответить
СообщениеДобрый день!
Как посчитать количество значений (ячеек) во временных интервалах, например с 9:00:00 до 10:00:00?
Помогите, пожалуйста, уже всю клавиатуру стер пока ответ в интернете искал(((
Файл во вложении

Автор - BeastMaster
Дата добавления - 22.01.2020 в 11:19
Nic70y Дата: Среда, 22.01.2020, 11:24 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6518
Репутация: 1434 ±
Замечаний: 0% ±

ru13;10;03
Код
=СЧЁТЕСЛИМН(A:A;">="&ЛЕВБ(D2;8);A:A;"<="&ПРАВБ(D2;8))


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИМН(A:A;">="&ЛЕВБ(D2;8);A:A;"<="&ПРАВБ(D2;8))

Автор - Nic70y
Дата добавления - 22.01.2020 в 11:24
BeastMaster Дата: Среда, 22.01.2020, 13:11 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Nic70y, спасибо огромное!!! Нет предела моей благодарности!
С этой формулой я не знаком. Подскажите, пожалуйста, для чего перед ЛЕВБ и ПРАВБ ставится значок &? И что означает 8 в формуле? Я посчитал количество знаков в ячейке D2? Восьмой символ приходится на -
Заранее благодарен Вам за ответ!
Вы мне, правда, очень помогли yes yes yes


Oleg Yu
 
Ответить
СообщениеNic70y, спасибо огромное!!! Нет предела моей благодарности!
С этой формулой я не знаком. Подскажите, пожалуйста, для чего перед ЛЕВБ и ПРАВБ ставится значок &? И что означает 8 в формуле? Я посчитал количество знаков в ячейке D2? Восьмой символ приходится на -
Заранее благодарен Вам за ответ!
Вы мне, правда, очень помогли yes yes yes

Автор - BeastMaster
Дата добавления - 22.01.2020 в 13:11
Nic70y Дата: Среда, 22.01.2020, 13:18 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6518
Репутация: 1434 ±
Замечаний: 0% ±

ru13;10;03
Восьмой символ приходится на -
нет,
на пробел или на цифру, зависит от длины
из ">="&ЛЕВБ(D2;8) получаем ">=9:00:00 " и т.д. соот. и считаем


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Восьмой символ приходится на -
нет,
на пробел или на цифру, зависит от длины
из ">="&ЛЕВБ(D2;8) получаем ">=9:00:00 " и т.д. соот. и считаем

Автор - Nic70y
Дата добавления - 22.01.2020 в 13:18
китин Дата: Среда, 22.01.2020, 13:28 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6289
Репутация: 964 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вариант гораздо длиннее, но подходит для всех версий
Код
=СУММПРОИЗВ(ЕЧИСЛО($A$2:$A$307)*(--ЛЕВБ($D2;ПОИСК("-";$D2)-1)<=$A$2:$A$307)*(--СЖПРОБЕЛЫ(ПОДСТАВИТЬ($D2;ЛЕВБ($D2;ПОИСК("-";$D2));""))>=$A$2:$A$307))
К сообщению приложен файл: 7570671.xlsx(17.4 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениевариант гораздо длиннее, но подходит для всех версий
Код
=СУММПРОИЗВ(ЕЧИСЛО($A$2:$A$307)*(--ЛЕВБ($D2;ПОИСК("-";$D2)-1)<=$A$2:$A$307)*(--СЖПРОБЕЛЫ(ПОДСТАВИТЬ($D2;ЛЕВБ($D2;ПОИСК("-";$D2));""))>=$A$2:$A$307))

Автор - китин
Дата добавления - 22.01.2020 в 13:28
BeastMaster Дата: Четверг, 23.01.2020, 03:47 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Господа, всем огромное спасибо за помощь!!!


Oleg Yu
 
Ответить
СообщениеГоспода, всем огромное спасибо за помощь!!!

Автор - BeastMaster
Дата добавления - 23.01.2020 в 03:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать количество ячеек во временном диапазоне (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!