Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск доли - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск доли (Формулы/Formulas)
Поиск доли
Andreius Дата: Среда, 22.01.2020, 11:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет!

Эксперты, помогите пожалуйста) Надо по каждому магазину найти товары с наибольшим отставанием по доле продаж от доли продаж этого товара по всем магазинам.
К сообщению приложен файл: 3485984.xlsx(8.8 Kb)
 
Ответить
СообщениеВсем привет!

Эксперты, помогите пожалуйста) Надо по каждому магазину найти товары с наибольшим отставанием по доле продаж от доли продаж этого товара по всем магазинам.

Автор - Andreius
Дата добавления - 22.01.2020 в 11:26
YouGreed Дата: Среда, 22.01.2020, 12:13 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 517
Репутация: 109 ±
Замечаний: 0% ±

Excel 2010
Andreius, Немного замудренно. С кучей допстолбцов %)

Код
=ИНДЕКС($A$1:$A$15;ПОИСКПОЗ(НАИБОЛЬШИЙ(($B$1:$B$15=$J2)*$G$1:$G$15;1);$G$1:$G$15;0);1)


Формула массива вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 9218388.xlsx(10.7 Kb)


Сообщение отредактировал YouGreed - Среда, 22.01.2020, 12:14
 
Ответить
СообщениеAndreius, Немного замудренно. С кучей допстолбцов %)

Код
=ИНДЕКС($A$1:$A$15;ПОИСКПОЗ(НАИБОЛЬШИЙ(($B$1:$B$15=$J2)*$G$1:$G$15;1);$G$1:$G$15;0);1)


Формула массива вводится одновременным нажатием Ctrl+Shift+Enter

Автор - YouGreed
Дата добавления - 22.01.2020 в 12:13
Andreius Дата: Среда, 22.01.2020, 12:32 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо) а без допстолбцов не получается?)
 
Ответить
СообщениеСпасибо) а без допстолбцов не получается?)

Автор - Andreius
Дата добавления - 22.01.2020 в 12:32
YouGreed Дата: Среда, 22.01.2020, 12:52 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 517
Репутация: 109 ±
Замечаний: 0% ±

Excel 2010
Andreius, Пока так... Один доп столбец

Код
=ИНДЕКС($A$1:$A$15;ПОИСКПОЗ(НАИБОЛЬШИЙ(($B$1:$B$15=$J2)*($E$1:$E$15-((($B$1:$B$15=$J2)*$C$1:$C$15)/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15)));1);($E$1:$E$15-((($B$1:$B$15=$J2)*$C$1:$C$15)/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15)));0);1)


Формула также массивна
К сообщению приложен файл: 2765066.xlsx(10.2 Kb)
 
Ответить
СообщениеAndreius, Пока так... Один доп столбец

Код
=ИНДЕКС($A$1:$A$15;ПОИСКПОЗ(НАИБОЛЬШИЙ(($B$1:$B$15=$J2)*($E$1:$E$15-((($B$1:$B$15=$J2)*$C$1:$C$15)/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15)));1);($E$1:$E$15-((($B$1:$B$15=$J2)*$C$1:$C$15)/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15)));0);1)


Формула также массивна

Автор - YouGreed
Дата добавления - 22.01.2020 в 12:52
китин Дата: Среда, 22.01.2020, 14:00 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6122
Репутация: 947 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а без допстолбцов не получается?)

дык и без них мона
Код
=ИНДЕКС($A$1:$A$15;ПОИСКПОЗ(МИН(ЕСЛИ((ЕСЛИ($B$1:$B$15=$J2;$C$1:$C$15)/СУММЕСЛИ($B$1:$B$15;$J2;$C$1:$C$15))<>0;(ЕСЛИ($B$1:$B$15=$J2;$C$1:$C$15)/СУММЕСЛИ($B$1:$B$15;$J2;$C$1:$C$15))));(ЕСЛИ($B$1:$B$15=$J2;$C$1:$C$15)/СУММЕСЛИ($B$1:$B$15;$J2;$C$1:$C$15));0))


Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 3699906.xlsx(9.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
а без допстолбцов не получается?)

дык и без них мона
Код
=ИНДЕКС($A$1:$A$15;ПОИСКПОЗ(МИН(ЕСЛИ((ЕСЛИ($B$1:$B$15=$J2;$C$1:$C$15)/СУММЕСЛИ($B$1:$B$15;$J2;$C$1:$C$15))<>0;(ЕСЛИ($B$1:$B$15=$J2;$C$1:$C$15)/СУММЕСЛИ($B$1:$B$15;$J2;$C$1:$C$15))));(ЕСЛИ($B$1:$B$15=$J2;$C$1:$C$15)/СУММЕСЛИ($B$1:$B$15;$J2;$C$1:$C$15));0))


Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 22.01.2020 в 14:00
Andreius Дата: Среда, 22.01.2020, 14:12 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
YouGreed, китин,
Пробовал так, но, если вручную посчитать неправильный результат получается.
У магазин 1 наибольшая доля отставания у моркови.
 
Ответить
СообщениеYouGreed, китин,
Пробовал так, но, если вручную посчитать неправильный результат получается.
У магазин 1 наибольшая доля отставания у моркови.

Автор - Andreius
Дата добавления - 22.01.2020 в 14:12
YouGreed Дата: Среда, 22.01.2020, 14:17 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 517
Репутация: 109 ±
Замечаний: 0% ±

Excel 2010
Andreius, У меня разве не правильная? С одним доп столбцом)

Цитата
дык и без них мона

Я думаю, время использовать Power Query.
Логика у меня верная, но как запихнуть в одну формулу, я не могу додумать.


Сообщение отредактировал YouGreed - Среда, 22.01.2020, 14:22
 
Ответить
СообщениеAndreius, У меня разве не правильная? С одним доп столбцом)

Цитата
дык и без них мона

Я думаю, время использовать Power Query.
Логика у меня верная, но как запихнуть в одну формулу, я не могу додумать.

Автор - YouGreed
Дата добавления - 22.01.2020 в 14:17
Andreius Дата: Среда, 22.01.2020, 14:19 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
YouGreed,
Если с одним, то все окей)
 
Ответить
СообщениеYouGreed,
Если с одним, то все окей)

Автор - Andreius
Дата добавления - 22.01.2020 в 14:19
китин Дата: Среда, 22.01.2020, 14:20 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 6122
Репутация: 947 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
У магазин 1 наибольшая доля отставания у моркови.

да ладно...... проверьте исчё!!!!
К сообщению приложен файл: 6061374.xlsx(9.9 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
У магазин 1 наибольшая доля отставания у моркови.

да ладно...... проверьте исчё!!!!

Автор - китин
Дата добавления - 22.01.2020 в 14:20
Светлый Дата: Среда, 22.01.2020, 14:22 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1425
Репутация: 374 ±
Замечаний: 0% ±

Excel 2010, 2013
Мой вариант массивной формулы:
Код
=ИНДЕКС(A:A;ОСТАТ(МИН(ЕСЛИ(B$1:B$20=J2;ОКРУГЛ(СУММЕСЛИМН(C$1:C$20;A$1:A$20;A$1:A$20;B$1:B$20;J2)/СУММЕСЛИ(A$1:A$20;A$1:A$20;C$1:C$20);6)+СТРОКА($1:$20)%%%%))/1%%%%;100))
*Что-то я замудрил:
Код
=ИНДЕКС(A:A;ОСТАТ(МИН(ЕСЛИ(B$1:B$20=J2;ОКРУГЛ(C$1:C$20/СУММЕСЛИ(A$1:A$20;A$1:A$20;C$1:C$20);6)+СТРОКА($1:$20)%%%%))/1%%%%;100))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 22.01.2020, 14:36
 
Ответить
СообщениеМой вариант массивной формулы:
Код
=ИНДЕКС(A:A;ОСТАТ(МИН(ЕСЛИ(B$1:B$20=J2;ОКРУГЛ(СУММЕСЛИМН(C$1:C$20;A$1:A$20;A$1:A$20;B$1:B$20;J2)/СУММЕСЛИ(A$1:A$20;A$1:A$20;C$1:C$20);6)+СТРОКА($1:$20)%%%%))/1%%%%;100))
*Что-то я замудрил:
Код
=ИНДЕКС(A:A;ОСТАТ(МИН(ЕСЛИ(B$1:B$20=J2;ОКРУГЛ(C$1:C$20/СУММЕСЛИ(A$1:A$20;A$1:A$20;C$1:C$20);6)+СТРОКА($1:$20)%%%%))/1%%%%;100))

Автор - Светлый
Дата добавления - 22.01.2020 в 14:22
YouGreed Дата: Среда, 22.01.2020, 14:44 | Сообщение № 11
Группа: Проверенные
Ранг: Ветеран
Сообщений: 517
Репутация: 109 ±
Замечаний: 0% ±

Excel 2010
Светлый, А если мы, изменим значение Моркови, для первого магазина на 5 единиц, по доле, она будет меньшая все равно, а вот по формулам, уже помидоры у Вас выйдут.

Смотрите вложение.

Если обновить вложение, то все данные поплывут...
К сообщению приложен файл: 2938723.xlsx(11.0 Kb)


Сообщение отредактировал YouGreed - Среда, 22.01.2020, 14:51
 
Ответить
СообщениеСветлый, А если мы, изменим значение Моркови, для первого магазина на 5 единиц, по доле, она будет меньшая все равно, а вот по формулам, уже помидоры у Вас выйдут.

Смотрите вложение.

Если обновить вложение, то все данные поплывут...

Автор - YouGreed
Дата добавления - 22.01.2020 в 14:44
Nic70y Дата: Среда, 22.01.2020, 14:58 | Сообщение № 12
Группа: Друзья
Ранг: Экселист
Сообщений: 5945
Репутация: 1299 ±
Замечаний: 0% ±

ru13;10;03
потомушто все неправильно
К сообщению приложен файл: 5077756.xlsx(9.7 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениепотомушто все неправильно

Автор - Nic70y
Дата добавления - 22.01.2020 в 14:58
YouGreed Дата: Среда, 22.01.2020, 15:39 | Сообщение № 13
Группа: Проверенные
Ранг: Ветеран
Сообщений: 517
Репутация: 109 ±
Замечаний: 0% ±

Excel 2010
Nic70y, Я домучал...

Код
=ИНДЕКС($A$1:$A$15;ПОИСКПОЗ(НАИБОЛЬШИЙ(($B$1:$B$15=$J2)*((СУММЕСЛИ($A$1:$A$15;$A$1:$A$15;$C$1:$C$15)/СУММ($C$1:$C$15))-((($B$1:$B$15=$J2)*$C$1:$C$15)/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15)));1);((СУММЕСЛИ($A$1:$A$15;$A$1:$A$15;$C$1:$C$15)/СУММ($C$1:$C$15))-((($B$1:$B$15=$J2)*$C$1:$C$15)/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15)));0);1)


Напоминаю. Формула массива. Вводится нажатием Ctrl+Shift+Enter одновременно.
Правочка
Код
=ИНДЕКС($A$1:$A$15;ПОИСКПОЗ(МАКС(($B$1:$B$15=$J2)*(СУММЕСЛИ($A$1:$A$15;$A$1:$A$15;$C$1:$C$15)/СУММ($C$1:$C$15))-((($B$1:$B$15=$J2)*$C$1:$C$15)/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15)));(СУММЕСЛИ($A$1:$A$15;$A$1:$A$15;$C$1:$C$15)/СУММ($C$1:$C$15))-((($B$1:$B$15=$J2)*$C$1:$C$15)/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15));0);1)

Убрал лишние скобки, заменил наибольший на Макс

Отдельная благодарность Светлому, за подсказку формирования массива долей по наименованиям без привязки к Магазинам.
[offtop]В плане эргономики, не самый лучший вариант, но решение работает. Все действия последовательны, логичны и обоснованы :D Видимо, вкусный обед, действует благотворно.
К сообщению приложен файл: 0906941.xlsx(10.0 Kb)


Сообщение отредактировал YouGreed - Среда, 22.01.2020, 15:58
 
Ответить
СообщениеNic70y, Я домучал...

Код
=ИНДЕКС($A$1:$A$15;ПОИСКПОЗ(НАИБОЛЬШИЙ(($B$1:$B$15=$J2)*((СУММЕСЛИ($A$1:$A$15;$A$1:$A$15;$C$1:$C$15)/СУММ($C$1:$C$15))-((($B$1:$B$15=$J2)*$C$1:$C$15)/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15)));1);((СУММЕСЛИ($A$1:$A$15;$A$1:$A$15;$C$1:$C$15)/СУММ($C$1:$C$15))-((($B$1:$B$15=$J2)*$C$1:$C$15)/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15)));0);1)


Напоминаю. Формула массива. Вводится нажатием Ctrl+Shift+Enter одновременно.
Правочка
Код
=ИНДЕКС($A$1:$A$15;ПОИСКПОЗ(МАКС(($B$1:$B$15=$J2)*(СУММЕСЛИ($A$1:$A$15;$A$1:$A$15;$C$1:$C$15)/СУММ($C$1:$C$15))-((($B$1:$B$15=$J2)*$C$1:$C$15)/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15)));(СУММЕСЛИ($A$1:$A$15;$A$1:$A$15;$C$1:$C$15)/СУММ($C$1:$C$15))-((($B$1:$B$15=$J2)*$C$1:$C$15)/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15));0);1)

Убрал лишние скобки, заменил наибольший на Макс

Отдельная благодарность Светлому, за подсказку формирования массива долей по наименованиям без привязки к Магазинам.
[offtop]В плане эргономики, не самый лучший вариант, но решение работает. Все действия последовательны, логичны и обоснованы :D Видимо, вкусный обед, действует благотворно.

Автор - YouGreed
Дата добавления - 22.01.2020 в 15:39
Светлый Дата: Среда, 22.01.2020, 20:43 | Сообщение № 14
Группа: Друзья
Ранг: Старожил
Сообщений: 1425
Репутация: 374 ±
Замечаний: 0% ±

Excel 2010, 2013
В плане эргономики, не самый лучший вариант, но решение работает.
Оно же, но немного короче:
Код
=ИНДЕКС(A:A;ОСТАТ(МАКС(ЕСЛИ($B$1:$B$15=$J2;ОКРУГЛ(СУММЕСЛИ($A$1:$A$15;$A$1:$A$15;$C$1:$C$15)/СУММ($C$1:$C$15)-$C$1:$C$15/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15);6)+СТРОКА($1:$15)%%%%))/1%%%%;100))
*Или так:
Код
=ИНДЕКС(A:A;ОСТАТ(МАКС((B$1:B$25=J2)*(ОКРУГЛ(СУММЕСЛИ(A$1:A$25;A$1:A$25;C$1:C$25)/СУММ(C$1:C$25)-C$1:C$25/СУММ((B$1:B$25=J2)*C$1:C$25);6)+СТРОКА($1:$25)%%%%))/1%%%%;100))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 22.01.2020, 20:52
 
Ответить
Сообщение
В плане эргономики, не самый лучший вариант, но решение работает.
Оно же, но немного короче:
Код
=ИНДЕКС(A:A;ОСТАТ(МАКС(ЕСЛИ($B$1:$B$15=$J2;ОКРУГЛ(СУММЕСЛИ($A$1:$A$15;$A$1:$A$15;$C$1:$C$15)/СУММ($C$1:$C$15)-$C$1:$C$15/СУММ(($B$1:$B$15=$J2)*$C$1:$C$15);6)+СТРОКА($1:$15)%%%%))/1%%%%;100))
*Или так:
Код
=ИНДЕКС(A:A;ОСТАТ(МАКС((B$1:B$25=J2)*(ОКРУГЛ(СУММЕСЛИ(A$1:A$25;A$1:A$25;C$1:C$25)/СУММ(C$1:C$25)-C$1:C$25/СУММ((B$1:B$25=J2)*C$1:C$25);6)+СТРОКА($1:$25)%%%%))/1%%%%;100))

Автор - Светлый
Дата добавления - 22.01.2020 в 20:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск доли (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!