Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение реестра такси - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение реестра такси (Формулы/Formulas)
Сравнение реестра такси
komsostav Дата: Среда, 22.01.2020, 15:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
День добрый. Помогите с сравнением и поиском. Нужно, чтобы данные госномера из столбца "реестр" были найдены в столбце "Данные по автомобилям" и подсвечены или как-то ещё обозначены (например в столбце совпадение проставлена 1). Файл как пример, реальное количество строк где-то 5000.
К сообщению приложен файл: ___.xlsx(10.1 Kb)
 
Ответить
СообщениеДень добрый. Помогите с сравнением и поиском. Нужно, чтобы данные госномера из столбца "реестр" были найдены в столбце "Данные по автомобилям" и подсвечены или как-то ещё обозначены (например в столбце совпадение проставлена 1). Файл как пример, реальное количество строк где-то 5000.

Автор - komsostav
Дата добавления - 22.01.2020 в 15:51
YouGreed Дата: Среда, 22.01.2020, 16:13 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 564
Репутация: 119 ±
Замечаний: 0% ±

Excel 2010
komsostav, Как-то так

Код
=СУММ(($D$2:$D$24=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(B2;" ";ПОВТОР(" ";ДЛСТР(B2)));ДЛСТР(B2)*(3-1)+1;ДЛСТР(B2))))*1)


Формула массива, вводится одновременным нажатием Ctrl+Shift+Enter.
К сообщению приложен файл: 8670691.xlsx(12.1 Kb)
 
Ответить
Сообщениеkomsostav, Как-то так

Код
=СУММ(($D$2:$D$24=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(B2;" ";ПОВТОР(" ";ДЛСТР(B2)));ДЛСТР(B2)*(3-1)+1;ДЛСТР(B2))))*1)


Формула массива, вводится одновременным нажатием Ctrl+Shift+Enter.

Автор - YouGreed
Дата добавления - 22.01.2020 в 16:13
Nic70y Дата: Среда, 22.01.2020, 16:25 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6455
Репутация: 1421 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММ(--ЕЧИСЛО(ПОИСК(D$2:D$24;B2)))
она же и в УФ
К сообщению приложен файл: 1649333.xlsx(12.6 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=СУММ(--ЕЧИСЛО(ПОИСК(D$2:D$24;B2)))
она же и в УФ

Автор - Nic70y
Дата добавления - 22.01.2020 в 16:25
komsostav Дата: Среда, 22.01.2020, 17:19 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо, помогло. А как зафиксировать массив в формуле, чтобы при перетаскивании формулы вниз массив не двигался. Значком доллар не получается ).
 
Ответить
СообщениеСпасибо, помогло. А как зафиксировать массив в формуле, чтобы при перетаскивании формулы вниз массив не двигался. Значком доллар не получается ).

Автор - komsostav
Дата добавления - 22.01.2020 в 17:19
Nic70y Дата: Среда, 22.01.2020, 17:23 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 6455
Репутация: 1421 ±
Замечаний: 0% ±

ru13;10;03
так в формулах выше зафиксирован же $
покажите где не получается


Яндекс Деньги 41001841029809

Сообщение отредактировал Nic70y - Среда, 22.01.2020, 17:24
 
Ответить
Сообщениетак в формулах выше зафиксирован же $
покажите где не получается

Автор - Nic70y
Дата добавления - 22.01.2020 в 17:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение реестра такси (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!