Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение по номенклатуре - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение по номенклатуре (Формулы/Formulas)
Сравнение по номенклатуре
Окся Дата: Пятница, 24.01.2020, 13:42 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте уважаемые Гуру Excel , наверное попрошу невозможного и всё таки попробую! Во вложении таблица лист 1_ номенклатура товара название в слолбцах А и B . в листе 2 _другая номенклатура того же товара но забита по другому , есть только сходство нескольких СЛОВ! Вопрос можно ли вывести название продуктов с листа 2 на лист 1 ? По СХОЖЕСТИ НЕКОТОРЫХ СЛОВ , ЦИФР! ЕСТЬ ЛИ ТАКАЯ ВОЛШЕБНАЯ ФОРМУЛА ?

Дело в том что по штрих кодам и кодам мне не сравнить ! ОНИ РАЗНЫЕ!

Наверное прошу невозможного , но очень прошу помочь! Заранее брагодарна!
К сообщению приложен файл: 4539342.xls(32.0 Kb)


(*_*)

Сообщение отредактировал Окся - Пятница, 24.01.2020, 13:45
 
Ответить
СообщениеЗдравствуйте уважаемые Гуру Excel , наверное попрошу невозможного и всё таки попробую! Во вложении таблица лист 1_ номенклатура товара название в слолбцах А и B . в листе 2 _другая номенклатура того же товара но забита по другому , есть только сходство нескольких СЛОВ! Вопрос можно ли вывести название продуктов с листа 2 на лист 1 ? По СХОЖЕСТИ НЕКОТОРЫХ СЛОВ , ЦИФР! ЕСТЬ ЛИ ТАКАЯ ВОЛШЕБНАЯ ФОРМУЛА ?

Дело в том что по штрих кодам и кодам мне не сравнить ! ОНИ РАЗНЫЕ!

Наверное прошу невозможного , но очень прошу помочь! Заранее брагодарна!

Автор - Окся
Дата добавления - 24.01.2020 в 13:42
Serge_007 Дата: Пятница, 24.01.2020, 13:53 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13303
Репутация: ±
Замечаний: ±

Excel 2010
Здраствуйте

По СХОЖЕСТИ НЕКОТОРЫХ СЛОВ , ЦИФР! ЕСТЬ ЛИ ТАКАЯ ВОЛШЕБНАЯ ФОРМУЛА ?
Нет

Придется делать список соответствий, что крайне трудозатратно...


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдраствуйте

По СХОЖЕСТИ НЕКОТОРЫХ СЛОВ , ЦИФР! ЕСТЬ ЛИ ТАКАЯ ВОЛШЕБНАЯ ФОРМУЛА ?
Нет

Придется делать список соответствий, что крайне трудозатратно...

Автор - Serge_007
Дата добавления - 24.01.2020 в 13:53
Светлый Дата: Пятница, 24.01.2020, 13:58 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1432
Репутация: 376 ±
Замечаний: 0% ±

Excel 2010, 2013
Здравствуйте!
Попробуйте установить надстройку Fuzzy Lookup.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЗдравствуйте!
Попробуйте установить надстройку Fuzzy Lookup.

Автор - Светлый
Дата добавления - 24.01.2020 в 13:58
Serge_007 Дата: Пятница, 24.01.2020, 14:01 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13303
Репутация: ±
Замечаний: ±

Excel 2010
Сергей, 100% результата не будет...


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеСергей, 100% результата не будет...

Автор - Serge_007
Дата добавления - 24.01.2020 в 14:01
Светлый Дата: Пятница, 24.01.2020, 14:06 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1432
Репутация: 376 ±
Замечаний: 0% ±

Excel 2010, 2013
100% результата не будет
Хотя бы что-то. А хвосты потом вручную подобрать.


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
100% результата не будет
Хотя бы что-то. А хвосты потом вручную подобрать.

Автор - Светлый
Дата добавления - 24.01.2020 в 14:06
Окся Дата: Пятница, 24.01.2020, 14:26 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо , попробую...


(*_*)
 
Ответить
СообщениеСпасибо , попробую...

Автор - Окся
Дата добавления - 24.01.2020 в 14:26
Светлый Дата: Пятница, 24.01.2020, 14:38 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1432
Репутация: 376 ±
Замечаний: 0% ±

Excel 2010, 2013
А для начала попробуйте вот такую массивную (Ctrl+Shift+Enter) формулу:
Код
=ИНДЕКС(Лист2!A:A;ПРАВБ(МАКС(МУМНОЖ(Ч(ЕЧИСЛО(ПОИСК(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2&" "&B2;"""";);" ";ПОВТОР(" ";99));СТОЛБЕЦ(A:T)*99-98;99));Лист2!A$1:A$30)));ТРАНСП(1^СТОЛБЕЦ(A:T)))*100+СТРОКА($1:$30));2))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеА для начала попробуйте вот такую массивную (Ctrl+Shift+Enter) формулу:
Код
=ИНДЕКС(Лист2!A:A;ПРАВБ(МАКС(МУМНОЖ(Ч(ЕЧИСЛО(ПОИСК(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2&" "&B2;"""";);" ";ПОВТОР(" ";99));СТОЛБЕЦ(A:T)*99-98;99));Лист2!A$1:A$30)));ТРАНСП(1^СТОЛБЕЦ(A:T)))*100+СТРОКА($1:$30));2))

Автор - Светлый
Дата добавления - 24.01.2020 в 14:38
Окся Дата: Пятница, 24.01.2020, 15:08 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Не получается вставить (( пишет ошибку не вставить и за большего уровня сложности чем использует данный формат


(*_*)
 
Ответить
СообщениеНе получается вставить (( пишет ошибку не вставить и за большего уровня сложности чем использует данный формат

Автор - Окся
Дата добавления - 24.01.2020 в 15:08
Светлый Дата: Пятница, 24.01.2020, 19:54 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1432
Репутация: 376 ±
Замечаний: 0% ±

Excel 2010, 2013
и за большего уровня сложности
Пересохраните файл в формате *.xlsx офиса 2007+


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 24.01.2020, 20:20
 
Ответить
Сообщение
и за большего уровня сложности
Пересохраните файл в формате *.xlsx офиса 2007+

Автор - Светлый
Дата добавления - 24.01.2020 в 19:54
Окся Дата: Вторник, 28.01.2020, 14:06 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вы волшебник ! Всё получилось. СПАСИБО ВАМ ОГРОМНОЕ!!! hands hands hands hands hands


(*_*)
 
Ответить
СообщениеВы волшебник ! Всё получилось. СПАСИБО ВАМ ОГРОМНОЕ!!! hands hands hands hands hands

Автор - Окся
Дата добавления - 28.01.2020 в 14:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение по номенклатуре (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!